
<!DOCTYPE html>

<!--[if lt IE 7]><html  xmlns:og="//ogp.me/ns#" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html  xmlns:og="//ogp.me/ns#" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html  xmlns:og="//ogp.me/ns#" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html  xmlns:og="//ogp.me/ns#" class="no-js"><!--<![endif]-->

	<head>

		<meta charset="utf-8">

		<!-- Google Chrome Frame for IE -->
		<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]-->

        <title>Riverdale S03E22 Review: Survive the Night – A very entertaining finale!</title>
        <link href='https://fonts.googleapis.com/css?family=Knewave' rel='stylesheet' type='text/css'>
		
		<!-- mobile meta -->
                    <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
        
		<link rel="shortcut icon" href="/favicon-16x16.png">

		<link rel="pingback" href="https://www.cultofwhatever.com/xmlrpc.php">

		<!-- Holding main menu -->
		
		<!-- head functions -->
			<script>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</script>
	<style>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</style>
	<div class="consentReady_container_full consentReady_bottom consent_ready_popup_display" id="consentReady_consent_div">
	    <div class="consentReady_content">

	    <div style="font-weight:bold; font-size:20px;">This website uses cookies</div>
	    <div>
	By continuing to browse or by clicking "Accept Cookies" you agree to the storing of cookies on your browser (1st or 3rd parties) for statistical and marketing purposes. We use these cookies to analyze and improve your user experience and assist in our marketing efforts.</div>

	<div style="margin-top:10px;">
	<div style="
	    display: inline-block;
	    width:100%;
	">
	<label class="consentready_container">Necessary
	  <input type="checkbox" checked="checked" name="consentReady_nec" id="consentReady_nec" disabled>
	  <span class="consentready_checkmark"></span>
	</label>

	<label class="consentready_container">Performance
	  <input type="checkbox"   checked="checked"  name="consentReady_perf" id="consentReady_perf">
	  <span class="consentready_checkmark" ></span>
	</label>

	<label class="consentready_container">Preferences
	  <input type="checkbox"   checked="checked"  name="consentReady_prefs" id="consentReady_prefs">
	  <span class="consentready_checkmark"></span>
	</label>


	<label class="consentready_container">Marketing
	  <input type="checkbox"   checked="checked"  name="consentReady_mkt" id="consentReady_mkt">
	  <span class="consentready_checkmark"></span>
	</label>



	    <div style="
	    display: inline-block;
	    /* text-align: right; */
	    /* left: 0; */
	    float: right;
	"><a class="consentready_cookieinfo_btn" onclick="showCRCookieInfo();">Cookie Info</a>
	<a class="consentready_accept_btn" onclick="consentReady_accept(0, );">I Accept</a></div>

	</div>


	</div>
	<!--<div style="
	    text-align: right;
	    margin-top: -10px;
	"><a style="
	    font-size: 12px;
	    /* text-align: right; */
	">Cookie Info</a></div>-->

	<div class="consent_ready_cookie_more_info" id="consent_ready_cookie_more_info" style="margin-top:10px; margin-bottom:10px; display:none; overflow:auto;">

	        <!-- Tab links -->
	        <div class="consentready_tab">
	          <button class="consentready_tablinks" onclick="consentReady_opentab(event, 'consentready_our_cookies')">Our cookies</button>
	          <button class="consentready_tablinks" onclick="consentReady_opentab(event, 'consentready_cookie_info')">Cookie info</button>
	          <button class="" onclick="consentReady_accept(1);" style="float: right;">Accept all cookies</button>
	        </div>

	        <!-- Tab content -->
	        <div id="consentready_our_cookies" class="active consentready_tabcontent" style="display:block">
	            <div style="display:inline-block; width:100%; margin-bottom:-8px">
	              <div class="consentready_horiz_tab">
	                  <button class="consentready_horiz_tablinks" onclick="consentReady_opentab_horiz(event, 'consentready_tabs_Privacy')">Your Privacy</button>
	                  <button class="consentready_horiz_tablinks" onclick="consentReady_opentab_horiz(event, 'consentready_tabs_Necessary')">Necessary</button>
	                  <button class="consentready_horiz_tablinks" onclick="consentReady_opentab_horiz(event, 'consentready_tabs_Preferences')">Preferences</button>
	                  <button class="consentready_horiz_tablinks" onclick="consentReady_opentab_horiz(event, 'consentready_tabs_Performance')">Performance</button>
	                  <button class="consentready_horiz_tablinks" onclick="consentReady_opentab_horiz(event, 'consentready_tabs_Marketing')">Marketing</button>
	                </div>


	                <div id="consentready_tabs_Privacy" class="active consentready_horiz_tabcontent" style="display:block">
	                  <h3>We Value Your privacy</h3>
	                  <p>
	When you visit any web site, it may store or retrieve information on your browser, mostly in the form of cookies. This information might be about you, your preferences or your device and is mostly used to make the site work as you expect it to. The information does not usually directly identify you, but it can give you a more personalised web experience.
	<br/><br/>
	Because we respect your right to privacy, you can choose not to allow some types of cookies. Click on the different category headings to find out more and change our default settings. However, blocking some types of cookies may impact your experience of the site and the services we are able to offer.
	</p>
	                </div>

	                <div id="consentready_tabs_Necessary" class="consentready_horiz_tabcontent">
	                  <h3>Strictly Necessary Cookies</h3>
	                  <p>These cookies are necessary for the website to function and cannot be switched off in our systems. They are usually only set in response to actions made by you which amount to a request for services, such as setting your privacy preferences, logging in or filling in forms.
	                    <br /><br />
	                    You can set your browser to block or alert you about these cookies, but some parts of the site will not then work. These cookies do not store any personally identifiable information.</p>
	                    	<table class="consentReady_cookies_table">
		<thead>
			<tr>
				<td>Name</td>
				<td>Domain</td>
				<td>Desc </td>
				<td>Expiry</td>
			</tr>
		</thead>
		<tbody>
			<tr>
						<td>crcookieConsent</td>
						<td>.cultofwhatever.com</td>
						<td></td>
						<td>365 days</td>
					</tr><tr>
						<td>PHPSESSID</td>
						<td>.cultofwhatever.com</td>
						<td></td>
						<td>Until browser is closed.</td>
					</tr><tr>
						<td>wordpress_*</td>
						<td>.cultofwhatever.com</td>
						<td></td>
						<td>Up to 1 year.</td>
					</tr><tr>
						<td>wp-*</td>
						<td>.cultofwhatever.com</td>
						<td></td>
						<td>Up to 1 year.</td>
					</tr>		</tbody>

	</table>
		                </div>

	                <div id="consentready_tabs_Preferences" class="consentready_horiz_tabcontent">
	                  <h3>Preferences cookies</h3>
	                  <p>These are the types of cookies that are necessary in order to be authenticated to our website. You cannot authenticate without agreeing to store these cookies. You can set these later on.</p>
	                    	<table class="consentReady_cookies_table">
		<thead>
			<tr>
				<td>Name</td>
				<td>Domain</td>
				<td>Desc </td>
				<td>Expiry</td>
			</tr>
		</thead>
		<tbody>
			<tr>
						<td>comment_*</td>
						<td>.cultofwhatever.com</td>
						<td></td>
						<td>Up to 1 year.</td>
					</tr>		</tbody>

	</table>
		                </div>

	                <div id="consentready_tabs_Performance" class="consentready_horiz_tabcontent">
	                  <h3>Performance cookies</h3>
	                  <p>These cookies allow us to count visits and traffic sources so we can measure and improve the performance of our site. They help us to know which pages are the most and least popular and see how visitors move around the site.<br /><br />
	All information these cookies collect is aggregated and therefore anonymous. If you do not allow these cookies we will not know when you have visited our site, and will not be able to monitor its performance.</p>
	                    	<table class="consentReady_cookies_table">
		<thead>
			<tr>
				<td>Name</td>
				<td>Domain</td>
				<td>Desc </td>
				<td>Expiry</td>
			</tr>
		</thead>
		<tbody>
			<tr>
						<td>__cfduid</td>
						<td>.statcounter.com</td>
						<td></td>
						<td>364 days</td>
					</tr><tr>
						<td>_ga</td>
						<td>.cultofwhatever.com</td>
						<td></td>
						<td>729 days</td>
					</tr><tr>
						<td>_gat_gtag_UA_60765351_1</td>
						<td>.cultofwhatever.com</td>
						<td></td>
						<td>1 minute</td>
					</tr><tr>
						<td>_gid</td>
						<td>.cultofwhatever.com</td>
						<td></td>
						<td>23 hours</td>
					</tr><tr>
						<td>is_unique</td>
						<td>.statcounter.com</td>
						<td></td>
						<td>1824 days</td>
					</tr><tr>
						<td>is_visitor_unique</td>
						<td>.statcounter.com</td>
						<td></td>
						<td>729 days</td>
					</tr><tr>
						<td>sc_is_visitor_unique</td>
						<td>.www.cultofwhatever.com</td>
						<td></td>
						<td>729 days</td>
					</tr><tr>
						<td>uvc</td>
						<td>.addthis.com</td>
						<td></td>
						<td>394 days</td>
					</tr>		</tbody>

	</table>
		                </div>

	                <div id="consentready_tabs_Marketing" class="consentready_horiz_tabcontent">
	                  <h3>Marketing/targeting cookies</h3>
	                  <p>These cookies may be set through our site by our advertising partners. They may be used by those companies to build a profile of your interests and show you relevant adverts on other sites.<br /><br />

	They do not store directly personal information, but are based on uniquely identifying your browser and internet device. If you do not allow these cookies, you will experience less targeted advertising.</p>
	                    	<table class="consentReady_cookies_table">
		<thead>
			<tr>
				<td>Name</td>
				<td>Domain</td>
				<td>Desc </td>
				<td>Expiry</td>
			</tr>
		</thead>
		<tbody>
			<tr>
						<td>__atuvc</td>
						<td>www.cultofwhatever.com</td>
						<td></td>
						<td>394 days</td>
					</tr><tr>
						<td>__atuvs</td>
						<td>www.cultofwhatever.com</td>
						<td></td>
						<td>29 minutes</td>
					</tr><tr>
						<td>bt2</td>
						<td>.addthis.com</td>
						<td></td>
						<td>255 days</td>
					</tr><tr>
						<td>di2</td>
						<td>.addthis.com</td>
						<td></td>
						<td>389 days</td>
					</tr><tr>
						<td>IDE</td>
						<td>.doubleclick.net</td>
						<td></td>
						<td>729 days</td>
					</tr><tr>
						<td>loc</td>
						<td>.addthis.com</td>
						<td></td>
						<td>394 days</td>
					</tr><tr>
						<td>ouid</td>
						<td>.addthis.com</td>
						<td></td>
						<td>389 days</td>
					</tr><tr>
						<td>uid</td>
						<td>.addthis.com</td>
						<td></td>
						<td>389 days</td>
					</tr><tr>
						<td>vc</td>
						<td>.addthis.com</td>
						<td></td>
						<td>389 days</td>
					</tr>		</tbody>

	</table>
		                </div>
	            </div>
	        </div>

	        <div id="consentready_cookie_info" class="consentready_tabcontent">
	            <div class="consentready_tabdiv">
	              <h3>What are cookies?</h3>
	              <p>An HTTP cookie (also called web cookie, Internet cookie, browser cookie, or simply cookie) is a small piece of data sent from a website and stored on the user's computer by the user's web browser while the user is browsing. Cookies were designed to be a reliable mechanism for websites to remember stateful information (such as items added in the shopping cart in an online store) or to record the user's browsing activity (including clicking particular buttons, logging in, or recording which pages were visited in the past). They can also be used to remember arbitrary pieces of information that the user previously entered into form fields such as names, addresses, passwords, and credit card numbers.
	</p>
	          </div>
	        </div>


	</div>


	</div>
	</div>
	

    
<!-- All in One SEO Pack 2.6 by Michael Torbert of Semper Fi Web Design[558,652] -->
<meta name="description"  content="Season 3 of Riverdale ascends tonight and we&#039;re all going to need something a little stronger than maple syrup if we&#039;re going to *electric guitar riff* SURVIVE THE NIGHT." />

<meta name="keywords"  content="riverdale" />

<link rel="canonical" href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Cult of Whatever &raquo; Feed" href="https://www.cultofwhatever.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cult of Whatever &raquo; Comments Feed" href="https://www.cultofwhatever.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cult of Whatever &raquo; Riverdale S03E22 Review: Survive the Night &#8211; A very entertaining finale! Comments Feed" href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.cultofwhatever.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.10"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='login-with-ajax-css'  href='https://www.cultofwhatever.com/wp-content/themes/valenti/plugins/login-with-ajax/widget.css?ver=3.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='disqus_rcw-css'  href='https://www.cultofwhatever.com/wp-content/plugins/disqus-recent-comments-widget/disqus_rcw.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.cultofwhatever.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css?ver=4.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css'  href='https://www.cultofwhatever.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=11.9.1' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='cb-main-stylesheet-css'  href='https://www.cultofwhatever.com/wp-content/themes/valenti/library/css/style.css?ver=3.2' type='text/css' media='all' />
<link rel='stylesheet' id='cb-font-stylesheet-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C700%2C400italic%7COpen+Sans%3A400%2C700%2C400italic&#038;subset=greek%2Cgreek-ext&#038;ver=3.2' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://www.cultofwhatever.com/wp-content/themes/valenti/library/css/fontawesome/css/font-awesome.min.css?ver=4.1.0' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='cb-ie-only-css'  href='https://www.cultofwhatever.com/wp-content/themes/valenti/library/css/ie.css?ver=3.2' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='cb-child-stylesheet-css'  href='https://www.cultofwhatever.com/wp-content/themes/valenti-child/style.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var LWA = {"ajaxurl":"https:\/\/www.cultofwhatever.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/plugins/login-with-ajax/login-with-ajax.js?ver=3.1.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"rest_api":"1","sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/www.cultofwhatever.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","action":"update_views_ajax","ID":"47839","token":"51eefd1c4f","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.1.0.min.js?ver=4.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/www.cultofwhatever.com\/wp-admin\/admin-ajax.php","security":"f1de9bc540","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/www.cultofwhatever.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"11.9.1","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=11.9.1'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/plugins/youtube-embed-plus/scripts/jquery.cookie.min.js?ver=11.9.1'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/modernizr.custom.min.js?ver=2.6.2'></script>
<link rel='https://api.w.org/' href='https://www.cultofwhatever.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.cultofwhatever.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.cultofwhatever.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Game of Thrones S08E05: The Bells &#8211; The Mis-match of the Mad Queens' href='https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/' />
<meta name="generator" content="WordPress 4.9.10" />
<link rel='shortlink' href='https://www.cultofwhatever.com/?p=47839' />
<link rel="alternate" type="application/json+oembed" href="https://www.cultofwhatever.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cultofwhatever.com%2F2019%2F05%2Friverdale-s03e22-review-survive-the-night-a-very-entertaining-finale%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.cultofwhatever.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cultofwhatever.com%2F2019%2F05%2Friverdale-s03e22-review-survive-the-night-a-very-entertaining-finale%2F&#038;format=xml" />

<!-- This site is using AdRotate v3.11.2 Professional to display their advertisements - https://www.adrotateplugin.com/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px 1px 1px 1px; }
	.g-2 { margin:1px 1px 1px 1px; }
	.g-3 { margin:1px 1px 1px 1px; }
	.g-4 { margin:1px 1px 1px 1px; }
	.g-5 { margin:1px 1px 1px 1px; }
	.g-6 { margin:1px 1px 1px 1px; }
	.g-7 { margin:1px 1px 1px 1px; }
	.g-8 { margin:1px 1px 1px 1px; }
	.g-9 { margin:1px 1px 1px 1px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<!-- Fedmich facebook/digg thumbnail v1.15.6 -->
<meta property="og:title" content="Riverdale S03E22 Review: Survive the Night &#8211; A very entertaining finale!">
<meta property="og:site_name" content="Cult of Whatever">
<meta property="og:url" content="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/">
<meta property="og:locale" content="en_us">
<link rel="image_src" href="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-nathalie-boltt-penelope-blossom.jpg" />
<meta property="og:image" content="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-nathalie-boltt-penelope-blossom.jpg" />
<meta property="og:image" content="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica.jpg" />
<meta property="og:image" content="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-lili-reinhart-betty-cooper.jpg" />
<!-- /Fedmich facebook/digg thumbnail -->
<style>.cb-overlay-stars .fa-star, #cb-vote .fa-star, #cb-to-top .fa-long-arrow-up, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, .bbp-submit-wrapper button:visited, .buddypress .cb-cat-header #cb-cat-title a,  .buddypress .cb-cat-header #cb-cat-title a:visited, .woocommerce .star-rating:before, .woocommerce-page .star-rating:before, .woocommerce .star-rating span, .woocommerce-page .star-rating span {
            color:#1a93db;
        }#cb-search-modal .cb-header, .cb-join-modal .cb-header, .lwa .cb-header, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            border-color: #1a93db;
        }.cb-sidebar-widget .cb-sidebar-widget-title, .cb-multi-widget .tabbernav .tabberactive, .cb-author-page .cb-author-details .cb-meta .cb-author-page-contact, .cb-about-page .cb-author-line .cb-author-details .cb-meta .cb-author-page-contact, .cb-page-header, .cb-404-header, .cb-cat-header, #cb-footer #cb-widgets .cb-footer-widget-title span, #wp-calendar caption, .cb-tabs ul .current, #bbpress-forums li.bbp-header, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li.selected, #buddypress div.item-list-tabs ul li.current, #buddypress .item-list-tabs ul li:hover, .woocommerce div.product .woocommerce-tabs ul.tabs li.active {
            border-bottom-color: #1a93db ;
        }#cb-main-menu .current-post-ancestor, #cb-main-menu .current-menu-item, #cb-main-menu .current-menu-ancestor, #cb-main-menu .current-post-parent, #cb-main-menu .current-menu-parent, #cb-main-menu .current_page_item, #cb-main-menu .current-page-ancestor, #cb-main-menu .current-category-ancestor, .cb-review-box .cb-bar .cb-overlay span, #cb-accent-color, .cb-highlight, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            background-color: #1a93db;
        }</style><style type="text/css">
                                                 body, #respond { font-family: 'Open Sans', sans-serif; }
                                                 h1, h2, h3, h4, h5, h6, .h1, .h2, .h3, .h4, .h5, .h6, #cb-nav-bar #cb-main-menu ul li > a, .cb-breaking-news span, .cb-grid-4 h2 a, .cb-grid-5 h2 a, .cb-grid-6 h2 a, .cb-author-posts-count, .cb-author-title, .cb-author-position, .search  .s, .cb-review-box .cb-bar, .cb-review-box .cb-score-box, .cb-review-box .cb-title, #cb-review-title, .cb-title-subtle, #cb-top-menu a, .tabbernav, .cb-byline, #cb-next-link a, #cb-previous-link a, .cb-review-ext-box .cb-score, .tipper-positioner, .cb-caption, .cb-button, #wp-calendar caption, .forum-titles, .bbp-submit-wrapper button, #bbpress-forums li.bbp-header, #bbpress-forums fieldset.bbp-form .bbp-the-content-wrapper input, #bbpress-forums .bbp-forum-title, #bbpress-forums .bbp-topic-permalink, .widget_display_stats dl dt, .cb-lwa-profile .cb-block, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li, #buddypress .activity-list li.load-more, #buddypress a.activity-time-since, #buddypress ul#groups-list li div.meta, .widget.buddypress div.item-options, .cb-activity-stream #buddypress .activity-header .time-since, .cb-font-header, .woocommerce table.shop_table th, .woocommerce-page table.shop_table th, .cb-infinite-scroll a, .cb-no-more-posts { font-family:'Oswald', sans-serif; }
                     </style><link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png">
<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192">
<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96">
<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16">
<link rel="manifest" href="/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="/mstile-144x144.png">
<meta name="theme-color" content="#ffffff">

<!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f2c87727d2c01c3" async="async"></script>
<style type="text/css">#cb-top-menu .cb-breaking-news ul li a { color:#808080; }#cb-nav-logo { margin-right: 100px!important; }</style><!-- end custom css --><meta property="og:image" content="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica.jpg">		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<style>#cb-nav-bar #cb-main-menu .main-nav .menu-item-24169:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169 .cb-sub-menu { background:#faa200!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#faa200!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-41523:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-41523:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-41523 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-41523 .cb-sub-menu { background:#fa0088!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-41523 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#fa0088!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24170:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170 .cb-sub-menu { background:#1a93db!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#1a93db!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24171:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171 .cb-sub-menu { background:#24bc3a!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#24bc3a!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24172:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172 .cb-sub-menu { background:#20007f!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#20007f!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24173:hover,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24173:focus,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24173 .cb-sub-menu li .cb-grandchild-menu,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24173 .cb-sub-menu { background:#c42c2b!important; }
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24173 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#c42c2b!important; }</style><link rel="icon" href="https://www.cultofwhatever.com/wp-content/uploads/2018/05/cropped-cult-of-whatever-icon-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.cultofwhatever.com/wp-content/uploads/2018/05/cropped-cult-of-whatever-icon-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.cultofwhatever.com/wp-content/uploads/2018/05/cropped-cult-of-whatever-icon-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.cultofwhatever.com/wp-content/uploads/2018/05/cropped-cult-of-whatever-icon-512-270x270.png" />
		<!-- end head functions-->

	</head>
		<body class="post-template-default single single-post postid-47839 single-format-standard">
    <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

        
	    <div id="cb-outer-container">
	        <div id="cb-container">
        	<div class="wrap clearfix">
        	<div class="cb-large"><div id="adrotate_widgets-27" class="cb-sidebar-widget widget_adrotate_widgets"><div class="g g-3"><div class="g-single a-26"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- TOP-COW-MatchedContent -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-4708759492629486"
     data-ad-slot="4686766784"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div></div>        	</div>
        </div>
    
    		<div id="cb-container" class="cb-boxed wrap clearfix"  >

                <header class="header clearfix wrap" role="banner">

                        <div class="wrap clearfix">
                                                                            <div id="logo" class="cb-with-large">
                                                <a href="https://www.cultofwhatever.com">
                                                    <img src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo.png" alt="Cult of Whatever logo" width="" height="" data-retina-src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo@2x.png" />
                                                </a>
                                            </div>
                                                        </div>

    				    <nav id="cb-nav-bar" class="clearfix stickybar cb-dark-menu" role="navigation">

                            <div id="cb-search-modal" class="cb-dark-menu">
                        <div class="cb-search-box">
                            <div class="cb-header">
                                <div class="cb-title">Search</div>
                                <div class="cb-close">
                                    <span class="cb-close-modal"><i class="fa fa-times"></i></span>
                                </div>
                            </div><form role="search" method="get" class="cb-search" action="https://www.cultofwhatever.com/">

    <input type="text" class="cb-search-field" placeholder="" value="" name="s" title="">
    <button class="cb-search-submit" type="submit" value=""><i class="fa fa-search"></i></button>

</form></div></div> <div class="wrap clearfix"><div id="cb-main-menu" class="menu-top-navigation-menu-container"><ul class="nav main-nav clearfix"><li id="menu-item-24169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24169"><a href="https://www.cultofwhatever.com/movies/">Movies</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#faa200;">Featured</span></div>
                                        <ul> <li class="cb-article clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2018/12/review-aquaman-is-a-shockingly-great-time/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2018/12/aquaman-poster-2-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2018/12/review-aquaman-is-a-shockingly-great-time/">REVIEW: Aquaman is a shockingly great time</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-12-16">December 16, 2018</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-reviews/" title="View all posts in Movie Reviews">Movie Reviews</a></div></div>
                        </div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#faa200;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2019/05/review-grading-detective-pikachu-on-three-levels/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/pokemon-detective-pikachu-1-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/review-grading-detective-pikachu-on-three-levels/">REVIEW: Grading Detective Pikachu on three levels&#8230;</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-11">May 11, 2019</time></div></div>
                        </div></li> <li class="cb-article-2 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2019/04/review-avengers-endgame-spoiler-filled-observations/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/avengers-endgame-poster-3-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/review-avengers-endgame-spoiler-filled-observations/">REVIEW: Avengers Endgame &#8211; Spoiler-filled observations</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-27">April 27, 2019</time></div></div>
                        </div></li> <li class="cb-article-3 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2019/04/avengers-endgame-is-a-love-letter-to-the-mcu-fanbase-no-spoilers/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/avengers-endgame-chris-evans-captain-america-don-cheadle-scarlett-johansson-black-widow-mark-ruffalo-hulk-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/avengers-endgame-is-a-love-letter-to-the-mcu-fanbase-no-spoilers/">AVENGERS ENDGAME is a love letter to the MCU fanbase (no spoilers)</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-27">April 27, 2019</time></div></div>
                        </div></li> <li class="cb-article-4 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2019/04/the-matrix-is-still-awesome-twenty-years-later/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/matrix-keanu-reeves-neo-3-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/the-matrix-is-still-awesome-twenty-years-later/">The Matrix is still awesome&#8230;twenty years later</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-26">April 26, 2019</time></div></div>
                        </div></li> <li class="cb-article-5 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2019/04/the-rise-of-skywalker-finally-we-get-to-overanalyze-a-star-wars-teaser-again/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-wars-rise-skywalker-trailer-daisy-ridley-rey-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/the-rise-of-skywalker-finally-we-get-to-overanalyze-a-star-wars-teaser-again/">The Rise of Skywalker: FINALLY! We get to overanalyze a Star Wars teaser again&#8230;</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-14">April 14, 2019</time></div></div>
                        </div></li> <li class="cb-article-6 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2019/04/review-shazams-infectous-joy-overrides-its-flaws/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/shazam-zachary-levi-jack-dylan-grazer-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/review-shazams-infectous-joy-overrides-its-flaws/">REVIEW: SHAZAM!&#8217;s infectous joy overrides its flaws</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-07">April 7, 2019</time></div></div>
                        </div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-41523" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41523"><a href="https://www.cultofwhatever.com/music/">Music</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#fa0088;">Random</span></div>
                                        <ul> <li class="cb-article clearfix">
                        <div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2017/10/elvis-40-year-reign-1973-1975/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2017/10/bg-elvis-10-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/10/elvis-40-year-reign-1973-1975/">Elvis' 40 Year Reign (1973-1975)</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-10-29">October 29, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/music/music-blogs/" title="View all posts in Music Blogs">Music Blogs</a></div></div>
                        </div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#fa0088;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix">
                        <div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2019/03/fifty-years-of-led-zeppelin/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/02/led-zeppelin-1977-promo-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/03/fifty-years-of-led-zeppelin/">Fifty years of Led Zeppelin</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-03-04">March 4, 2019</time></div></div>
                        </div></li> <li class="cb-article-2 clearfix">
                        <div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2018/11/queens-catalogue-from-bottom-to-top/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2018/10/queen-2-album-cover-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2018/11/queens-catalogue-from-bottom-to-top/">QUEEN&#8217;s catalogue, from bottom to top</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-11-01">November 1, 2018</time></div></div>
                        </div></li> <li class="cb-article-3 clearfix">
                        <div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2018/09/fifty-years-ago-johnny-cash-did-folsom-prison/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2018/09/johnny-cash-folsom-prison-cover-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2018/09/fifty-years-ago-johnny-cash-did-folsom-prison/">Fifty Years ago Johnny Cash did Folsom Prison&#8230;</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-09-11">September 11, 2018</time></div></div>
                        </div></li> <li class="cb-article-4 clearfix">
                        <div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2017/12/your-official-christmas-2017-listening-guide/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/12/santa-music-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/12/your-official-christmas-2017-listening-guide/">YOUR official Christmas 2017 LISTENING Guide</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-12-20">December 20, 2017</time></div></div>
                        </div></li> <li class="cb-article-5 clearfix">
                        <div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2017/12/on-sam-and-sun-and-the-nativity-scene-of-rock-and-roll/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/12/sam-phillips-sun-records-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/12/on-sam-and-sun-and-the-nativity-scene-of-rock-and-roll/">On Sam and Sun and the nativity scene of rock and roll</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-12-18">December 18, 2017</time></div></div>
                        </div></li> <li class="cb-article-6 clearfix">
                        <div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2017/11/elvis-40-year-reign-1976-tomorrow/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/11/elvis-stamp-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/11/elvis-40-year-reign-1976-tomorrow/">Elvis&#8217; 40 Year Reign (1976-Tomorrow)</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-11-29">November 29, 2017</time></div></div>
                        </div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-24170" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-24170"><a href="https://www.cultofwhatever.com/tv/">TV</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1a93db;">Featured</span></div>
                                        <ul> <li class="cb-article clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/04/killing-eve-s02e04-review-desperate-times-i-expected-something-a-little-more-dazzling/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/killing-eve-s02e04-1-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/killing-eve-s02e04-review-desperate-times-i-expected-something-a-little-more-dazzling/">Killing Eve S02E04 Review: Desperate Times - I expected something a little more dazzling...</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-29">April 29, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>
                        </div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1a93db;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/">Riverdale S03E22 Review: Survive the Night &#8211; A very entertaining finale!</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-16">May 16, 2019</time></div></div>
                        </div></li> <li class="cb-article-2 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-of-thrones-s08e05-peter-dinklage-tyrion-lannister-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/">Game of Thrones S08E05: The Bells &#8211; The Mis-match of the Mad Queens</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-13">May 13, 2019</time></div></div>
                        </div></li> <li class="cb-article-3 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e06-review-i-hope-you-like-missionary-a-hard-to-believe-episode/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e06-jodie-comer-villanelle-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e06-review-i-hope-you-like-missionary-a-hard-to-believe-episode/">Killing Eve S02E06 Review: I Hope You Like Missionary! &#8211; A hard-to-believe episode&#8230;</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-13">May 13, 2019</time></div></div>
                        </div></li> <li class="cb-article-4 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e21-review-the-dark-secret-of-harvest-house-unexpected-revelations-from-the-farm/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e21-chad-michael-murray-edgar-evernever-lili-reinhart-betty-cooper-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e21-review-the-dark-secret-of-harvest-house-unexpected-revelations-from-the-farm/">Riverdale S03E21 Review: The Dark Secret of Harvest House &#8211; Unexpected revelations from The Farm</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-09">May 9, 2019</time></div></div>
                        </div></li> <li class="cb-article-5 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/05/star-trek-discovery-review-season-2-has-the-show-jumped-the-shark-or-grown-the-beard/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e13-crew-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/star-trek-discovery-review-season-2-has-the-show-jumped-the-shark-or-grown-the-beard/">Star Trek Discovery Review: Season 2 &#8211; Has the show jumped the shark or grown the beard?</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-07">May 7, 2019</time></div></div>
                        </div></li> <li class="cb-article-6 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e04-the-last-of-the-starks-after-last-weeks-divisive-heroics-the-last-war-begins/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-thrones-s08e04-lena-headey-cersei-lannister-pilou-asbaek-euron-greyjoy-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e04-the-last-of-the-starks-after-last-weeks-divisive-heroics-the-last-war-begins/">Game of Thrones S08E04: The Last of the Starks &#8211; After last week’s divisive heroics, the last war begins</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-06">May 6, 2019</time></div></div>
                        </div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-24171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24171"><a href="https://www.cultofwhatever.com/video-games/">Video Games</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#24bc3a;">Featured</span></div>
                                        <ul> <li class="cb-article clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2015/07/batman-arkham-knight-a-fitting-end-to-a-trilogy/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2015/07/arkham-knight-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2015/07/arkham-knight-480x240.jpg 480w, https://www.cultofwhatever.com/wp-content/uploads/2015/07/arkham-knight-1400x700.jpg 1400w" sizes="(max-width: 480px) 100vw, 480px" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2015/07/batman-arkham-knight-a-fitting-end-to-a-trilogy/">Batman: Arkham Knight - A fitting end to a trilogy</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/tom-farr/">Tom Farr</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2015-07-18">July 18, 2015</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/video-games/video-games-reviews/" title="View all posts in Video Game Reviews">Video Game Reviews</a></div></div>
                        </div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#24bc3a;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2018/08/is-the-xbox-one-x-worth-it-in-mid-2018/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2018/08/x-box-x-1-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2018/08/is-the-xbox-one-x-worth-it-in-mid-2018/">Is the XBOX ONE X &#8220;worth it&#8221; in mid-2018?</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-08-14">August 14, 2018</time></div></div>
                        </div></li> <li class="cb-article-2 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2018/06/in-which-i-tell-nintendo-fans-to-calm-down/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2018/06/nintendo-e3-2018-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2018/06/in-which-i-tell-nintendo-fans-to-calm-down/">In which I tell Nintendo fans to calm down(!)</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-06-27">June 27, 2018</time></div></div>
                        </div></li> <li class="cb-article-3 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2018/05/ocarina-of-time-is-still-seminal-20-years-later/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2018/05/zelda-ocarina-time-1998-cover-n64-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2018/05/ocarina-of-time-is-still-seminal-20-years-later/">Ocarina of Time is still seminal, 20 years later&#8230;</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-05-28">May 28, 2018</time></div></div>
                        </div></li> <li class="cb-article-4 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2018/04/nintendo-labo-review-a-new-way-to-do-something-before-you-play/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2018/04/nintendo-labo-1-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2018/04/nintendo-labo-review-a-new-way-to-do-something-before-you-play/">Nintendo LABO Review: A new way to do *something* before you play!</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-04-25">April 25, 2018</time></div></div>
                        </div></li> <li class="cb-article-5 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2018/03/nintendo-switch-one-year-later-an-indie-gamers-paradise/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2016/10/nintendo-switch-6-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2018/03/nintendo-switch-one-year-later-an-indie-gamers-paradise/">Nintendo Switch: One Year Later &#8211; An indie gamer&#8217;s paradise</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-03-14">March 14, 2018</time></div></div>
                        </div></li> <li class="cb-article-6 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2018/02/nintendo-switch-one-year-later-how-mario-and-zelda-saved-nintendo/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2016/10/nintendo-switch-3-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2018/02/nintendo-switch-one-year-later-how-mario-and-zelda-saved-nintendo/">Nintendo Switch: One Year Later &#8211; How Mario and Zelda saved Nintendo</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-02-19">February 19, 2018</time></div></div>
                        </div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-24172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24172"><a href="https://www.cultofwhatever.com/wrestling/">Wrestling</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#20007f;">Featured</span></div>
                                        <ul> <li class="cb-article clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2017/04/your-so-of-course-preview-of-wwe-payback-2017/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2017/04/wwe-payback-2017-poster-2-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/04/your-so-of-course-preview-of-wwe-payback-2017/">Your SO OF COURSE preview of WWE Payback 2017</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-04-30">April 30, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/blogs/wwe-blogs/" title="View all posts in WWE">WWE</a></div></div>
                        </div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#20007f;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2019/05/your-way-too-early-predictions-for-wwe-wrestlemania-36/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/wrestlemania-36-logo-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/your-way-too-early-predictions-for-wwe-wrestlemania-36/">Your WAY TOO EARLY Predictions for WWE WrestleMania 36!</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-12">May 12, 2019</time></div></div>
                        </div></li> <li class="cb-article-2 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2019/04/did-wrestlemania-35-mark-a-turning-point-for-wwe/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2016/08/02072016-new-day-big-e-kofi-kingston-xavier-woods-tag-team-title-belt-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/08/02072016-new-day-big-e-kofi-kingston-xavier-woods-tag-team-title-belt-80x60.jpg 80w, https://www.cultofwhatever.com/wp-content/uploads/2016/08/02072016-new-day-big-e-kofi-kingston-xavier-woods-tag-team-title-belt-300x225.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2016/08/02072016-new-day-big-e-kofi-kingston-xavier-woods-tag-team-title-belt-360x270.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2016/08/02072016-new-day-big-e-kofi-kingston-xavier-woods-tag-team-title-belt.jpg 700w" sizes="(max-width: 80px) 100vw, 80px" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/did-wrestlemania-35-mark-a-turning-point-for-wwe/">Did WrestleMania 35 mark a turning point for WWE?</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-14">April 14, 2019</time></div></div>
                        </div></li> <li class="cb-article-3 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2019/04/wwe-wrestlemania-35-weekend-in-review/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2018/05/wwe-wrestlemania-35-logo-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/wwe-wrestlemania-35-weekend-in-review/">WWE WrestleMania 35: Weekend in Review!</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-11">April 11, 2019</time></div></div>
                        </div></li> <li class="cb-article-4 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2019/04/your-so-of-course-preview-of-wwe-wrestlemania-35/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/wrestlemania-35-poster-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/your-so-of-course-preview-of-wwe-wrestlemania-35/">Your SO OF COURSE preview of WWE WRESTLEMANIA 35!</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-05">April 5, 2019</time></div></div>
                        </div></li> <li class="cb-article-5 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2019/03/does-it-even-matter-who-main-events-wrestlemania/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2016/08/01072016-becky-lynch-1-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/08/01072016-becky-lynch-1-80x60.jpg 80w, https://www.cultofwhatever.com/wp-content/uploads/2016/08/01072016-becky-lynch-1-300x225.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2016/08/01072016-becky-lynch-1-360x270.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2016/08/01072016-becky-lynch-1.jpg 700w" sizes="(max-width: 80px) 100vw, 80px" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/03/does-it-even-matter-who-main-events-wrestlemania/">Does it even matter who main-events WrestleMania?</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-03-19">March 19, 2019</time></div></div>
                        </div></li> <li class="cb-article-6 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2019/03/your-so-of-course-preview-of-wwe-fastlane-2019/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2019/03/wwe-fastlane-2019-poster-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/03/your-so-of-course-preview-of-wwe-fastlane-2019/">Your SO OF COURSE preview of WWE Fastlane 2019</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-03-08">March 8, 2019</time></div></div>
                        </div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-24173" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24173"><a href="https://www.talkwhateveronline.com/">Forum</a><div class="cb-links-menu"></li>
<li class="cb-icons"><ul></ul></li><li id="cb-nav-logo" class="cb-nav-logo-always" style="padding-top: 0px"><a href="https://www.cultofwhatever.com"><img src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo.png" alt="site logo" width="" height="" data-retina-src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo@2x.png" ></a></li></ul></div></div>
    	 				</nav>

    	 				
                            <!-- Secondary Menu -->
                            
                            <div id="cb-top-menu" class="clearfix cb-dark-menu">
                                    <div class="wrap clearfix">

                                        
                                                    <a href="#" id="cb-small-menu-trigger"><i class="fa fa-bars"></i></a>

                                        <div class="cb-breaking-news"><span>Latest <i class="fa fa-long-arrow-right"></i></span><ul><li><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/" title="Look Riverdale S03E22 Review: Survive the Night - A very entertaining finale!" >Riverdale S03E22 Review: Survive the Night - A very entertaining finale!</a> </li> <li><a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/" title="Look Game of Thrones S08E05: The Bells - The Mis-match of the Mad Queens" >Game of Thrones S08E05: The Bells - The Mis-match of the Mad Queens</a> </li> <li><a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e06-review-i-hope-you-like-missionary-a-hard-to-believe-episode/" title="Look Killing Eve S02E06 Review: I Hope You Like Missionary! - A hard-to-believe episode..." >Killing Eve S02E06 Review: I Hope You Like Missionary! - A hard-to-believe episode...</a> </li> <li><a href="https://www.cultofwhatever.com/2019/05/your-way-too-early-predictions-for-wwe-wrestlemania-36/" title="Look Your WAY TOO EARLY Predictions for WWE WrestleMania 36!" >Your WAY TOO EARLY Predictions for WWE WrestleMania 36!</a> </li> <li><a href="https://www.cultofwhatever.com/2019/05/review-grading-detective-pikachu-on-three-levels/" title="Look REVIEW: Grading Detective Pikachu on three levels..." >REVIEW: Grading Detective Pikachu on three levels...</a> </li> <li><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e21-review-the-dark-secret-of-harvest-house-unexpected-revelations-from-the-farm/" title="Look Riverdale S03E21 Review: The Dark Secret of Harvest House - Unexpected revelations from The Farm" >Riverdale S03E21 Review: The Dark Secret of Harvest House - Unexpected revelations from The Farm</a> </li> </ul></div><div class="right-secondary-menu"><ul class="cb-top-nav"><li id="menu-item-24158" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24158"><a target="_blank" href="https://www.facebook.com/cultofwhatever">Facebook</a></li>
<li id="menu-item-24159" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24159"><a target="_blank" href="https://twitter.com/cultofwhatever">Twitter</a></li>
</ul><a href="#" title="Search" class="cb-tip-bot cb-small-menu-icons cb-small-menu-search secondary-menu-search" data-reveal-id="cb-search-modal"><i class="fa fa-search"></i></a></div>
                                        <div id="cb-tap-detect"></div>

                                    </div>
                            </div>
                            <!-- /Secondary Menu -->

                            


                        
                        
                            <!-- Small-Screen Menu -->

                            <section id="cb-small-menu" class="clearfix cb-dark-menu cb-sm-on">

                                <a href="#" id="cb-small-menu-close"><i class="fa fa-times"></i></a>

                                <ul class="cb-small-nav"><li id="menu-item-24205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-24205"><a href="http://www.cultofwhatever.com/">Home</a></li>
<li id="menu-item-24206" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24206"><a href="https://www.cultofwhatever.com/movies/">Movies</a></li>
<li id="menu-item-41524" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41524"><a href="https://www.cultofwhatever.com/music/">Music</a></li>
<li id="menu-item-24207" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-24207"><a href="https://www.cultofwhatever.com/tv/">TV</a></li>
<li id="menu-item-24208" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24208"><a href="https://www.cultofwhatever.com/video-games/">Video Games</a></li>
<li id="menu-item-24209" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24209"><a href="https://www.cultofwhatever.com/wrestling/">Wrestling</a></li>
<li id="menu-item-24210" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24210"><a href="http://www.talkwhateveronline.com/">Forum</a></li>
</ul>
                            </section>

                            <!-- /Small-Screen Menu -->

                        
                        
    	 				<a href="#" id="cb-to-top"><i class="fa fa-arrow-circle-o-up"></i></a>

                        
                </header> <!-- end header -->            <div id="cb-content" class="wrap clearfix off">

 

				   
					<div id="main" class="clearfix" role="main">

                                             

							<article id="post-47839" class="clearfix post-47839 post type-post status-publish format-standard has-post-thumbnail hentry category-tv-blogs tag-riverdale" role="article" itemscope itemtype="http://schema.org/BlogPosting">

                                 <div class="cb-entry-header cb-style-off"><span class="cb-title-fi"><h1 class="entry-title cb-entry-title cb-single-title" itemprop="headline">Riverdale S03E22 Review: Survive the Night &#8211; A very entertaining finale!</h1><div class="custom_post_meta"><div class="first_row">Posted on <time class="updated" datetime="2019-05-16" style="color: #1a93db;">May 16, 2019</time> by <a href="https://www.cultofwhatever.com/author/salome-g/" style="color: #1a93db;">Salome G</a></div> <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs" class="category_button" style="background-color: #1a93db;" >TV Blogs</a><div class="cb-social-sharing cb-beside clearfix"><div class="cb-title-subtle">Share On:</div><div class="cb-facebook"><div id="fb-root"></div>
                        <script>(function(d, s, id) {
                          var js, fjs = d.getElementsByTagName(s)[0];
                          if (d.getElementById(id)) return;
                          js = d.createElement(s); js.id = id;
                          js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
                          fjs.parentNode.insertBefore(js, fjs);
                        }(document, "script", "facebook-jssdk"));</script>
                       <div class="fb-like" data-href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/" data-width="450" data-layout="button_count" data-show-faces="false" data-send="false"></div></div><div class="cb-pinterest"><script type="text/javascript" src="//assets.pinterest.com/js/pinit.js" async></script>
            <a href="//pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.cultofwhatever.com%2F2019%2F05%2Friverdale-s03e22-review-survive-the-night-a-very-entertaining-finale%2F&media=https%3A%2F%2Fwww.cultofwhatever.com%2Fwp-content%2Fuploads%2F2019%2F05%2Friverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica.jpg&description=Riverdale+S03E22+Review%3A+Survive+the+Night+%26%238211%3B+A+very+entertaining+finale%21" data-pin-do="buttonPin" data-pin-config="beside" target="_blank"><img src="//assets.pinterest.com/images/pidgets/pin_it_button.png" /></a></div><div class="cb-google ">
                            <div class="g-plusone" data-size="medium"></div>

                            <script type="text/javascript">
                              (function() {
                                var po = document.createElement("script"); po.type = "text/javascript"; po.async = true;
                                po.src = "https://apis.google.com/js/plusone.js";
                                var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(po, s);
                              })();
                            </script></div><div class="cb-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-dnt="true"  data-count="horizontal">Tweet</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div></div></div></span></div>
								<section class="entry-content clearfix" itemprop="articleBody">
								
									<p>&#8220;Oh, loose ends. Such a bother, aren&#8217;t they?&#8221; *looks at the camera like I&#8217;m on The Office*</p>
<p>This line, delivered by Penelope, comes in the first 10 minutes of the episode. The fact that she&#8217;s delivering it to a dinner party that includes Veronica, Jughead, Archie, and Betty (rescued/bought from The Farm) is a small hint that this season finale is going to be a wild ride. The fact that the dinner party also includes the Black Hood and the Gargoyle King is a big one.</p>
<p><span id="more-47839"></span></p>
<p>The Black Hood is quickly unmasked as Hal, but the Gargoyle King&#8217;s true identity remains to be seen. Penelope invites Jughead to take a guess and after some quick deduction, he names him as Chic. His guess turns out to be correct. And if you&#8217;re wondering if Ethel lied, then the answer is: probably not. Apparently, a red dye job and just calling him Jason was enough to convince her he was a Blossom. Meanwhile, I&#8217;m trying to decide whose return was a bigger bummer this week, Chic&#8217;s or <a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/">Euron Greyjoy&#8217;s</a>.</p>
<p><img class="aligncenter size-full wp-image-47848" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-nathalie-boltt-penelope-blossom.jpg" alt="" width="750" height="500" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-nathalie-boltt-penelope-blossom.jpg 750w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-nathalie-boltt-penelope-blossom-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-nathalie-boltt-penelope-blossom-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-nathalie-boltt-penelope-blossom-600x400.jpg 600w" sizes="(max-width: 750px) 100vw, 750px" /></p>
<p>But really, Penelope is the Gargoyle King, as she is the one who revived the game through Hal&#8217;s new minion, Chic, who begat Dilton and Ben, who begat Ethel and so on. [Note: I wrote this sentence before Jughead used the word &#8220;begat&#8221; a bunch, which was startling.] Penelope Blossom will have her revenge on the town that saw her groomed as a child bride and robbed of her son. While I&#8217;m sympathetic to the traumas she&#8217;s experienced, hearing today from someone who&#8217;s hellbent on punishing &#8220;sinners&#8221; just makes me really tired. All offense, but fall in a lake.</p>
<p>Anyway, she&#8217;s gathered the core four there so that they can be forced to participate in an Ascension Night game. First up, the Red Paladin, who has to face a &#8220;grizzled beast.&#8221; Luckily for Archie, it&#8217;s not an actual grizzly. Unluckily, it&#8217;s a dude so big, he might as well be a bear. Archie, the sweetest, dumbest boy in the county, runs headlong at him. He is clotheslined immediately.</p>
<p>But hey, somehow, he gets the upper hand and knocks the dude out cold. It occurs to me that maybe it would have been trickier not to have the kids complete challenges that play to their strengths, but what do I know? I&#8217;m not out here trying to murder children.</p>
<p>Speaking of, Veronica&#8217;s challenge. She gets a Russian roulette, but with possibly poisoned chalices. Shouldn&#8217;t the fact that Veronica samples the last chalice to save Betty be proof of her inherent goodness? Again, sorry&#8211;I&#8217;m new to torturing youths through gameplay.</p>
<p>Archie: &#8220;Wait, I still don&#8217;t get it.&#8221; *looks back to the camera*</p>
<p><img class="aligncenter size-full wp-image-47849" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica.jpg" alt="" width="750" height="501" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica.jpg 750w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica-600x400.jpg 600w" sizes="(max-width: 750px) 100vw, 750px" /></p>
<p>That amazing line comes after Jughead has to fight Chic, which again, is like watching that Euron fight on Sunday. Jughead wins, of course, because Chic isn&#8217;t really a person&#8211;more of a plot device.</p>
<p>Then Betty is up and her challenge is to shoot her father before he shoots her. It would have been much funnier if she&#8217;d just plugged him right when he walked up and been like, &#8220;Are we finished now?&#8221; That&#8217;s not the tone they&#8217;re going for, though, so instead, she wings him. Then Penelope shoots him in the head.</p>
<p>At that point, the kids should have won, but what a surprise&#8211;Mad Queen Penelope doesn&#8217;t play fair. She sics her own minions&#8211;and who are these people, exactly?&#8211;on the four. Thankfully, though, the cavalry arrives, comprising a newly liberated Cheryl, plus Toni and a mixed bag of Serpents and Poisons. They descend on the forest and on the minions, whoever the hell they are. Penelope escapes.</p>
<p>After that, the core four go to the Farm but find only Kevin in a Heaven&#8217;s Gate-esque tableau. Everyone else supposedly ascended, leaving him behind to tell the tale. Right.</p>
<p>Also, Hermione is arrested for conspiracy to commit murder, specifically, her husband&#8217;s. That arrest is all his doing, of course, and God knows what tedious punishment he has in store for Veronica. But that isn&#8217;t the only FBI activity in town.</p>
<p><img class="aligncenter size-full wp-image-47850" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-lili-reinhart-betty-cooper.jpg" alt="" width="750" height="505" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-lili-reinhart-betty-cooper.jpg 750w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-lili-reinhart-betty-cooper-300x202.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-lili-reinhart-betty-cooper-360x242.jpg 360w" sizes="(max-width: 750px) 100vw, 750px" /></p>
<p>An Agent Smith (Wyatt Nash) shows up at the Jones&#8217;s door&#8211;where has FP been through most of this, btw?&#8211;telling Jug and Betty that he&#8217;s been investigating Edgar for some time. To that end, he&#8217;s had a woman on the inside&#8211;Alice. To say this comes as a shock to Betty is an understatement&#8211;Alice cashed in Betty&#8217;s college money, remember?! But the shocks keep coming. As soon as Betty wonders if she knows Agent Smith and he&#8217;s like, &#8220;Well, there&#8217;s a reason I worked with Alice&#8230;&#8221; I had to pause the DVR and take a deep breath. Like, THANK GOD. I knew a dude who shared Betty and Jug&#8217;s DNA could not be as loathsome/annoying/repulsive/I could keep going as Chic.</p>
<p>Archie: &#8220;Wait, back up.&#8221;</p>
<p>That&#8217;s right, folks&#8211;this is the real Charles. Until, you know, we find out he&#8217;s not or whatever. But at least Alice&#8217;s claims that she&#8217;s been talking to him aren&#8217;t as disturbing as they were when we all thought he was dead.</p>
<p>And that would have been a heckuva way to end the season, but we don&#8217;t stop there. As the kids regroup at Pop&#8217;s, they make a promise to have a drama-free, if sedate senior year. Flash forward to spring break, and the group, minus Jughead, is standing blood-splattered around a fire. Betty says they&#8217;ll wash up in the Sweetwater, burn their clothes, and never speak of this again.</p>
<p>Wait, back up.</p>
<p><strong>8/10 &#8211; Despite a sometimes wildly unbalanced season, Riverdale managed to stick the landing with this very entertaining finale. Also, I love that Archie&#8211;sweet Archie&#8211;floated so blissfully through the G&amp;G storylines that he refers to them as &#8220;Gremlins&#8221; during the Pop&#8217;s scene.</strong></p>

								</section> <!-- end article section -->

								
								<footer class="article-footer">

                                    <style type="text/css">
                                        .cb-tags a {
                                            background-color:#1a93db!important;
                                         }

                                         .entry-content blockquote:before {
                                            color: #1a93db;
                                         }

                                        .entry-content h1, .entry-content h2, .entry-content h3, .entry-content h4,
										.entry-content h5, .entry-content h6 {
                                            color: #1a93db;
                                        }

                                         .widget_nav_menu ul li:before, .widget_rss ul li:before, .widget_recent_entries ul li:before, .widget_recent_comments ul li:before, .widget_meta ul li:before, .widget_categories ul li:before, .widget_archive ul li:before, .widget_pages ul li:before, .widget-popular-posts li:before {
                                            color: #1a93db !important;
                                         }

                                         ul.slides {
                                            background-color: #fff;
                                         }
                                         .entry-content ul li:before {
                                            background-color:#1a93db;
                                         }
										 .entry-content ol li:before {
                                            color:#1a93db;
                                         }
										 
										 .entry-content a {
										    text-decoration: none;
											color: #333;
											box-shadow: inset 0 -2px 0 #1a93db;
											transition: box-shadow .3s ease-out,background-color .3s ease-out;
											font-weight: 400;
										}
										.entry-content a:hover {
											background-color: rgba(26,147,219,0.7);
											box-shadow: inset 0 -2px 0 rgba(13,190,152,0);
											text-decoration: none !Important;
										}
										.entry-content .color-section {
											border-color: rgba(26,147,219,0.7);
											border-width: 2px;
											border-style: solid;
											background-color: #f2f3f7;
											padding: 15px;
											margin: 20px auto;
											color: #333;
										}
										.cb-article-widget a {
											background-color: #1a93db;
										}

                                    </style>
									<h3>Tags</h3><p class="cb-tags"> <a href="https://www.cultofwhatever.com/tag/riverdale/" rel="tag">Riverdale</a></p>
<div id="disqus_thread"></div>
<div id="text-38" class="cb-article-widget widget_text"><h3 class="cb-article-widget-title"><span>Cult of Whatever is currently watching:</span></h3>			<div class="textwidget"><p><a href="https://www.cultofwhatever.com/tag/american-gods/">American Gods</a> <a href="https://www.cultofwhatever.com/tag/game-of-thrones/">Game of Thrones</a> <a href="https://www.cultofwhatever.com/tag/killing-eve/">Killing Eve</a> <a href="https://www.cultofwhatever.com/tag/project-blue-book/">Project Blue Book</a> <a href="https://www.cultofwhatever.com/tag/riverdale/">Riverdale</a> <a href="https://www.cultofwhatever.com/tag/roswell-new-mexico/">Roswell, New Mexico</a> <a href="https://www.cultofwhatever.com/tag/star-trek-discovery/">Star Trek Discovery</a> <a href="https://www.cultofwhatever.com/wrestling/">WWE</a></p>
</div>
		</div><div id="cb-related-posts" class="clearfix"><h3 style="border-bottom: 4px solid #1a93db;">You might also like</h3><ul>
							<li class="no-1">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e21-review-the-dark-secret-of-harvest-house-unexpected-revelations-from-the-farm/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e21-chad-michael-murray-edgar-evernever-lili-reinhart-betty-cooper-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e21-review-the-dark-secret-of-harvest-house-unexpected-revelations-from-the-farm/">Riverdale S03E21 Review: The Dark Secret of Harvest House &#8211; Unexpected revelations from The Farm</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-09">May 9, 2019</time></div></div>
								</div>

							</li>


							<li class="no-2">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e20-review-prom-night-it-gets-bloody/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e20-lili-reinhart-betty-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e20-review-prom-night-it-gets-bloody/">Riverdale S03E20 Review: Prom Night &#8211; It gets bloody!</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-02">May 2, 2019</time></div></div>
								</div>

							</li>


							<li class="no-3">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/04/riverdale-s03e19-review-fear-the-reaper-a-wild-jellybean-chase/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/riverdale-s03e19-cole-sprouse-jughead-skeet-ulrich-fp-jones-gina-gershon-gladys-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/04/riverdale-s03e19-review-fear-the-reaper-a-wild-jellybean-chase/">Riverdale S03E19 Review: Fear the Reaper &#8211; A wild Jellybean chase</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-25">April 25, 2019</time></div></div>
								</div>

							</li>


							<li class="no-4">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/04/riverdale-s03e18-review-jawbreaker-g-is-rapidly-spreading-throughout-town-and-it-aint-pretty/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/riverdale-s03e18-casey-cott-kevin-madelaine-petsch-cheryl-blossom-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/04/riverdale-s03e18-review-jawbreaker-g-is-rapidly-spreading-throughout-town-and-it-aint-pretty/">Riverdale S03E18 Review: Jawbreaker &#8211; G is rapidly spreading throughout town and it ain&#8217;t pretty!</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-18">April 18, 2019</time></div></div>
								</div>

							</li>


							<li class="no-5">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/03/riverdale-s03e17-review-the-master-hows-this-all-going-to-fit-together/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/03/riverdale-s03e17-cole-sprouse-jughead-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/03/riverdale-s03e17-review-the-master-hows-this-all-going-to-fit-together/">Riverdale S03E17 Review: The Master &#8211; Hows this all going to fit together?</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-03-28">March 28, 2019</time></div></div>
								</div>

							</li>


							<li class="no-6">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/03/riverdale-s03e16-review-big-fun-time-to-get-musical-again/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/03/riverdale-s03e16-madelaine-petsch-cheryl-lili-reinhart-betty-camila-mendes-veronica-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/03/riverdale-s03e16-review-big-fun-time-to-get-musical-again/">Riverdale S03E16 Review: Big Fun &#8211; Time to get musical again</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-03-21">March 21, 2019</time></div></div>
								</div>

							</li>


							<li class="no-7">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/03/riverdale-s03e15-review-american-dreams-happy-50th/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/03/riverdale-s03e15-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/03/riverdale-s03e15-review-american-dreams-happy-50th/">Riverdale S03E15 Review: American Dreams &#8211; Happy 50th!</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-03-17">March 17, 2019</time></div></div>
								</div>

							</li>


							<li class="no-8">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/03/riverdale-s03e14-review-fire-walk-with-me-heartbroken/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/02/riverdale-luke-perry-kj-apa-fred-archie-andrews-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/03/riverdale-s03e14-review-fire-walk-with-me-heartbroken/">Riverdale S03E14 Review: Fire Walk with Me &#8211; Heartbroken</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-03-07">March 7, 2019</time></div></div>
								</div>

							</li>


							<li class="no-9">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/02/riverdale-s03e13-review-requiem-for-a-welterweight-a-series-low/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/02/riverdale-s03e13-madchen-amick-alice-cooper-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/02/riverdale-s03e13-review-requiem-for-a-welterweight-a-series-low/">Riverdale S03E13 Review: Requiem for a Welterweight &#8211; A series low?</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-02-28">February 28, 2019</time></div></div>
								</div>

							</li>


							<li class="no-10">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/02/riverdale-s03e12-review-bizarrodale-gargoyle-king-not-happy-with-kevin-and-moose/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/02/riverdale-s03e12-casey-cott-josie-kevin-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/02/riverdale-s03e12-review-bizarrodale-gargoyle-king-not-happy-with-kevin-and-moose/">Riverdale S03E12 Review: Bizarrodale &#8211; The Gargoyle King not happy with Kevin and Moose?</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-02-07">February 7, 2019</time></div></div>
								</div>

							</li>


							<li class="no-11">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/01/riverdale-s03e11-review-the-red-dahlia-a-muddled-mix-of-storylines/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/01/riverdale-s03e11-kelly-ripa-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/01/riverdale-s03e11-review-the-red-dahlia-a-muddled-mix-of-storylines/">Riverdale S03E11 Review: The Red Dahlia &#8211; A muddled mix of storylines</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-01-31">January 31, 2019</time></div></div>
								</div>

							</li>


							<li class="no-12">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/01/riverdale-s03e10-review-the-stranger-how-is-that-even-legal/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/01/riverdale-s03e10-camila-mendes-veronica-lodge-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/01/riverdale-s03e10-review-the-stranger-how-is-that-even-legal/">Riverdale S03E10 Review: The Stranger &#8211; How is that even legal?</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-01-24">January 24, 2019</time></div></div>
								</div>

							</li>


							<li class="no-13">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2019/01/riverdale-s03e09-review-no-exit-get-your-vixens-funeral-uniform-ready/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2019/01/riverdale-s03e09-charles-melton-reggie-mantle-camila-mendes-veronica-lodge-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2019/01/riverdale-s03e09-review-no-exit-get-your-vixens-funeral-uniform-ready/">Riverdale S03E09 Review: No Exit &#8211; Get your Vixens funeral uniform ready&#8230;</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-01-17">January 17, 2019</time></div></div>
								</div>

							</li>


							<li class="no-14">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2018/12/riverdale-s03e08-review-outbreak-hirams-plan-doesnt-make-a-whole-lotta-sense/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2018/12/riverdale-s03e08-cole-sprouse-kj-apa-jughead-archie-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2018/12/riverdale-s03e08-review-outbreak-hirams-plan-doesnt-make-a-whole-lotta-sense/">Riverdale S03E08 Review: Outbreak &#8211; Hiram&#8217;s plan doesn&#8217;t make a whole lotta sense!</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-12-13">December 13, 2018</time></div></div>
								</div>

							</li>


							<li class="no-15">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2018/12/riverdale-s03e07-review-the-man-in-black-ethel-is-the-freakin-worst-now/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2018/12/riverdale-s03e07-lili-reinhart-betty-cooper-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2018/12/riverdale-s03e07-review-the-man-in-black-ethel-is-the-freakin-worst-now/">Riverdale S03E07 Review: The Man in Black &#8211; Ethel is the freakin&#8217; WORST now!</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-12-06">December 6, 2018</time></div></div>
								</div>

							</li>


							<li class="no-16">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2018/11/riverdale-s03e06-review-manhunter-pawns-are-often-sacrificed/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2018/11/riverdale-s03e06-kj-apa-archie-andrews-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2018/11/riverdale-s03e06-review-manhunter-pawns-are-often-sacrificed/">Riverdale S03E06 Review: Manhunter &#8211; Pawns are often sacrificed&#8230;</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-11-30">November 30, 2018</time></div></div>
								</div>

							</li>


							<li class="no-17">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2018/11/riverdale-s03e05-review-the-great-escape-i-feel-like-im-on-fizzle-rocks/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2018/11/riverdale-s03e05-2-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2018/11/riverdale-s03e05-review-the-great-escape-i-feel-like-im-on-fizzle-rocks/">Riverdale S03E05 Review: The Great Escape &#8211; I feel like I&#8217;m on fizzle rocks!</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-11-18">November 18, 2018</time></div></div>
								</div>

							</li>


							<li class="no-18">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2018/11/riverdale-s03e04-review-the-midnight-club-were-going-back-to-the-90s/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2018/10/riverdale-s03e04-midnight-club-poster-2-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2018/11/riverdale-s03e04-review-the-midnight-club-were-going-back-to-the-90s/">Riverdale S03E04 Review: The Midnight Club &#8211; We&#8217;re going back to the 90s!</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-11-08">November 8, 2018</time></div></div>
								</div>

							</li>


							<li class="no-19">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2018/10/riverdale-s03e03-review-as-above-so-below-thats-right-daddy-im-shaking-you-down/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2018/10/riverdale-s03e03-camila-mendes-veronica-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2018/10/riverdale-s03e03-review-as-above-so-below-thats-right-daddy-im-shaking-you-down/">Riverdale S03E03 Review: As Above, So Below &#8211; &#8216;That&#8217;s right, Daddy&#8211;I&#8217;m shaking you down&#8217;</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-10-25">October 25, 2018</time></div></div>
								</div>

							</li>


							<li class="no-20">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2018/10/riverdale-s03e02-review-fortune-and-mens-eyes-archie-gives-another-brutally-cringe-inducing-speech/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2018/10/riverdale-s03e02-cole-sprouse-lili-reinhart-jughead-betty-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2018/10/riverdale-s03e02-review-fortune-and-mens-eyes-archie-gives-another-brutally-cringe-inducing-speech/">Riverdale S03E02 Review: Fortune and Men&#8217;s Eyes &#8211; Archie gives another brutally cringe-inducing speech</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-10-20">October 20, 2018</time></div></div>
								</div>

							</li>


							<li class="no-21">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2018/10/riverdale-s03e01-review-labor-day-cult-2018-baby/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2018/10/riverdale-s03e01-kj-apa-archie-molly-ringwald-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2018/10/riverdale-s03e01-review-labor-day-cult-2018-baby/">Riverdale S03E01 Review: Labor Day &#8211; CULT 2018, baby!</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-10-12">October 12, 2018</time></div></div>
								</div>

							</li>


							<li class="no-22">

								<div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2018/05/riverdale-s02e22-review-brave-new-world-archie-puts-a-target-on-his-back/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2018/05/riverdale-s02e22-luke-perry-kj-apa-fred-archie-andrews-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2018/05/riverdale-s02e22-review-brave-new-world-archie-puts-a-target-on-his-back/">Riverdale S02E22 Review: Brave New World &#8211; Archie puts a target on his back</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-05-17">May 17, 2018</time></div></div>
								</div>

							</li>

</ul></div>
								</footer> <!-- end article footer -->

							</article> <!-- end article -->

						
						
					</div> <!-- end #main -->

										

					<style type="text/css">
        .cb-tags a {
            background-color:#1a93db!important;
         }

         .entry-content blockquote:before {
            color: #1a93db;
         }

        .entry-content h2, .entry-content h3, .entry-content h4 {
            color: #1a93db;
        }

         .widget_nav_menu ul li:before, .widget_rss ul li:before, .widget_recent_entries ul li:before, .widget_recent_comments ul li:before, .widget_meta ul li:before, .widget_categories ul li:before, .widget_archive ul li:before, .widget_pages ul li:before, .widget-popular-posts li:before {
            color: #1a93db !important;
         }

         ul.slides {
            background-color: #1a93db;
         }
         .entry-content ul li:before {
            background-color:#1a93db;
         }

    </style><aside class="cb-sidebar clearfix" role="complementary">

<div id="adrotate_widgets-18" class="cb-sidebar-widget widget_adrotate_widgets"><div class="g g-4"><div class="g-single a-15"><script type="text/javascript"><!--
google_ad_client = "ca-pub-4708759492629486";
/* W101-Big-Box */
google_ad_slot = "5509493980";
google_ad_width = 336;
google_ad_height = 280;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div></div></div><div id="text-33" class="cb-sidebar-widget widget_text">			<div class="textwidget"><p style="text-align: center;">Our <a href="https://www.cultofwhatever.com/privacy-policy/"><strong>Privacy Policy</strong></a> has been updated</p>

<div style="text-align: center;"><a
 href="https://www.talkwhateveronline.com">
<img style="border: 0px solid ; width: 336px; height: 58px;"
 alt="Discuss whatever you're into on the forums"
 src="https://www.cultofwhatever.com/wp-content/uploads/2018/03/talk-whatever-online-336-cow.jpg"></a></div>


</div>
		</div>		<div id="recent-posts-5" class="cb-sidebar-widget widget_recent_entries">		<h3 class="cb-sidebar-widget-title">The Latest</h3>		<ul>
											<li>
					<a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/">Riverdale S03E22 Review: Survive the Night &#8211; A very entertaining finale!</a>
									</li>
											<li>
					<a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/">Game of Thrones S08E05: The Bells &#8211; The Mis-match of the Mad Queens</a>
									</li>
											<li>
					<a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e06-review-i-hope-you-like-missionary-a-hard-to-believe-episode/">Killing Eve S02E06 Review: I Hope You Like Missionary! &#8211; A hard-to-believe episode&#8230;</a>
									</li>
											<li>
					<a href="https://www.cultofwhatever.com/2019/05/your-way-too-early-predictions-for-wwe-wrestlemania-36/">Your WAY TOO EARLY Predictions for WWE WrestleMania 36!</a>
									</li>
											<li>
					<a href="https://www.cultofwhatever.com/2019/05/review-grading-detective-pikachu-on-three-levels/">REVIEW: Grading Detective Pikachu on three levels&#8230;</a>
									</li>
											<li>
					<a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e21-review-the-dark-secret-of-harvest-house-unexpected-revelations-from-the-farm/">Riverdale S03E21 Review: The Dark Secret of Harvest House &#8211; Unexpected revelations from The Farm</a>
									</li>
											<li>
					<a href="https://www.cultofwhatever.com/2019/05/star-trek-discovery-review-season-2-has-the-show-jumped-the-shark-or-grown-the-beard/">Star Trek Discovery Review: Season 2 &#8211; Has the show jumped the shark or grown the beard?</a>
									</li>
											<li>
					<a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e04-the-last-of-the-starks-after-last-weeks-divisive-heroics-the-last-war-begins/">Game of Thrones S08E04: The Last of the Starks &#8211; After last week’s divisive heroics, the last war begins</a>
									</li>
											<li>
					<a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e05-review-smell-ya-later-eve-hatches-a-plan/">Killing Eve S02E05 Review: Smell Ya Later &#8211; Eve hatches a plan&#8230;</a>
									</li>
											<li>
					<a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e20-review-prom-night-it-gets-bloody/">Riverdale S03E20 Review: Prom Night &#8211; It gets bloody!</a>
									</li>
					</ul>
		</div><div id="adrotate_widgets-19" class="cb-sidebar-widget widget_adrotate_widgets"><div class="g g-5"><div class="g-single a-16"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- COW-300*600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-4708759492629486"
     data-ad-slot="4657643981"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div><div id="recent-comments-5" class="cb-sidebar-widget widget_recent_comments"><h3 class="cb-sidebar-widget-title">Recent Comments</h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">holy55</span> on <a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e05-review-smell-ya-later-eve-hatches-a-plan/#comment-7035">Killing Eve S02E05 Review: Smell Ya Later &#8211; Eve hatches a plan&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.cultofwhatever.com' rel='external nofollow' class='url'>Salome G</a></span> on <a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/#comment-7034">Game of Thrones S08E05: The Bells &#8211; The Mis-match of the Mad Queens</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.cultofwhatever.com' rel='external nofollow' class='url'>Salome G</a></span> on <a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e06-review-i-hope-you-like-missionary-a-hard-to-believe-episode/#comment-7033">Killing Eve S02E06 Review: I Hope You Like Missionary! &#8211; A hard-to-believe episode&#8230;</a></li><li class="recentcomments"><span class="comment-author-link">Bridget</span> on <a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/#comment-7026">Game of Thrones S08E05: The Bells &#8211; The Mis-match of the Mad Queens</a></li><li class="recentcomments"><span class="comment-author-link">SaveMe</span> on <a href="https://www.cultofwhatever.com/2019/04/review-avengers-endgame-spoiler-filled-observations/#comment-7032">REVIEW: Avengers Endgame &#8211; Spoiler-filled observations</a></li><li class="recentcomments"><span class="comment-author-link">SaveMe</span> on <a href="https://www.cultofwhatever.com/2019/04/game-of-thrones-s08e03-the-long-night-a-song-of-ice-and-arya/#comment-7031">Game of Thrones S08E03: The Long Night &#8211; A Song of Ice and Arya</a></li><li class="recentcomments"><span class="comment-author-link">SaveMe</span> on <a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e05-review-smell-ya-later-eve-hatches-a-plan/#comment-7030">Killing Eve S02E05 Review: Smell Ya Later &#8211; Eve hatches a plan&#8230;</a></li><li class="recentcomments"><span class="comment-author-link">Bridget</span> on <a href="https://www.cultofwhatever.com/2019/03/review-dumbo-makes-me-sad-for-all-the-wrong-reasons/#comment-7029">REVIEW: Dumbo makes me sad for all the wrong reasons</a></li><li class="recentcomments"><span class="comment-author-link">Bridget</span> on <a href="https://www.cultofwhatever.com/2019/05/star-trek-discovery-review-season-2-has-the-show-jumped-the-shark-or-grown-the-beard/#comment-7028">Star Trek Discovery Review: Season 2 &#8211; Has the show jumped the shark or grown the beard?</a></li><li class="recentcomments"><span class="comment-author-link">Bridget</span> on <a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e06-review-i-hope-you-like-missionary-a-hard-to-believe-episode/#comment-7027">Killing Eve S02E06 Review: I Hope You Like Missionary! &#8211; A hard-to-believe episode&#8230;</a></li></ul></div><div id="latest-articles-10" class="cb-sidebar-widget widget_latest-articles"><h3 class="cb-sidebar-widget-title">Recommended for you</h3>
		<ul class="cb-light cb-small">
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1a93db;">
                		<a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/">Riverdale S03E22 Review: Survive the Night &#8211; A very entertaining finale!</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-16">May 16, 2019</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1a93db;">
                		<a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-of-thrones-s08e05-peter-dinklage-tyrion-lannister-2-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-of-thrones-s08e05-peter-dinklage-tyrion-lannister-2-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-of-thrones-s08e05-peter-dinklage-tyrion-lannister-2-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/">Game of Thrones S08E05: The Bells &#8211; The Mis-match of the Mad Queens</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-13">May 13, 2019</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1a93db;">
                		<a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e06-review-i-hope-you-like-missionary-a-hard-to-believe-episode/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e06-jodie-comer-villanelle-2-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e06-jodie-comer-villanelle-2-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e06-jodie-comer-villanelle-2-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e06-review-i-hope-you-like-missionary-a-hard-to-believe-episode/">Killing Eve S02E06 Review: I Hope You Like Missionary! &#8211; A hard-to-believe episode&#8230;</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-13">May 13, 2019</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1a93db;">
                		<a href="https://www.cultofwhatever.com/2019/05/star-trek-discovery-review-season-2-has-the-show-jumped-the-shark-or-grown-the-beard/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e13-crew-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e13-crew-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e13-crew-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2019/05/star-trek-discovery-review-season-2-has-the-show-jumped-the-shark-or-grown-the-beard/">Star Trek Discovery Review: Season 2 &#8211; Has the show jumped the shark or grown the beard?</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-07">May 7, 2019</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1a93db;">
                		<a href="https://www.cultofwhatever.com/2019/04/roswell-new-mexico-s01e13-review-recovering-the-satellites-an-alien-messiah/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/roswell-nm-s01e13-jeanine-mason-liz-ortecho-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/roswell-nm-s01e13-jeanine-mason-liz-ortecho-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/roswell-nm-s01e13-jeanine-mason-liz-ortecho-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2019/04/roswell-new-mexico-s01e13-review-recovering-the-satellites-an-alien-messiah/">Roswell, New Mexico S01E13 Review: Recovering the Satellites &#8211; An alien messiah?</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-24">April 24, 2019</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1a93db;">
                		<a href="https://www.cultofwhatever.com/2019/04/chilling-adventures-of-sabrina-review-part-2-loosey-goosey-plotlines/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/chilling-adventures-sabrina-s2-poster-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/chilling-adventures-sabrina-s2-poster-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/chilling-adventures-sabrina-s2-poster-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2019/04/chilling-adventures-of-sabrina-review-part-2-loosey-goosey-plotlines/">Chilling Adventures of Sabrina Review: Part 2 &#8211; Loosey-goosey plotlines</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-12">April 12, 2019</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1a93db;">
                		<a href="https://www.cultofwhatever.com/2019/04/which-was-the-most-shocking-death-in-game-of-thrones-history/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/04/game-thrones-s6-2-iwan-rheon-bolton-ramsay-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/04/game-thrones-s6-2-iwan-rheon-bolton-ramsay-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/04/game-thrones-s6-2-iwan-rheon-bolton-ramsay-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2019/04/which-was-the-most-shocking-death-in-game-of-thrones-history/">Which was the most shocking death in Game of Thrones&#8217; history?</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-09">April 9, 2019</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1a93db;">
                		<a href="https://www.cultofwhatever.com/2019/04/santa-clarita-diet-review-season-3-best-season-so-far/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/santa-clarita-s3-poster-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/santa-clarita-s3-poster-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/santa-clarita-s3-poster-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2019/04/santa-clarita-diet-review-season-3-best-season-so-far/">Santa Clarita Diet Review: Season 3 &#8211; Best season so far!</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-08">April 8, 2019</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1a93db;">
                		<a href="https://www.cultofwhatever.com/2019/04/the-oa-review-season-2-im-crying-and-confused/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2019/03/oa-s2-emory-cohen-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/03/oa-s2-emory-cohen-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2019/03/oa-s2-emory-cohen-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2019/04/the-oa-review-season-2-im-crying-and-confused/">The OA Review: Season 2 &#8211; I&#8217;m crying and confused!</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-03">April 3, 2019</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1a93db;">
                		<a href="https://www.cultofwhatever.com/2019/02/black-mirror-best-to-best-best/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/11/black-mirror-s3-1-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/11/black-mirror-s3-1-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/11/black-mirror-s3-1-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2019/02/black-mirror-best-to-best-best/">BLACK MIRROR: Best to Best-Best</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-02-21">February 21, 2019</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2018/11/excelsior-remembering-stan-lee-1922-2018/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2018/11/stan-lee-2007-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2018/11/stan-lee-2007-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2018/11/stan-lee-2007-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2018/11/excelsior-remembering-stan-lee-1922-2018/">Excelsior! Remembering Stan Lee, 1922-2018</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-11-13">November 13, 2018</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2018/08/on-disney-owning-fox-what-else-are-they-getting/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2018/08/simpsons-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2018/08/simpsons-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2018/08/simpsons-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2018/08/on-disney-owning-fox-what-else-are-they-getting/">on Disney owning Fox&#8230;what ELSE are they getting?</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-08-22">August 22, 2018</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2018/01/the-dceu-what-happened-and-whats-next/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/11/justice-league-batman-wonder-woman-flash-aquaman-cyborg-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/11/justice-league-batman-wonder-woman-flash-aquaman-cyborg-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/11/justice-league-batman-wonder-woman-flash-aquaman-cyborg-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2018/01/the-dceu-what-happened-and-whats-next/">The DCEU: What happened and what&#8217;s next?</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-01-16">January 16, 2018</time></div></div>                                           </div>
                </li>
    		    	</ul>

    		</div><div id="adrotate_widgets-20" class="cb-sidebar-widget widget_adrotate_widgets"><div class="g g-8"><div class="g-single a-25"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- COW-336-Bottom -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-4708759492629486"
     data-ad-slot="7611110385"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div><div id="text-32" class="cb-sidebar-widget widget_text">			<div class="textwidget"></div>
		</div><div id="rss-6" class="cb-sidebar-widget widget_rss"><h3 class="cb-sidebar-widget-title"><a class="rsswidget" href="https://www.talkwhateveronline.com/forums/-/index.rss"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.cultofwhatever.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.talkwhateveronline.com/">Latest Forum Discussions</a></h3><ul><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/apple-vs-android.65594/'>Apple Vs. Android</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/forgive-and-forget-or-burn-the-bridge.65589/'>Forgive and forget or burn the bridge?</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/the-best-place-to-live.65565/'>The Best Place To Live</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/passing-out-on-amusement-rides.65605/'>Passing Out On Amusement Rides</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/last-second-winning-moments.65599/'>Last-second winning moments</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/accents.65607/'>Accents</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/constance-wus-tweets.65606/'>Constance Wu&#039;s Tweets</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/44-fwl-update-week-8-final-week.65513/'>[44] FWL Update: Week 8 (Final week)</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/changing-climate.65534/'>Changing Climate</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/concert-regrets.65584/'>Concert regrets</a></li></ul></div>
</aside>
					<div id="main" class="cb-full-width clearfix" role="main">
						<h3 style="border-bottom: 4px solid #1a93db">Latest Articles</h3>
						<div id="cb-latest-posts">
													<div class="cb-line clearfix masonry-container">
						        <article id="post-47839" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e22-cole-sprouse-kj-apa-jughead-archie-lili-reinhart-betty-cooper-camila-mendes-veronica.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/">Riverdale S03E22 Review: Survive the Night &#8211; A very entertaining finale!</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-16">May 16, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Season 3 of Riverdale ascends tonight and we're all going to need something a little stronger than maple syrup if we're going to *electric guitar riff* SURVIVE THE NIGHT.</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale/" class="masonry-link-on-hover">
                  <h2 class="h4">Riverdale S03E22 Review: Survive the Night &#8211; A very entertaining finale!</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-16">May 16, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Season 3 of Riverdale ascends tonight and we're all going to need something a little stronger than maple syrup if we're going to *electric guitar riff* SURVIVE THE NIGHT.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47806" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/"><img width="360" height="234" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-of-thrones-s08e05-peter-dinklage-tyrion-lannister-2-360x234.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-of-thrones-s08e05-peter-dinklage-tyrion-lannister-2-360x234.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-of-thrones-s08e05-peter-dinklage-tyrion-lannister-2-300x195.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-of-thrones-s08e05-peter-dinklage-tyrion-lannister-2.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/">Game of Thrones S08E05: The Bells &#8211; The Mis-match of the Mad Queens</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-13">May 13, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">So, what did we all think of that?</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e05-the-bells-the-mis-match-of-the-mad-queens/" class="masonry-link-on-hover">
                  <h2 class="h4">Game of Thrones S08E05: The Bells &#8211; The Mis-match of the Mad Queens</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-13">May 13, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">So, what did we all think of that?</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47780" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e06-review-i-hope-you-like-missionary-a-hard-to-believe-episode/"><img width="360" height="246" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e06-jodie-comer-villanelle-2-360x246.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e06-jodie-comer-villanelle-2-360x246.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e06-jodie-comer-villanelle-2-300x205.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e06-jodie-comer-villanelle-2.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e06-review-i-hope-you-like-missionary-a-hard-to-believe-episode/">Killing Eve S02E06 Review: I Hope You Like Missionary! &#8211; A hard-to-believe episode&#8230;</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-13">May 13, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Everyone dispenses with pesky reality in a hard-to-believe episode this week.</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e06-review-i-hope-you-like-missionary-a-hard-to-believe-episode/" class="masonry-link-on-hover">
                  <h2 class="h4">Killing Eve S02E06 Review: I Hope You Like Missionary! &#8211; A hard-to-believe episode&#8230;</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-13">May 13, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Everyone dispenses with pesky reality in a hard-to-believe episode this week.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47703" class="cb-blog-style-c clearfix cb-last masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#20007f;">
               <a href="https://www.cultofwhatever.com/2019/05/your-way-too-early-predictions-for-wwe-wrestlemania-36/"><img width="360" height="233" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/wrestlemania-36-logo-360x233.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/wrestlemania-36-logo-360x233.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/wrestlemania-36-logo-300x194.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/wrestlemania-36-logo-768x496.jpg 768w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/wrestlemania-36-logo.jpg 800w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/your-way-too-early-predictions-for-wwe-wrestlemania-36/">Your WAY TOO EARLY Predictions for WWE WrestleMania 36!</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-12">May 12, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/blogs/wwe-blogs/" title="View all posts in WWE">WWE</a></div></div>             <div class="cb-excerpt" style="display: none;">Because it's always fun to think about what Vince McMahon will do a year from now when the man himself won't know until three minutes beforehand...THIS is your WAY TOO EARLY predictions for WrestleMania 36!</div>

              <div class="blog-hidden-content" style="background: rgba(32,0,127, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/05/your-way-too-early-predictions-for-wwe-wrestlemania-36/" class="masonry-link-on-hover">
                  <h2 class="h4">Your WAY TOO EARLY Predictions for WWE WrestleMania 36!</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-12">May 12, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/blogs/wwe-blogs/" title="View all posts in WWE">WWE</a></div></div>                   <div class="cb-excerpt" style="display: none;">Because it's always fun to think about what Vince McMahon will do a year from now when the man himself won't know until three minutes beforehand...THIS is your WAY TOO EARLY predictions for WrestleMania 36!</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47762" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#faa200;">
               <a href="https://www.cultofwhatever.com/2019/05/review-grading-detective-pikachu-on-three-levels/"><img width="360" height="238" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/pokemon-detective-pikachu-1-360x238.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/pokemon-detective-pikachu-1-360x238.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/pokemon-detective-pikachu-1-300x198.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/pokemon-detective-pikachu-1.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/review-grading-detective-pikachu-on-three-levels/">REVIEW: Grading Detective Pikachu on three levels&#8230;</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-11">May 11, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-reviews/" title="View all posts in Movie Reviews">Movie Reviews</a></div></div>             <div class="cb-excerpt" style="display: none;">We've come a long way from the bad video game movies of the 1990's. Matthew looks at Detective Pikachu and considers how the movie works as a film, as a video game adaptation, and as the potential for something....bigger. Full review inside...</div>

              <div class="blog-hidden-content" style="background: rgba(250,162,0, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/05/review-grading-detective-pikachu-on-three-levels/" class="masonry-link-on-hover">
                  <h2 class="h4">REVIEW: Grading Detective Pikachu on three levels&#8230;</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-11">May 11, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-reviews/" title="View all posts in Movie Reviews">Movie Reviews</a></div></div>                   <div class="cb-excerpt" style="display: none;">We've come a long way from the bad video game movies of the 1990's. Matthew looks at Detective Pikachu and considers how the movie works as a film, as a video game adaptation, and as the potential for something....bigger. Full review inside...</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47746" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e21-review-the-dark-secret-of-harvest-house-unexpected-revelations-from-the-farm/"><img width="360" height="238" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e21-chad-michael-murray-edgar-evernever-lili-reinhart-betty-cooper-360x238.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e21-chad-michael-murray-edgar-evernever-lili-reinhart-betty-cooper-360x238.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e21-chad-michael-murray-edgar-evernever-lili-reinhart-betty-cooper-300x198.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e21-chad-michael-murray-edgar-evernever-lili-reinhart-betty-cooper.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e21-review-the-dark-secret-of-harvest-house-unexpected-revelations-from-the-farm/">Riverdale S03E21 Review: The Dark Secret of Harvest House &#8211; Unexpected revelations from The Farm</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-09">May 9, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Secrets are finally revealed this week, as Betty learns (one of) the dark secrets behind the Farm and Jughead finds out who is the Gargoyle King is. In the Riverdale way, it makes no and all the sense.</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e21-review-the-dark-secret-of-harvest-house-unexpected-revelations-from-the-farm/" class="masonry-link-on-hover">
                  <h2 class="h4">Riverdale S03E21 Review: The Dark Secret of Harvest House &#8211; Unexpected revelations from The Farm</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-09">May 9, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Secrets are finally revealed this week, as Betty learns (one of) the dark secrets behind the Farm and Jughead finds out who is the Gargoyle King is. In the Riverdale way, it makes no and all the sense.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47553" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/05/star-trek-discovery-review-season-2-has-the-show-jumped-the-shark-or-grown-the-beard/"><img width="360" height="244" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e13-crew-360x244.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e13-crew-360x244.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e13-crew-300x204.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e13-crew.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/star-trek-discovery-review-season-2-has-the-show-jumped-the-shark-or-grown-the-beard/">Star Trek Discovery Review: Season 2 &#8211; Has the show jumped the shark or grown the beard?</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-07">May 7, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Year Two of DISCO is in the books and though two of the fourteen hours were some of Star Trek's best, the other twelve are some of Star Trek's worst. Full season review inside...</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/05/star-trek-discovery-review-season-2-has-the-show-jumped-the-shark-or-grown-the-beard/" class="masonry-link-on-hover">
                  <h2 class="h4">Star Trek Discovery Review: Season 2 &#8211; Has the show jumped the shark or grown the beard?</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-07">May 7, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Year Two of DISCO is in the books and though two of the fourteen hours were some of Star Trek's best, the other twelve are some of Star Trek's worst. Full season review inside...</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47725" class="cb-blog-style-c clearfix cb-last masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e04-the-last-of-the-starks-after-last-weeks-divisive-heroics-the-last-war-begins/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-thrones-s08e04-lena-headey-cersei-lannister-pilou-asbaek-euron-greyjoy-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-thrones-s08e04-lena-headey-cersei-lannister-pilou-asbaek-euron-greyjoy-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-thrones-s08e04-lena-headey-cersei-lannister-pilou-asbaek-euron-greyjoy-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-thrones-s08e04-lena-headey-cersei-lannister-pilou-asbaek-euron-greyjoy-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/game-thrones-s08e04-lena-headey-cersei-lannister-pilou-asbaek-euron-greyjoy.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e04-the-last-of-the-starks-after-last-weeks-divisive-heroics-the-last-war-begins/">Game of Thrones S08E04: The Last of the Starks &#8211; After last week’s divisive heroics, the last war begins</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-06">May 6, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">The morning after the Long Night proves to be just as dramatic and flawed...</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/05/game-of-thrones-s08e04-the-last-of-the-starks-after-last-weeks-divisive-heroics-the-last-war-begins/" class="masonry-link-on-hover">
                  <h2 class="h4">Game of Thrones S08E04: The Last of the Starks &#8211; After last week’s divisive heroics, the last war begins</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-06">May 6, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">The morning after the Long Night proves to be just as dramatic and flawed...</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47707" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e05-review-smell-ya-later-eve-hatches-a-plan/"><img width="360" height="243" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e05-jodie-comer-villanelle-2-360x243.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e05-jodie-comer-villanelle-2-360x243.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e05-jodie-comer-villanelle-2-300x203.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/killing-eve-s02e05-jodie-comer-villanelle-2.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e05-review-smell-ya-later-eve-hatches-a-plan/">Killing Eve S02E05 Review: Smell Ya Later &#8211; Eve hatches a plan&#8230;</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-06">May 6, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Eve makes a Faustian pact to get the truth from The Ghost, because those always go so well. </div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/05/killing-eve-s02e05-review-smell-ya-later-eve-hatches-a-plan/" class="masonry-link-on-hover">
                  <h2 class="h4">Killing Eve S02E05 Review: Smell Ya Later &#8211; Eve hatches a plan&#8230;</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-06">May 6, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Eve makes a Faustian pact to get the truth from The Ghost, because those always go so well. </div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47619" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e20-review-prom-night-it-gets-bloody/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e20-lili-reinhart-betty-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e20-lili-reinhart-betty-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e20-lili-reinhart-betty-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e20-lili-reinhart-betty-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2019/05/riverdale-s03e20-lili-reinhart-betty.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e20-review-prom-night-it-gets-bloody/">Riverdale S03E20 Review: Prom Night &#8211; It gets bloody!</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-02">May 2, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">It's prom night in Riverdale, so unsurprisingly, there are multiple murders. Also, the Farmies may be cannibals. </div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/05/riverdale-s03e20-review-prom-night-it-gets-bloody/" class="masonry-link-on-hover">
                  <h2 class="h4">Riverdale S03E20 Review: Prom Night &#8211; It gets bloody!</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-05-02">May 2, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">It's prom night in Riverdale, so unsurprisingly, there are multiple murders. Also, the Farmies may be cannibals. </div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47000" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/04/killing-eve-s02e04-review-desperate-times-i-expected-something-a-little-more-dazzling/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/killing-eve-s02e04-1-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/killing-eve-s02e04-1-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/killing-eve-s02e04-1-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/killing-eve-s02e04-1-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/killing-eve-s02e04-1.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/killing-eve-s02e04-review-desperate-times-i-expected-something-a-little-more-dazzling/">Killing Eve S02E04 Review: Desperate Times &#8211; I expected something a little more dazzling&#8230;</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-29">April 29, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Nobody likes being ghosted, even when you're an assassin with an amazing wardrobe. </div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/04/killing-eve-s02e04-review-desperate-times-i-expected-something-a-little-more-dazzling/" class="masonry-link-on-hover">
                  <h2 class="h4">Killing Eve S02E04 Review: Desperate Times &#8211; I expected something a little more dazzling&#8230;</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-29">April 29, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Nobody likes being ghosted, even when you're an assassin with an amazing wardrobe. </div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47664" class="cb-blog-style-c clearfix cb-last masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/04/game-of-thrones-s08e03-the-long-night-a-song-of-ice-and-arya/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/game-thrones-s08e03-maisie-williams-arya-stark-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/game-thrones-s08e03-maisie-williams-arya-stark-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/game-thrones-s08e03-maisie-williams-arya-stark-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/game-thrones-s08e03-maisie-williams-arya-stark-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/game-thrones-s08e03-maisie-williams-arya-stark.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/game-of-thrones-s08e03-the-long-night-a-song-of-ice-and-arya/">Game of Thrones S08E03: The Long Night &#8211; A Song of Ice and Arya</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-29">April 29, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">This is the big one people...</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/04/game-of-thrones-s08e03-the-long-night-a-song-of-ice-and-arya/" class="masonry-link-on-hover">
                  <h2 class="h4">Game of Thrones S08E03: The Long Night &#8211; A Song of Ice and Arya</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-29">April 29, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">This is the big one people...</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47636" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#faa200;">
               <a href="https://www.cultofwhatever.com/2019/04/review-avengers-endgame-spoiler-filled-observations/"><img width="360" height="237" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/avengers-endgame-poster-3-360x237.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/avengers-endgame-poster-3-360x237.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/avengers-endgame-poster-3-300x197.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/avengers-endgame-poster-3-768x505.jpg 768w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/avengers-endgame-poster-3.jpg 800w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/review-avengers-endgame-spoiler-filled-observations/">REVIEW: Avengers Endgame &#8211; Spoiler-filled observations</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-27">April 27, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-reviews/" title="View all posts in Movie Reviews">Movie Reviews</a></div></div>             <div class="cb-excerpt" style="display: none;">There aren't adequate words to describe what a visceral and emotional and thoroughly satisfying movie this is.</div>

              <div class="blog-hidden-content" style="background: rgba(250,162,0, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/04/review-avengers-endgame-spoiler-filled-observations/" class="masonry-link-on-hover">
                  <h2 class="h4">REVIEW: Avengers Endgame &#8211; Spoiler-filled observations</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-27">April 27, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-reviews/" title="View all posts in Movie Reviews">Movie Reviews</a></div></div>                   <div class="cb-excerpt" style="display: none;">There aren't adequate words to describe what a visceral and emotional and thoroughly satisfying movie this is.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47633" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#faa200;">
               <a href="https://www.cultofwhatever.com/2019/04/avengers-endgame-is-a-love-letter-to-the-mcu-fanbase-no-spoilers/"><img width="360" height="245" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/avengers-endgame-chris-evans-captain-america-don-cheadle-scarlett-johansson-black-widow-mark-ruffalo-hulk-360x245.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/avengers-endgame-chris-evans-captain-america-don-cheadle-scarlett-johansson-black-widow-mark-ruffalo-hulk-360x245.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/avengers-endgame-chris-evans-captain-america-don-cheadle-scarlett-johansson-black-widow-mark-ruffalo-hulk-300x204.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/avengers-endgame-chris-evans-captain-america-don-cheadle-scarlett-johansson-black-widow-mark-ruffalo-hulk.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/avengers-endgame-is-a-love-letter-to-the-mcu-fanbase-no-spoilers/">AVENGERS ENDGAME is a love letter to the MCU fanbase (no spoilers)</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-27">April 27, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-blogs/" title="View all posts in Movie Blogs">Movie Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Endgame does the near-impossible: It sticks the landing after ten years of flying higher than anyone ever imagined</div>

              <div class="blog-hidden-content" style="background: rgba(250,162,0, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/04/avengers-endgame-is-a-love-letter-to-the-mcu-fanbase-no-spoilers/" class="masonry-link-on-hover">
                  <h2 class="h4">AVENGERS ENDGAME is a love letter to the MCU fanbase (no spoilers)</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-27">April 27, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-blogs/" title="View all posts in Movie Blogs">Movie Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Endgame does the near-impossible: It sticks the landing after ten years of flying higher than anyone ever imagined</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47509" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#faa200;">
               <a href="https://www.cultofwhatever.com/2019/04/the-matrix-is-still-awesome-twenty-years-later/"><img width="360" height="237" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/matrix-keanu-reeves-neo-3-360x237.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/matrix-keanu-reeves-neo-3-360x237.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/matrix-keanu-reeves-neo-3-300x198.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/matrix-keanu-reeves-neo-3.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/the-matrix-is-still-awesome-twenty-years-later/">The Matrix is still awesome&#8230;twenty years later</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-26">April 26, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-blogs/" title="View all posts in Movie Blogs">Movie Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Twenty years ago Star Wars Episode I dominated pop culture, but bubbling under the surface was a small, indie-feeling sci-fi film with a much smaller budget and much bigger ambitions...</div>

              <div class="blog-hidden-content" style="background: rgba(250,162,0, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/04/the-matrix-is-still-awesome-twenty-years-later/" class="masonry-link-on-hover">
                  <h2 class="h4">The Matrix is still awesome&#8230;twenty years later</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-26">April 26, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-blogs/" title="View all posts in Movie Blogs">Movie Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Twenty years ago Star Wars Episode I dominated pop culture, but bubbling under the surface was a small, indie-feeling sci-fi film with a much smaller budget and much bigger ambitions...</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47613" class="cb-blog-style-c clearfix cb-last masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/04/riverdale-s03e19-review-fear-the-reaper-a-wild-jellybean-chase/"><img width="360" height="235" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/riverdale-s03e19-cole-sprouse-jughead-skeet-ulrich-fp-jones-gina-gershon-gladys-360x235.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/riverdale-s03e19-cole-sprouse-jughead-skeet-ulrich-fp-jones-gina-gershon-gladys-360x235.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/riverdale-s03e19-cole-sprouse-jughead-skeet-ulrich-fp-jones-gina-gershon-gladys-300x196.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/riverdale-s03e19-cole-sprouse-jughead-skeet-ulrich-fp-jones-gina-gershon-gladys.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/riverdale-s03e19-review-fear-the-reaper-a-wild-jellybean-chase/">Riverdale S03E19 Review: Fear the Reaper &#8211; A wild Jellybean chase</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-25">April 25, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">The Joneses go on a wild Jellybean chase, while Betty finds out yet another secret about the Farm. Meanwhile, Salome just wants to know why no one will tip over the Gargoyle King when they see him. He's just a guy on stilts!</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/04/riverdale-s03e19-review-fear-the-reaper-a-wild-jellybean-chase/" class="masonry-link-on-hover">
                  <h2 class="h4">Riverdale S03E19 Review: Fear the Reaper &#8211; A wild Jellybean chase</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-25">April 25, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">The Joneses go on a wild Jellybean chase, while Betty finds out yet another secret about the Farm. Meanwhile, Salome just wants to know why no one will tip over the Gargoyle King when they see him. He's just a guy on stilts!</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-46244" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/04/roswell-new-mexico-s01e13-review-recovering-the-satellites-an-alien-messiah/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/roswell-nm-s01e13-jeanine-mason-liz-ortecho-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/roswell-nm-s01e13-jeanine-mason-liz-ortecho-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/roswell-nm-s01e13-jeanine-mason-liz-ortecho-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/roswell-nm-s01e13-jeanine-mason-liz-ortecho-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/roswell-nm-s01e13-jeanine-mason-liz-ortecho.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/roswell-new-mexico-s01e13-review-recovering-the-satellites-an-alien-messiah/">Roswell, New Mexico S01E13 Review: Recovering the Satellites &#8211; An alien messiah?</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-24">April 24, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Roswell, New Mexico's first (AND HOPEFULLY, NOT LAST) season ends with a stunning revelation.</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/04/roswell-new-mexico-s01e13-review-recovering-the-satellites-an-alien-messiah/" class="masonry-link-on-hover">
                  <h2 class="h4">Roswell, New Mexico S01E13 Review: Recovering the Satellites &#8211; An alien messiah?</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-24">April 24, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Roswell, New Mexico's first (AND HOPEFULLY, NOT LAST) season ends with a stunning revelation.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47589" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/04/game-of-thrones-s08e02-the-knight-of-the-seven-kingdoms-everyone-at-winterfell-faces-what-could-be-their-last-night-in-this-world/"><img width="360" height="241" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/game-thrones-s08e2-john-bradley-samwell-tarly-360x241.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/game-thrones-s08e2-john-bradley-samwell-tarly-360x241.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/game-thrones-s08e2-john-bradley-samwell-tarly-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/game-thrones-s08e2-john-bradley-samwell-tarly-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/game-thrones-s08e2-john-bradley-samwell-tarly.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/game-of-thrones-s08e02-the-knight-of-the-seven-kingdoms-everyone-at-winterfell-faces-what-could-be-their-last-night-in-this-world/">Game of Thrones S08E02: The Knight of the Seven Kingdoms &#8211; Everyone at Winterfell faces what could be their last night  ...</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-22">April 22, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Game of Thrones asks, "Another drink before the war?"</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/04/game-of-thrones-s08e02-the-knight-of-the-seven-kingdoms-everyone-at-winterfell-faces-what-could-be-their-last-night-in-this-world/" class="masonry-link-on-hover">
                  <h2 class="h4">Game of Thrones S08E02: The Knight of the Seven Kingdoms &#8211; Everyone at Winterfell faces what could be their last night in this world</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-22">April 22, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Game of Thrones asks, "Another drink before the war?"</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-46999" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/04/killing-eve-s02e03-review-the-hungry-caterpillar-obsessed-with-villanelle/"><img width="360" height="233" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/killing-eve-s02e03-sandra-oh-eve-polastri-owen-mcdonnell-niko-360x233.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/killing-eve-s02e03-sandra-oh-eve-polastri-owen-mcdonnell-niko-360x233.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/killing-eve-s02e03-sandra-oh-eve-polastri-owen-mcdonnell-niko-300x194.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/killing-eve-s02e03-sandra-oh-eve-polastri-owen-mcdonnell-niko.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/killing-eve-s02e03-review-the-hungry-caterpillar-obsessed-with-villanelle/">Killing Eve S02E03 Review: The Hungry Caterpillar &#8211; Obsessed with Villanelle!</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-22">April 22, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Villanelle gets a reset this week, while Eve's fascination with her causes problems both at home and on the job.</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/04/killing-eve-s02e03-review-the-hungry-caterpillar-obsessed-with-villanelle/" class="masonry-link-on-hover">
                  <h2 class="h4">Killing Eve S02E03 Review: The Hungry Caterpillar &#8211; Obsessed with Villanelle!</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-22">April 22, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Villanelle gets a reset this week, while Eve's fascination with her causes problems both at home and on the job.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-47556" class="cb-blog-style-c clearfix cb-last masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2019/04/star-trek-discovery-s02e14-and-with-that-season-two-is-over/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e414-anson-mount-captain-christopher-pike-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e414-anson-mount-captain-christopher-pike-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e414-anson-mount-captain-christopher-pike-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e414-anson-mount-captain-christopher-pike-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2019/04/star-trek-discovery-s02e414-anson-mount-captain-christopher-pike.jpg 750w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2019/04/star-trek-discovery-s02e14-and-with-that-season-two-is-over/">Star Trek Discovery S02E14: And with that, season two is over&#8230;</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-19">April 19, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Star Trek Discovery's second season has wrapped and with it come new opportunities for the future. Hopefully one that they explore is the chance to tell logical stories again...</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2019/04/star-trek-discovery-s02e14-and-with-that-season-two-is-over/" class="masonry-link-on-hover">
                  <h2 class="h4">Star Trek Discovery S02E14: And with that, season two is over&#8230;</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2019-04-19">April 19, 2019</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Star Trek Discovery's second season has wrapped and with it come new opportunities for the future. Hopefully one that they explore is the chance to tell logical stories again...</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
</div>							</div>
						</div>
					</div>

			</div> <!-- end #cb-content -->

     			<footer id="cb-footer" class=" wrap" role="contentinfo">

    				<div id="cb-widgets" class="cb-footer-b wrap clearfix">

                                                    <div class="cb-one cb-column clearfix">
                                <div id="nav_menu-3" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>Movies</span></h3><div class="menu-movies-container"><ul id="menu-movies" class="menu"><li id="menu-item-24175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24175"><a href="https://www.cultofwhatever.com/movies/">Movies</a></li>
<li id="menu-item-24177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24177"><a href="https://www.cultofwhatever.com/movies/movie-blogs/">Movie Blogs</a></li>
<li id="menu-item-24179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24179"><a href="https://www.cultofwhatever.com/movies/movie-reviews/">Movie Reviews</a></li>
</ul></div></div>                            </div>
                                                                            <div class="cb-two cb-column clearfix">
                                <div id="nav_menu-7" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>Music</span></h3><div class="menu-music-container"><ul id="menu-music" class="menu"><li id="menu-item-41525" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41525"><a href="https://www.cultofwhatever.com/music/">Music</a></li>
<li id="menu-item-41526" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41526"><a href="https://www.cultofwhatever.com/music/music-blogs/">Music Blogs</a></li>
</ul></div></div>                            </div>
                                                                            <div class="cb-three cb-column clearfix">
                                <div id="nav_menu-4" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>TV</span></h3><div class="menu-tv-container"><ul id="menu-tv" class="menu"><li id="menu-item-24180" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-24180"><a href="https://www.cultofwhatever.com/tv/">TV</a></li>
<li id="menu-item-24181" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24181"><a href="https://www.cultofwhatever.com/tv/tv-blogs/">TV Blogs</a></li>
</ul></div></div>                            </div>
                                                                            <div class="cb-four cb-column clearfix">
                                <div id="nav_menu-5" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>Video Games</span></h3><div class="menu-video-games-container"><ul id="menu-video-games" class="menu"><li id="menu-item-24183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24183"><a href="https://www.cultofwhatever.com/video-games/">Video Games</a></li>
<li id="menu-item-24184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24184"><a href="https://www.cultofwhatever.com/video-games/video-game-blogs/">Video Game Blogs</a></li>
<li id="menu-item-24186" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24186"><a href="https://www.cultofwhatever.com/video-games/video-games-reviews/">Video Game Reviews</a></li>
</ul></div></div>                            </div>
                        						
						                            <div class="cb-five cb-column clearfix">
                                <div id="nav_menu-6" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>Wrestling</span></h3><div class="menu-wrestling-container"><ul id="menu-wrestling" class="menu"><li id="menu-item-24187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24187"><a href="https://www.cultofwhatever.com/wrestling/">Wrestling</a></li>
<li id="menu-item-24188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24188"><a href="https://www.cultofwhatever.com/wrestling/blogs/">Wrestling Blogs</a></li>
<li id="menu-item-24191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24191"><a href="https://www.cultofwhatever.com/wrestling/interviews/">Wrestling Interviews</a></li>
<li id="menu-item-24195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24195"><a href="https://www.cultofwhatever.com/wrestling/show-reports/">WWE Show Reports</a></li>
<li id="menu-item-24192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24192"><a href="https://www.cultofwhatever.com/wrestling/wrestling-news/">Wrestling News</a></li>
<li id="menu-item-24193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24193"><a href="https://www.cultofwhatever.com/wrestling/reviews/">Wrestling Reviews</a></li>
<li id="menu-item-24190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24190"><a href="https://www.cultofwhatever.com/wrestling/gallery/">Wrestling Galleries</a></li>
</ul></div></div>                            </div>
                        						
												<div class="clearfix cb-hottopics">
							<div id="text-36" class="cb-footer-widget widget_text">			<div class="textwidget"><hr>
</div>
		</div>						</div>
												
						                            <div class="cb-one cb-column clearfix subtopics">
                                <div id="nav_menu-8" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>Movie Topics</span></h3><div class="menu-movies-sub-container"><ul id="menu-movies-sub" class="menu"><li id="menu-item-41527" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41527"><a href="https://www.cultofwhatever.com/tag/action-movies/">Action Movies</a></li>
<li id="menu-item-41528" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41528"><a href="https://www.cultofwhatever.com/tag/adventure-movies/">Adventure Movies</a></li>
<li id="menu-item-41560" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41560"><a href="https://www.cultofwhatever.com/tag/comic-book-movies/">Comic Book Movies</a></li>
<li id="menu-item-41561" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41561"><a href="https://www.cultofwhatever.com/tag/family-movies/">Family Movies</a></li>
<li id="menu-item-41562" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41562"><a href="https://www.cultofwhatever.com/tag/fantasy-movies/">Fantasy Movies</a></li>
<li id="menu-item-41563" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41563"><a href="https://www.cultofwhatever.com/tag/horror-movies/">Horror Movies</a></li>
<li id="menu-item-41564" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41564"><a href="https://www.cultofwhatever.com/tag/thriller-movies/">Thriller Movies</a></li>
<li id="menu-item-41565" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41565"><a href="https://www.cultofwhatever.com/tag/sci-fi-movies/">Sci-Fi Movies</a></li>
<li id="menu-item-44213" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-44213"><a href="https://www.cultofwhatever.com/tag/dc-universe/">DC Universe</a></li>
<li id="menu-item-41534" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41534"><a href="https://www.cultofwhatever.com/tag/disney/">Disney</a></li>
<li id="menu-item-41533" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41533"><a href="https://www.cultofwhatever.com/tag/marvel/">Marvel</a></li>
<li id="menu-item-41532" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41532"><a href="https://www.cultofwhatever.com/tag/star-wars/">Star Wars</a></li>
</ul></div></div>                            </div>
                        						                            <div class="cb-two cb-column clearfix subtopics">
                                <div id="nav_menu-9" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>Music Topics</span></h3><div class="menu-music-sub-container"><ul id="menu-music-sub" class="menu"><li id="menu-item-41535" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41535"><a href="https://www.cultofwhatever.com/tag/elvis-presley/">Elvis Presley</a></li>
<li id="menu-item-41536" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41536"><a href="https://www.cultofwhatever.com/tag/beatles/">The Beatles</a></li>
</ul></div></div>                            </div>
                        						                            <div class="cb-three cb-column clearfix subtopics">
                                <div id="nav_menu-10" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>TV Topics</span></h3><div class="menu-tv-sub-container"><ul id="menu-tv-sub" class="menu"><li id="menu-item-41537" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41537"><a href="https://www.cultofwhatever.com/tag/doctor-who/">Doctor Who</a></li>
<li id="menu-item-41538" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41538"><a href="https://www.cultofwhatever.com/tag/game-of-thrones/">Game of Thrones</a></li>
<li id="menu-item-44862" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-44862"><a href="https://www.cultofwhatever.com/tag/killing-eve/">Killing Eve</a></li>
<li id="menu-item-41539" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41539"><a href="https://www.cultofwhatever.com/tag/legion/">Legion</a></li>
<li id="menu-item-41540" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41540"><a href="https://www.cultofwhatever.com/tag/netflix/">Netflix</a></li>
<li id="menu-item-41541" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41541"><a href="https://www.cultofwhatever.com/tag/star-trek/">Star Trek</a></li>
<li id="menu-item-41542" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41542"><a href="https://www.cultofwhatever.com/tag/star-trek-discovery/">Star Trek Discovery</a></li>
<li id="menu-item-41543" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41543"><a href="https://www.cultofwhatever.com/tag/the-walking-dead/">The Walking Dead</a></li>
<li id="menu-item-41544" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41544"><a href="https://www.cultofwhatever.com/tag/the-x-files/">The X-Files</a></li>
<li id="menu-item-41545" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41545"><a href="https://www.cultofwhatever.com/tag/vikings/">Vikings</a></li>
<li id="menu-item-41546" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41546"><a href="https://www.cultofwhatever.com/tag/westworld/">Westworld</a></li>
<li id="menu-item-46279" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-46279"><a href="https://www.cultofwhatever.com/tag/you/">You</a></li>
</ul></div></div>                            </div>
                        						                            <div class="cb-four cb-column clearfix subtopics">
                                <div id="nav_menu-11" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>Video Game Topics</span></h3><div class="menu-video-games-sub-container"><ul id="menu-video-games-sub" class="menu"><li id="menu-item-41547" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41547"><a href="https://www.cultofwhatever.com/tag/nintendo/">Nintendo</a></li>
<li id="menu-item-41548" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41548"><a href="https://www.cultofwhatever.com/tag/nintendo-switch/">Nintendo Switch</a></li>
<li id="menu-item-41677" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41677"><a href="https://www.cultofwhatever.com/tag/wrestling-video-games/">Wrestling Video Games</a></li>
<li id="menu-item-41678" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41678"><a href="https://www.cultofwhatever.com/tag/wwe-video-games/">WWE Video Games</a></li>
</ul></div></div>                            </div>
                        						                            <div class="cb-five cb-column clearfix subtopics">
                                <div id="nav_menu-12" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>Wrestling Topics</span></h3><div class="menu-wrestling-sub-container"><ul id="menu-wrestling-sub" class="menu"><li id="menu-item-41550" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41550"><a href="https://www.cultofwhatever.com/tag/wwe-royal-rumble/">WWE Royal Rumble</a></li>
<li id="menu-item-41551" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41551"><a href="https://www.cultofwhatever.com/tag/wwe-summerslam/">WWE SummerSlam</a></li>
<li id="menu-item-41552" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41552"><a href="https://www.cultofwhatever.com/tag/wwe-survivor-series/">WWE Survivor Series</a></li>
<li id="menu-item-41553" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41553"><a href="https://www.cultofwhatever.com/tag/wwe-wrestlemania/">WWE Wrestlemania</a></li>
<li id="menu-item-41554" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41554"><a href="https://www.cultofwhatever.com/tag/attitude-era/">Attitude Era</a></li>
<li id="menu-item-41555" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41555"><a href="https://www.cultofwhatever.com/tag/improving-wwe/">Improving WWE</a></li>
<li id="menu-item-41556" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41556"><a href="https://www.cultofwhatever.com/tag/john-cena/">John Cena</a></li>
<li id="menu-item-41557" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41557"><a href="https://www.cultofwhatever.com/tag/roman-reigns/">Roman Reigns</a></li>
<li id="menu-item-41558" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41558"><a href="https://www.cultofwhatever.com/tag/wwe-cartoons/">WWE Cartoons</a></li>
<li id="menu-item-41559" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41559"><a href="https://www.cultofwhatever.com/tag/wwe-top-10-lists/">WWE Top 10 Lists</a></li>
</ul></div></div>                            </div>
                                                

                    </div>

                     <div class="footer-h-menu">
                        <div class="menu-info-links-container"><ul id="menu-info-links" class="menu"><li id="menu-item-24197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24197"><a href="https://www.cultofwhatever.com/about-us/">About Us</a></li>
<li id="menu-item-24198" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24198"><a href="https://www.cultofwhatever.com/advertising/">Advertising</a></li>
<li id="menu-item-24200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24200"><a href="https://www.cultofwhatever.com/contact/">Contact Us</a></li>
<li id="menu-item-43244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43244"><a href="https://www.cultofwhatever.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-24201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24201"><a href="https://www.cultofwhatever.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-24199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24199"><a href="https://www.cultofwhatever.com/commenting-policy/">Commenting Policy</a></li>
<li id="menu-item-24202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24202"><a href="https://www.cultofwhatever.com/photo-credits/">Photo Credits</a></li>
<li id="menu-item-24390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24390"><a href="https://www.cultofwhatever.com/rss-feeds/">RSS</a></li>
<li id="menu-item-24204" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24204"><a href="https://www.cultofwhatever.com/write-for-us/">Write For Us</a></li>
</ul></div>                    </div>

                    
                        <div class="cb-footer-lower clearfix">

                            <div class="wrap clearfix">

                                <div class="cb-copyright">All Cult of Whatever articles, logos, illustrations and graphics are copyright CultOfWhatever.com. All other trademarks, logos and copyrights are the property of their respective owners. © 2018 CultOfWhatever. All Rights Reserved.</div>

        						
                                    <div class="footer-badge">
                                    <a title=""><img src="https://www.cultofwhatever.com/wp-content/themes/valenti/images/footer-badge.jpg"></a>
                                </div>

           					</div>

        				</div>
    				
    			</footer> <!-- end footer -->

    		</div> <!-- end #cb-container -->

		</div> <!-- end #cb-outer-container -->

		<script type='text/javascript' src='//assets.consentready.com/js/consentReady.js?ver=1.1.0'></script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-60765351-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', '<GA_TRACKING_ID>', { 'anonymize_ip': true });

  gtag('config', 'UA-60765351-1');
</script>


<!-- Default Statcounter code for Cult of Whatever
https://www.cultofwhatever.com -->
<script type="text/javascript">
var sc_project=10343041; 
var sc_invisible=1; 
var sc_security="d327d034"; 
</script>
<script type="text/javascript"
src="https://www.statcounter.com/counter/counter.js"
async></script>
<noscript><div class="statcounter"><a title="Web Analytics"
href="http://statcounter.com/" target="_blank"><img
class="statcounter"
src="//c.statcounter.com/10343041/0/d327d034/1/" alt="Web
Analytics"></a></div></noscript>
<!-- End of Statcounter Code --> <script type='text/javascript'>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</script><script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js?ver=0.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"wrestling101"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"47839 https:\/\/www.cultofwhatever.com\/?p=47839","disqusShortname":"wrestling101","disqusTitle":"Riverdale S03E22 Review: Survive the Night \u2013 A very entertaining finale!","disqusUrl":"https:\/\/www.cultofwhatever.com\/2019\/05\/riverdale-s03e22-review-survive-the-night-a-very-entertaining-finale\/","postId":"47839"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=11.9.1'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/comment-reply.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/jquery.flexslider-min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/cookie.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/selectivizr-min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/jquery.fs.boxer.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/jquery.ext.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/cb-scripts.js?ver=3.2'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti-child/js/scripts.js'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/wp-embed.min.js?ver=4.9.10'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
var tracker_url = 'https://www.cultofwhatever.com/wp-content/plugins/adrotate-pro/library/clicktracker.php';
</script>
<!-- /AdRotate JS -->


       
        



	</body>

</html> <!-- The End. what a ride! -->