
<!DOCTYPE html>

<!--[if lt IE 7]><html  xmlns:og="//ogp.me/ns#" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html  xmlns:og="//ogp.me/ns#" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html  xmlns:og="//ogp.me/ns#" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html  xmlns:og="//ogp.me/ns#" class="no-js"><!--<![endif]-->

	<head>

		<meta charset="utf-8">

		<!-- Google Chrome Frame for IE -->
		<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]-->

        <title>Episode III sucked too: Coming to grips with the disappointment of the Prequels.</title>
        <link href='https://fonts.googleapis.com/css?family=Knewave' rel='stylesheet' type='text/css'>
		<!-- mobile meta -->
                    <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
        
		<link rel="shortcut icon" href="/favicon-16x16.png">

		<link rel="pingback" href="https://www.cultofwhatever.com/xmlrpc.php">

		<!-- Holding main menu -->
		
		<!-- head functions -->
		
<!-- All in One SEO Pack 2.3.11.1 by Michael Torbert of Semper Fi Web Design[558,654] -->
<link rel="author" href="http://103477281773012458978" />
<meta name="description"  content="It's only by a combination of smoke and mirrors and willful self-delusion that fans look back fondly on Episode III, was it as good as you think it was?" />

<meta name="keywords"  content="star wars,prequel trilogy,revenge of the sith" />

<link rel="canonical" href="https://www.cultofwhatever.com/2015/05/episode-iii-sucked-too-coming-to-grips-with-the-disappointment-of-the-prequels/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Cult of Whatever &raquo; Feed" href="https://www.cultofwhatever.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cult of Whatever &raquo; Comments Feed" href="https://www.cultofwhatever.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cult of Whatever &raquo; Episode III sucked too: Coming to grips with the disappointment of the Prequels. Comments Feed" href="https://www.cultofwhatever.com/2015/05/episode-iii-sucked-too-coming-to-grips-with-the-disappointment-of-the-prequels/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.cultofwhatever.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='login-with-ajax-css'  href='https://www.cultofwhatever.com/wp-content/themes/valenti/plugins/login-with-ajax/widget.css?ver=3.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='disqus_rcw-css'  href='https://www.cultofwhatever.com/wp-content/plugins/disqus-recent-comments-widget/disqus_rcw.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css'  href='https://www.cultofwhatever.com/wp-content/plugins/wordpress-popular-posts/style/wpp.css?ver=3.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css'  href='https://www.cultofwhatever.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=4.7.3' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='cb-main-stylesheet-css'  href='https://www.cultofwhatever.com/wp-content/themes/valenti/library/css/style.css?ver=3.2' type='text/css' media='all' />
<link rel='stylesheet' id='cb-font-stylesheet-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C700%2C400italic%7COpen+Sans%3A400%2C700%2C400italic&#038;subset=greek%2Cgreek-ext&#038;ver=3.2' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://www.cultofwhatever.com/wp-content/themes/valenti/library/css/fontawesome/css/font-awesome.min.css?ver=4.1.0' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='cb-ie-only-css'  href='https://www.cultofwhatever.com/wp-content/themes/valenti/library/css/ie.css?ver=3.2' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='cb-child-stylesheet-css'  href='https://www.cultofwhatever.com/wp-content/themes/valenti-child/style.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var LWA = {"ajaxurl":"https:\/\/www.cultofwhatever.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/plugins/login-with-ajax/login-with-ajax.js?ver=3.1.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/www.cultofwhatever.com\/wp-admin\/admin-ajax.php","security":"3f9713a6ea","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/www.cultofwhatever.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"11.5","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/modernizr.custom.min.js?ver=2.6.2'></script>
<link rel='https://api.w.org/' href='https://www.cultofwhatever.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.cultofwhatever.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.cultofwhatever.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.3" />
<link rel='shortlink' href='https://www.cultofwhatever.com/?p=25856' />
<link rel="alternate" type="application/json+oembed" href="https://www.cultofwhatever.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cultofwhatever.com%2F2015%2F05%2Fepisode-iii-sucked-too-coming-to-grips-with-the-disappointment-of-the-prequels%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.cultofwhatever.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cultofwhatever.com%2F2015%2F05%2Fepisode-iii-sucked-too-coming-to-grips-with-the-disappointment-of-the-prequels%2F&#038;format=xml" />

<!-- This site is using AdRotate v3.11.2 Professional to display their advertisements - https://www.adrotateplugin.com/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px 1px 1px 1px; }
	.g-2 { margin:1px 1px 1px 1px; }
	.g-3 { margin:1px 1px 1px 1px; }
	.g-4 { margin:1px 1px 1px 1px; }
	.g-5 { margin:1px 1px 1px 1px; }
	.g-6 { margin:1px 1px 1px 1px; }
	.g-7 { margin:1px 1px 1px 1px; }
	.g-8 { margin:1px 1px 1px 1px; }
	.g-9 { margin:1px 1px 1px 1px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<!-- Fedmich facebook/digg thumbnail v1.15.6 -->
<meta property="og:title" content="Episode III sucked too: Coming to grips with the disappointment of the Prequels.">
<meta property="og:site_name" content="Cult of Whatever">
<meta property="og:url" content="https://www.cultofwhatever.com/2015/05/episode-iii-sucked-too-coming-to-grips-with-the-disappointment-of-the-prequels/">
<meta property="og:locale" content="en_us">
<link rel="image_src" href="//i4.ytimg.com/vi/ZW8UReCYyRQ/default.jpg" />
<meta property="og:image" content="//i4.ytimg.com/vi/ZW8UReCYyRQ/default.jpg" />
<meta property="og:image" content="//i4.ytimg.com/vi/ZW8UReCYyRQ/0.jpg" />
<meta property="og:image" content="//i4.ytimg.com/vi/ZW8UReCYyRQ/1.jpg" />
<meta property="og:image" content="//i4.ytimg.com/vi/ZW8UReCYyRQ/2.jpg" />
<link rel="video_src" href="//www.youtube.com/v/ZW8UReCYyRQ&hl=en&fs=1&rel=0&autoplay=1" />
<meta property="og:video" content="//www.youtube.com/v/ZW8UReCYyRQ&hl=en&fs=1&rel=0&autoplay=1">
<!-- /Fedmich facebook/digg thumbnail -->
<style>.cb-overlay-stars .fa-star, #cb-vote .fa-star, #cb-to-top .fa-long-arrow-up, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, .bbp-submit-wrapper button:visited, .buddypress .cb-cat-header #cb-cat-title a,  .buddypress .cb-cat-header #cb-cat-title a:visited, .woocommerce .star-rating:before, .woocommerce-page .star-rating:before, .woocommerce .star-rating span, .woocommerce-page .star-rating span {
            color:#faa200;
        }#cb-search-modal .cb-header, .cb-join-modal .cb-header, .lwa .cb-header, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            border-color: #faa200;
        }.cb-sidebar-widget .cb-sidebar-widget-title, .cb-multi-widget .tabbernav .tabberactive, .cb-author-page .cb-author-details .cb-meta .cb-author-page-contact, .cb-about-page .cb-author-line .cb-author-details .cb-meta .cb-author-page-contact, .cb-page-header, .cb-404-header, .cb-cat-header, #cb-footer #cb-widgets .cb-footer-widget-title span, #wp-calendar caption, .cb-tabs ul .current, #bbpress-forums li.bbp-header, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li.selected, #buddypress div.item-list-tabs ul li.current, #buddypress .item-list-tabs ul li:hover, .woocommerce div.product .woocommerce-tabs ul.tabs li.active {
            border-bottom-color: #faa200 ;
        }#cb-main-menu .current-post-ancestor, #cb-main-menu .current-menu-item, #cb-main-menu .current-menu-ancestor, #cb-main-menu .current-post-parent, #cb-main-menu .current-menu-parent, #cb-main-menu .current_page_item, #cb-main-menu .current-page-ancestor, #cb-main-menu .current-category-ancestor, .cb-review-box .cb-bar .cb-overlay span, #cb-accent-color, .cb-highlight, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            background-color: #faa200;
        }</style><style type="text/css">
                                                 body, #respond { font-family: 'Open Sans', sans-serif; }
                                                 h1, h2, h3, h4, h5, h6, .h1, .h2, .h3, .h4, .h5, .h6, #cb-nav-bar #cb-main-menu ul li > a, .cb-breaking-news span, .cb-grid-4 h2 a, .cb-grid-5 h2 a, .cb-grid-6 h2 a, .cb-author-posts-count, .cb-author-title, .cb-author-position, .search  .s, .cb-review-box .cb-bar, .cb-review-box .cb-score-box, .cb-review-box .cb-title, #cb-review-title, .cb-title-subtle, #cb-top-menu a, .tabbernav, .cb-byline, #cb-next-link a, #cb-previous-link a, .cb-review-ext-box .cb-score, .tipper-positioner, .cb-caption, .cb-button, #wp-calendar caption, .forum-titles, .bbp-submit-wrapper button, #bbpress-forums li.bbp-header, #bbpress-forums fieldset.bbp-form .bbp-the-content-wrapper input, #bbpress-forums .bbp-forum-title, #bbpress-forums .bbp-topic-permalink, .widget_display_stats dl dt, .cb-lwa-profile .cb-block, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li, #buddypress .activity-list li.load-more, #buddypress a.activity-time-since, #buddypress ul#groups-list li div.meta, .widget.buddypress div.item-options, .cb-activity-stream #buddypress .activity-header .time-since, .cb-font-header, .woocommerce table.shop_table th, .woocommerce-page table.shop_table th, .cb-infinite-scroll a, .cb-no-more-posts { font-family:'Oswald', sans-serif; }
                     </style><link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png">
<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192">
<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96">
<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16">
<link rel="manifest" href="/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="/mstile-144x144.png">
<meta name="theme-color" content="#ffffff">

<!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f2c87727d2c01c3" async="async"></script>
<style type="text/css">#cb-top-menu .cb-breaking-news ul li a { color:#808080; }#cb-nav-logo { margin-right: 100px!important; }</style><!-- end custom css --><meta property="og:image" content="https://www.cultofwhatever.com/wp-content/uploads/2015/05/sw-bg3.jpg">		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
						<!-- WordPress Popular Posts v3.3.4 -->
				<script type="text/javascript">

					var sampling_active = 0;
					var sampling_rate   = 100;
					var do_request = false;

					if ( !sampling_active ) {
						do_request = true;
					} else {
						var num = Math.floor(Math.random() * sampling_rate) + 1;
						do_request = ( 1 === num );
					}

					if ( do_request ) {

						/* Create XMLHttpRequest object and set variables */
						var xhr = ( window.XMLHttpRequest )
						  ? new XMLHttpRequest()
						  : new ActiveXObject( "Microsoft.XMLHTTP" ),
						url = 'https://www.cultofwhatever.com/wp-admin/admin-ajax.php',
						params = 'action=update_views_ajax&token=5c7f052235&wpp_id=25856';
						/* Set request method and target URL */
						xhr.open( "POST", url, true );
						/* Set request header */
						xhr.setRequestHeader( "Content-type", "application/x-www-form-urlencoded" );
						/* Hook into onreadystatechange */
						xhr.onreadystatechange = function() {
							if ( 4 === xhr.readyState && 200 === xhr.status ) {
								if ( window.console && window.console.log ) {
									window.console.log( xhr.responseText );
								}
							}
						};
						/* Send request */
						xhr.send( params );

					}

				</script>
				<!-- End WordPress Popular Posts v3.3.4 -->
				<style>#cb-nav-bar #cb-main-menu .main-nav .menu-item-24169:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169 .cb-sub-menu { background:#faa200!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#faa200!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24170:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170 .cb-sub-menu { background:#1a93db!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#1a93db!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24171:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171 .cb-sub-menu { background:#24bc3a!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#24bc3a!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24172:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172 .cb-sub-menu { background:#20007f!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#20007f!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24173:hover,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24173:focus,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24173 .cb-sub-menu li .cb-grandchild-menu,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24173 .cb-sub-menu { background:#c42c2b!important; }
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24173 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#c42c2b!important; }</style>
<!-- BEGIN GADWP v4.9.4 Universal Tracking - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-60765351-1', 'auto');
  ga('send', 'pageview');
</script>

<!-- END GADWP Universal Tracking -->

		<!-- end head functions-->

	</head>

	<body class="post-template-default single single-post postid-25856 single-format-standard">
    <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

        
	    <div id="cb-outer-container">
	        <div id="cb-container">
        	<div class="wrap clearfix">
        	<div class="cb-large"><div id="adrotate_widgets-27" class="cb-sidebar-widget widget_adrotate_widgets"><div class="g g-3"><div class="g-single a-26"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- TOP-COW-MatchedContent -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-4708759492629486"
     data-ad-slot="4686766784"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div></div>        	</div>
        </div>
    
    		<div id="cb-container" class="cb-boxed wrap clearfix"  >

                <header class="header clearfix wrap" role="banner">

                        <div class="wrap clearfix">
                                                                            <div id="logo" class="cb-with-large">
                                                <a href="https://www.cultofwhatever.com">
                                                    <img src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo.png" alt="Cult of Whatever logo" width="" height="" data-retina-src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo@2x.png" />
                                                </a>
                                            </div>
                                                        </div>

    				    <nav id="cb-nav-bar" class="clearfix stickybar cb-dark-menu" role="navigation">

                            <div id="cb-search-modal" class="cb-dark-menu">
                        <div class="cb-search-box">
                            <div class="cb-header">
                                <div class="cb-title">Search</div>
                                <div class="cb-close">
                                    <span class="cb-close-modal"><i class="fa fa-times"></i></span>
                                </div>
                            </div><form role="search" method="get" class="cb-search" action="https://www.cultofwhatever.com/">

    <input type="text" class="cb-search-field" placeholder="" value="" name="s" title="">
    <button class="cb-search-submit" type="submit" value=""><i class="fa fa-search"></i></button>

</form></div></div> <div class="wrap clearfix"><div id="cb-main-menu" class="menu-top-navigation-menu-container"><ul class="nav main-nav clearfix"><li id="menu-item-24169" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-24169"><a href="https://www.cultofwhatever.com/movies/">Movies</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#faa200;">Featured</span></div>
                                        <ul> <li class="cb-article clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2016/07/star-trek-beyond-review-the-search-for-classic-trek/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2016/07/star-trek-beyond-poster-2-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2016/07/star-trek-beyond-review-the-search-for-classic-trek/">Star Trek Beyond Review: The Search for classic Trek</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-07-22">July 22, 2016</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-reviews/" title="View all posts in Movie Reviews">Movie Reviews</a></div></div>
                        </div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#faa200;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2017/03/star-trek-nemesis-ended-the-berman-era-with-a-whimper/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-star-trek-nemesis-ships-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/star-trek-nemesis-ended-the-berman-era-with-a-whimper/">Star Trek Nemesis ended the Berman era with a whimper</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-07">March 7, 2017</time></div></div>
                        </div></li> <li class="cb-article-2 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2017/03/spoiler-review-logan-is-a-masterpiece-of-brutality-and-raw-emotions/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/logan-wolverine-hugh-jackman-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/spoiler-review-logan-is-a-masterpiece-of-brutality-and-raw-emotions/">Spoiler Review: LOGAN is a masterpiece of brutality and raw emotions</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-05">March 5, 2017</time></div></div>
                        </div></li> <li class="cb-article-3 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2017/03/star-wars-is-in-good-hands-looking-ahead-through-2017/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/star-wars-logo-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/star-wars-is-in-good-hands-looking-ahead-through-2017/">Star Wars is in good hands; looking ahead through 2017&#8230;</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-01">March 1, 2017</time></div></div>
                        </div></li> <li class="cb-article-4 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2017/02/spoiler-free-review-get-out-is-the-best-thriller-in-years/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/get-out-daniel-kaluuya-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/02/spoiler-free-review-get-out-is-the-best-thriller-in-years/">Spoiler-Free Review: GET OUT is the best thriller in years</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-27">February 27, 2017</time></div></div>
                        </div></li> <li class="cb-article-5 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2017/02/review-a-cure-for-wellness-gets-worse-as-it-goes-on-and-on/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/cure-wellness-dane-dehaan-3-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/02/review-a-cure-for-wellness-gets-worse-as-it-goes-on-and-on/">Review: A CURE FOR WELLNESS gets worse as it goes on (and on)</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-21">February 21, 2017</time></div></div>
                        </div></li> <li class="cb-article-6 clearfix">
                        <div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2017/02/tron-is-still-awesome-35-years-later/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/tron-1982-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/02/tron-is-still-awesome-35-years-later/">TRON is still awesome, 35 years later&#8230;</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-16">February 16, 2017</time></div></div>
                        </div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-24170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24170"><a href="https://www.cultofwhatever.com/tv/">TV</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1a93db;">Featured</span></div>
                                        <ul> <li class="cb-article clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2017/02/riverdale-s01e03-review-body-double-riverdale-start-to-get-weird/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/riverdale-s1-e3-lili-reinhart-madelaine-petsch-betty-cheryl-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/02/riverdale-s01e03-review-body-double-riverdale-start-to-get-weird/">Riverdale S01E03 Review: Body Double - Riverdale starts to get weird</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-12">February 12, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>
                        </div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1a93db;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2017/03/legion-s01e05-chapter-five-in-which-evil-wears-a-human-face/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s01e5-aubrey-plaza-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/legion-s01e05-chapter-five-in-which-evil-wears-a-human-face/">Legion S01E05: Chapter Five &#8211; In which evil wears a human face</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-09">March 9, 2017</time></div></div>
                        </div></li> <li class="cb-article-2 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2017/03/some-game-of-thrones-crazy-fan-theories-to-keep-us-warm-before-the-shows-return/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2016/06/game-of-thrones-s6-e7-david-rintoul-aerys-targaryen-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/some-game-of-thrones-crazy-fan-theories-to-keep-us-warm-before-the-shows-return/">Some Game of Thrones crazy fan theories to keep us warm before the show’s return</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-09">March 9, 2017</time></div></div>
                        </div></li> <li class="cb-article-3 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2017/03/the-walking-dead-s07e12-say-yes-once-again-the-characters-are-they-key-to-good-story-telling/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/walking-dead-s07e12-rick-michonne-andrew-lincoln-danai-gurira-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/the-walking-dead-s07e12-say-yes-once-again-the-characters-are-they-key-to-good-story-telling/">The Walking Dead S07E12: Say Yes &#8211; Once again the characters are they key to good story-telling</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-06">March 6, 2017</time></div></div>
                        </div></li> <li class="cb-article-4 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2017/03/riverdale-s01e06-review-faster-pussycats-kill-kill-this-episode-has-everything-except-cheryl/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/riverdale-s01e06-cole-sprouse-lili-reinhart-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/riverdale-s01e06-review-faster-pussycats-kill-kill-this-episode-has-everything-except-cheryl/">Riverdale S01E06 Review: Faster, Pussycats! Kill! Kill! &#8211; This episode has everything! (Except Cheryl)</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-05">March 5, 2017</time></div></div>
                        </div></li> <li class="cb-article-5 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2017/03/legion-s01e04-chapter-four-the-most-perplexingly-entertaining-superhero-show/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s1e4-dan-stevens-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/legion-s01e04-chapter-four-the-most-perplexingly-entertaining-superhero-show/">Legion S01E04: Chapter Four &#8211; The most perplexingly entertaining superhero show?</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-03">March 3, 2017</time></div></div>
                        </div></li> <li class="cb-article-6 clearfix">
                        <div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2017/03/taboo-s01e08-review-taboo-ends-with-an-explosive-finale/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/taboo-s1e8-tom-hardy-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/taboo-s01e08-review-taboo-ends-with-an-explosive-finale/">Taboo S01E08 Review: Taboo ends with an explosive finale!</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-02">March 2, 2017</time></div></div>
                        </div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-24171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24171"><a href="https://www.cultofwhatever.com/video-games/">Video Games</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#24bc3a;">Featured</span></div>
                                        <ul> <li class="cb-article clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2015/07/batman-arkham-knight-a-fitting-end-to-a-trilogy/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2015/07/arkham-knight-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2015/07/arkham-knight-480x240.jpg 480w, https://www.cultofwhatever.com/wp-content/uploads/2015/07/arkham-knight-1400x700.jpg 1400w" sizes="(max-width: 480px) 100vw, 480px" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2015/07/batman-arkham-knight-a-fitting-end-to-a-trilogy/">Batman: Arkham Knight - A fitting end to a trilogy</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/tom-farr/">Tom Farr</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2015-07-18">July 18, 2015</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/video-games/video-games-reviews/" title="View all posts in Video Game Reviews">Video Game Reviews</a></div></div>
                        </div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#24bc3a;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2017/03/nintendos-switch-launch-lineup-is-deceptively-great/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-nintendo-switch-games-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/nintendos-switch-launch-lineup-is-deceptively-great/">Nintendo&#8217;s Switch launch lineup is deceptively great</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-08">March 8, 2017</time></div></div>
                        </div></li> <li class="cb-article-2 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2017/03/system-review-nintendos-switch-brings-joy-and-cons/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2016/10/nintendo-switch-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/system-review-nintendos-switch-brings-joy-and-cons/">SYSTEM REVIEW: Nintendo&#8217;s Switch brings Joy and Cons&#8230;</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-02">March 2, 2017</time></div></div>
                        </div></li> <li class="cb-article-3 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2017/02/learning-from-success-has-never-been-the-nintendo-way/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/01/mario-nintendo-switch-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/02/learning-from-success-has-never-been-the-nintendo-way/">Learning from success has never been the Nintendo way</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-28">February 28, 2017</time></div></div>
                        </div></li> <li class="cb-article-4 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2017/01/nintendos-switch-has-been-unveiled-thumbs-up-or-down/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2016/10/nintendo-switch-logo-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/01/nintendos-switch-has-been-unveiled-thumbs-up-or-down/">Nintendo&#8217;s Switch has been unveiled (thumbs up or down?)</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-01-16">January 16, 2017</time></div></div>
                        </div></li> <li class="cb-article-5 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2016/10/resident-evil-horror-history-and-halloween/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2016/10/resident-evil-poster-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2016/10/resident-evil-horror-history-and-halloween/">Resident Evil: Horror, History and Halloween</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-10-27">October 27, 2016</time></div></div>
                        </div></li> <li class="cb-article-6 clearfix">
                        <div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2016/10/the-nintendo-switch-is-the-companys-big-do-over/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2016/10/nintendo-switch-logo-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2016/10/the-nintendo-switch-is-the-companys-big-do-over/">The Nintendo &#8220;Switch&#8221; is the company&#8217;s big do-over</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-10-20">October 20, 2016</time></div></div>
                        </div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-24172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24172"><a href="https://www.cultofwhatever.com/wrestling/">Wrestling</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#20007f;">Featured</span></div>
                                        <ul> <li class="cb-article clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2015/06/interview-mr-anderson/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2015/06/ken-anderson-kennedy-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2015/06/interview-mr-anderson/">Interview: Mr. Anderson</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/josh-modaberi/">Josh Modaberi</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2015-06-25">June 25, 2015</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/interviews/" title="View all posts in Wrestling Interviews">Wrestling Interviews</a></div></div>
                        </div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#20007f;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2017/03/wwe-wm33-updated-card/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/wrestlemania-33-sign-logo-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/02/wrestlemania-33-sign-logo-80x60.jpg 80w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/wrestlemania-33-sign-logo-700x520.jpg 700w" sizes="(max-width: 80px) 100vw, 80px" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/wwe-wm33-updated-card/">WWE Spoilers: Updated card for WrestleMania 33</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-09">March 9, 2017</time></div></div>
                        </div></li> <li class="cb-article-2 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2017/03/wwe-smackdown-3-7-17-results/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-smackdown-logo-0716-grey-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/wwe-smackdown-3-7-17-results/">WWE SmackDown LIVE Results: March 7, 2017</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-08">March 8, 2017</time></div></div>
                        </div></li> <li class="cb-article-3 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2017/03/wwe-raw-3-6-17-results/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-raw-logo-0716-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/wwe-raw-3-6-17-results/">WWE RAW Results: March 6, 2017</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-07">March 7, 2017</time></div></div>
                        </div></li> <li class="cb-article-4 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2017/03/wwe-fastlane-2017-results/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/wwe-fastlane-2017-poster-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/wwe-fastlane-2017-results/">WWE Fastlane 2017 Results</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-06">March 6, 2017</time></div></div>
                        </div></li> <li class="cb-article-5 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2017/03/your-so-of-course-preview-of-wwe-fast-lane-2017/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/Fastlane2017Poster-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/your-so-of-course-preview-of-wwe-fast-lane-2017/">Your SO OF COURSE preview of WWE Fast Lane 2017</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-05">March 5, 2017</time></div></div>
                        </div></li> <li class="cb-article-6 clearfix">
                        <div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2017/03/wwe-fastlane-2017-card/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/Fastlane2017Poster-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a></div>
                        <div class="cb-meta">
                            <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/wwe-fastlane-2017-card/">WWE Spoilers: Final card for Fastlane 2017</a></h2>
                            <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-03">March 3, 2017</time></div></div>
                        </div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-24173" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24173"><a href="http://www.talkwhateveronline.com/">Forum</a><div class="cb-links-menu"></li>
<li class="cb-icons"><ul></ul></li><li id="cb-nav-logo" class="cb-nav-logo-always" style="padding-top: 0px"><a href="https://www.cultofwhatever.com"><img src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo.png" alt="site logo" width="" height="" data-retina-src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo@2x.png" ></a></li></ul></div></div>
    	 				</nav>

    	 				
                            <!-- Secondary Menu -->
                            
                            <div id="cb-top-menu" class="clearfix cb-dark-menu">
                                    <div class="wrap clearfix">

                                        
                                                    <a href="#" id="cb-small-menu-trigger"><i class="fa fa-bars"></i></a>

                                        <div class="cb-breaking-news"><span>Latest <i class="fa fa-long-arrow-right"></i></span><ul><li><a href="https://www.cultofwhatever.com/2017/03/legion-s01e05-chapter-five-in-which-evil-wears-a-human-face/" title="Look Legion S01E05: Chapter Five - In which evil wears a human face" >Legion S01E05: Chapter Five - In which evil wears a human face</a> </li> <li><a href="https://www.cultofwhatever.com/2017/03/some-game-of-thrones-crazy-fan-theories-to-keep-us-warm-before-the-shows-return/" title="Look Some Game of Thrones crazy fan theories to keep us warm before the show’s return" >Some Game of Thrones crazy fan theories to keep us warm before the show’s return</a> </li> <li><a href="https://www.cultofwhatever.com/2017/03/wwe-wm33-updated-card/" title="Look WWE Spoilers: Updated card for WrestleMania 33" >WWE Spoilers: Updated card for WrestleMania 33</a> </li> <li><a href="https://www.cultofwhatever.com/2017/03/nintendos-switch-launch-lineup-is-deceptively-great/" title="Look Nintendo&#039;s Switch launch lineup is deceptively great" >Nintendo's Switch launch lineup is deceptively great</a> </li> <li><a href="https://www.cultofwhatever.com/2017/03/wwe-smackdown-3-7-17-results/" title="Look WWE SmackDown LIVE Results: March 7, 2017" >WWE SmackDown LIVE Results: March 7, 2017</a> </li> <li><a href="https://www.cultofwhatever.com/2017/03/star-trek-nemesis-ended-the-berman-era-with-a-whimper/" title="Look Star Trek Nemesis ended the Berman era with a whimper" >Star Trek Nemesis ended the Berman era with a whimper</a> </li> </ul></div><div class="right-secondary-menu"><ul class="cb-top-nav"><li id="menu-item-24158" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24158"><a target="_blank" href="https://www.facebook.com/cultofwhatever">Facebook</a></li>
<li id="menu-item-24159" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24159"><a target="_blank" href="https://twitter.com/cultofwhatever">Twitter</a></li>
<li id="menu-item-24160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24160"><a target="_blank" href="https://plus.google.com/109480483111289240773">Google+</a></li>
</ul><a href="#" title="Search" class="cb-tip-bot cb-small-menu-icons cb-small-menu-search secondary-menu-search" data-reveal-id="cb-search-modal"><i class="fa fa-search"></i></a></div>
                                        <div id="cb-tap-detect"></div>

                                    </div>
                            </div>
                            <!-- /Secondary Menu -->

                            


                        
                        
                            <!-- Small-Screen Menu -->

                            <section id="cb-small-menu" class="clearfix cb-dark-menu cb-sm-on">

                                <a href="#" id="cb-small-menu-close"><i class="fa fa-times"></i></a>

                                <ul class="cb-small-nav"><li id="menu-item-24205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-24205"><a href="http://www.cultofwhatever.com/">Home</a></li>
<li id="menu-item-24206" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-24206"><a href="https://www.cultofwhatever.com/movies/">Movies</a></li>
<li id="menu-item-24207" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24207"><a href="https://www.cultofwhatever.com/tv/">TV</a></li>
<li id="menu-item-24208" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24208"><a href="https://www.cultofwhatever.com/video-games/">Video Games</a></li>
<li id="menu-item-24209" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24209"><a href="https://www.cultofwhatever.com/wrestling/">Wrestling</a></li>
<li id="menu-item-24210" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24210"><a href="http://www.talkwhateveronline.com/">Forum</a></li>
</ul>
                            </section>

                            <!-- /Small-Screen Menu -->

                        
                        
    	 				<a href="#" id="cb-to-top"><i class="fa fa-arrow-circle-o-up"></i></a>

                        
                </header> <!-- end header -->            <div id="cb-content" class="wrap clearfix full-width">

 <header id="cb-full-width-featured" class="wrap clearfix"><script type="text/javascript">jQuery(document).ready(function($){
						 $("#cb-full-width-featured").backstretch("https://www.cultofwhatever.com/wp-content/uploads/2015/05/sw-bg3-1200x520.jpg", {speed: 350});
					});  </script><div class="cb-entry-header cb-style-full-width"><div class="cb-image-credit"><i class="fa fa-camera"></i>© LucasFilm</div><span class="cb-title-fi"><h1 class="entry-title cb-entry-title cb-single-title" itemprop="headline">Episode III sucked too: Coming to grips with the disappointment of the Prequels.</h1><div class="custom_post_meta"><div class="first_row">Posted on <time class="updated" datetime="2015-05-04" style="color: #faa200;">May 4, 2015</time> by <a href="https://www.cultofwhatever.com/author/matthew-martin/" style="color: #faa200;">Matthew Martin</a></div> <a href="https://www.cultofwhatever.com/movies/movie-blogs/" title="View all posts in Movie Blogs" class="category_button" style="background-color: #faa200;" >Movie Blogs</a><div class="cb-social-sharing cb-beside clearfix"><div class="cb-title-subtle">Share On:</div><div class="cb-facebook"><div id="fb-root"></div>
                        <script>(function(d, s, id) {
                          var js, fjs = d.getElementsByTagName(s)[0];
                          if (d.getElementById(id)) return;
                          js = d.createElement(s); js.id = id;
                          js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
                          fjs.parentNode.insertBefore(js, fjs);
                        }(document, "script", "facebook-jssdk"));</script>
                       <div class="fb-like" data-href="https://www.cultofwhatever.com/2015/05/episode-iii-sucked-too-coming-to-grips-with-the-disappointment-of-the-prequels/" data-width="450" data-layout="button_count" data-show-faces="false" data-send="false"></div></div><div class="cb-pinterest"><script type="text/javascript" src="//assets.pinterest.com/js/pinit.js" async></script>
            <a href="//pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.cultofwhatever.com%2F2015%2F05%2Fepisode-iii-sucked-too-coming-to-grips-with-the-disappointment-of-the-prequels%2F&media=https%3A%2F%2Fwww.cultofwhatever.com%2Fwp-content%2Fuploads%2F2015%2F05%2Fsw-bg3.jpg&description=Episode+III+sucked+too%3A+Coming+to+grips+with+the+disappointment+of+the+Prequels." data-pin-do="buttonPin" data-pin-config="beside" target="_blank"><img src="//assets.pinterest.com/images/pidgets/pin_it_button.png" /></a></div><div class="cb-google ">
                            <div class="g-plusone" data-size="medium"></div>

                            <script type="text/javascript">
                              (function() {
                                var po = document.createElement("script"); po.type = "text/javascript"; po.async = true;
                                po.src = "https://apis.google.com/js/plusone.js";
                                var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(po, s);
                              })();
                            </script></div><div class="cb-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-dnt="true"  data-count="horizontal">Tweet</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div></div></div></span></div></header>

				   
					<div id="main" class="clearfix" role="main">

                                             

							<article id="post-25856" class="clearfix post-25856 post type-post status-publish format-standard has-post-thumbnail hentry category-movie-blogs tag-prequel-trilogy tag-revenge-of-the-sith tag-star-wars" role="article" itemscope itemtype="http://schema.org/BlogPosting">

                                 
								<section class="entry-content clearfix" itemprop="articleBody">

									<p>I&#8217;ve <a href="https://www.cultofwhatever.com/2015/03/expanding-universe-will-the-force-awakens-feel-like-star-wars-or-a-glorified-fanfic/" target="_blank">written before</a> about my hesitancy to get excited about the upcoming Star Wars movies. I had come to terms with it, in part after the release of Revenge of the Sith, and ultimately with the purchase of Lucasfilm by Disney. Before Lucas sold the franchise, I held out a fool&#8217;s hope in the back of my mind, that maybe one day&#8211;long after George had shuffled off this mortal coil&#8211;someone would come along and reimagine the whole thing.<span id="more-25856"></span></p>
<p>It&#8217;s no secret, despite Lucas&#8217; protestations, that the six-part &#8220;Star Wars saga&#8221; was a work in progress, constantly being revised. Darth Vader was not Luke&#8217;s dad until a late-drafting of The Empire Strikes Back. The idea that Luke and Leia were siblings didn&#8217;t come along until Lucas grew tired of making the Star Wars films and opted to end the series with the third movie, Return of the Jedi. Yoda&#8217;s declaration that &#8220;there is another&#8221; was just a loose thread in The Empire Strikes Back, left intentionally vague so that anyone or anything could be thought up later. The series was supposed to end on Coruscant, in part nine of the series, in the Emperor&#8217;s throne room, and not on a rebuilt Death Star in part six. And so on.</p>
<p>So in the years between the &#8220;completion&#8221; of the series, with Revenge of the Sith, and the purchase of Lucasfilm by Disney, I had dreamed that someone would come along and&#8211;having the whole story now told&#8211;re-tell the saga in a tidier, better-acted way. It&#8217;s always easier to re-tell a story once you know how it&#8217;s supposed to go, than it is to make it up as you go along and hope it all turns out okay.</p>
<p>But with Disney now in control, that dream is over. The Walt Disney Company is the biggest &#8220;franchise&#8221; maker and sustainer on the planet. They are the single biggest reason why copyright expiration laws have been extended into near-infinity. Originally, in the United States, copyright was supposed to be held by the creator of an original property for fourteen years, with the option to renew for another fourteen years. Over the centuries this has been expanded to seventy five years after, and again up to one-hundred and twenty years after creation. Whenever there is a copyright battle on Capital Hill, Disney is usually at the frontline arguing and using its massive lobbying muscle to push for copyright extensions. The company is terrified to see Mickey Mouse enter public domain. Once they acquired Star Wars, you can be sure the same legal zeal was applied to Luke Skywalker and friends as well.</p>
<p>That means the core six movies as we know them are locked in and will forever be &#8220;Star Wars.&#8221; Someone may come along and release a big budget adaptation of The Wizard of Oz to be more in line with the source material, in a few decades a new Lord of the Rings saga might be commissioned with state of the art visual effects behind it, maybe some day soon the BBC will release a seven-year-series adaptation of Harry Potter, doing justice to some of the mistakes and omissions found in the latter films, but Star Wars will never change. It will be as untouchable as Mickey Mouse.</p>
<p>In some ways, that&#8217;s a good thing. <a href="https://www.cultofwhatever.com/2015/04/repeat-reboot-the-sequel/" target="_blank">Goodness knows we have enough reboots and remakes in cinema today</a>. But when it comes to the prequels, you can hate the acting, the over-reliance on green screen settings, and the convoluted screenplays all you want, but you have to come to terms with it: They&#8217;re never going away. They&#8217;re never getting remade, they&#8217;re never getting retconned.</p>
<p>Let&#8217;s come to terms with it.</p>
<p style="text-align: center;">____________________</p>
<p>When Episode I came out it took a few months, maybe even a year, for the general consensus to settle in that the film was subpar. Once the whole trilogy was completed, it came to be viewed as the most technically superior film of the three, but artistically the weakest. Episode II meanwhile was generally thought of as the least-technically impressive (bad editing, lighting, the poorest soundtrack) <em>and</em> the least artistically impressive (wooden acting, weak screenplay). By default, Episode III wins the prize as the best of the three.</p>
<p>By default.</p>
<p>In reality, Episode III is a movie that is <em>just</em> good enough to make us think it&#8217;s actually good. It does this by running through a checklist of fan-pleasing scenes, ramping up the parts that fans seemed to like in the first two films while also cutting back on the parts that made Episodes I and II so grating. It&#8217;s only by a combination of smoke and mirrors and willful self-delusion that fans look back fondly on the film.</p>
<p>After half a decade of disappointment, I stood in line for Episode III&#8217;s premier at midnight, telling myself that this one would be good. I didn&#8217;t need &#8220;great&#8221; or &#8220;thrilling&#8221; or &#8220;amazing&#8221; or even &#8220;as wonderful as the original films.&#8221; I had been beaten down so thoroughly by the first two prequels that the only adjective I was hoping to use to describe it was &#8220;competent.&#8221; I just wanted a well made movie. I needed Star Wars to be good enough again to justify a near-lifetime of fandom. I had glanced at newspaper reviews in the days leading up to it. There were a lot of &#8220;A&#8221; ratings, &#8220;4 stars&#8221; here, and &#8220;Star Wars is Back!&#8221; headlines there. It was all very promising. But I remember that Roger Ebert gave The Phantom Menace a glowing review, so I refused to get my hopes up. All I needed was for it to justify its existence.</p>
<p>And, watching it on opening night, it felt like it had.</p>
<p>I wanted to see the fight between Anakin and Obi Wan, and the movie delivered. I wanted to see the fall of Anakin and the hunting down of the Jedi, and the movie delivered. I wanted to see the culmination of Palpatine&#8217;s elaborate, shadowy plan leading to the establishment of the Empire, and the movie delivered. When it was over, I walked out of the Memphis Paradiso Theater content that the Star Wars prequels had finally lived up to their purpose.</p>
<p>Then I went back to see it again&#8230;and the feeling had dissipated.</p>
<p>Once I got past the thrill of seeing those isolated moments that I&#8217;d dreamed about since childhood, I realized the tissue that connected those moments was thin and riddled with flaws. Like so many, I grew up wondering how exactly Anakin turned to the darkside. When I finally saw it, I enjoyed the spectacle of it, the sight and sound of his assisting Palpatine in killing Mace Windu and pledging himself to the Sith in order to save his presumed-endangered wife. But once you see the moment, and you enjoy seeing the moment, your brain pipes in and ruins the moment by asking questions.</p>
<p>Tell me, in the context of the movie, and only the movie (not decades of fan surmising, expanded-universe writing, and general consensus) why did Anakin go dark, REAL dark? I mean he went from trying to talk Windu into just <em>not killing</em> Palpatine (so he could stand trial), to, literally five minutes later, slaughtering young Jedi babies in the name of Sith Supremacy. He would later tell Obi Wan that &#8220;from [his] point of view the Jedi are evil.&#8221; But what in-movie reason is there for him to think that?</p>
<p>What&#8217;s so frustrating is how many obvious answers there are to that question, but the movie never touches on any of them.</p>
<p style="text-align: center;">____________________</p>
<p>Anakin&#8217;s very first experience with Jedi comes from Qui Gon Jinn and Obi Wan Kenobi. The former is the only one to give half a crap about him as a youngster, and once he&#8217;s gone, Anakin is stuck with Obi Wan, who only agreed to train him as a promise to his dying master and who earlier had ran down the notion of Qui Gon training him. Yoda, Mace Windu and the rest of the council summarily rejected his being trained, with Windu in particular showing disdain that this &#8220;too-old boy&#8221; was being brought before them.</p>
<p>Ten years later, Anakin is a Jedi pupil, hen-pecked by his master and forced to bury his personal feelings in the name of Jedi relative-altruism. When his mother is in jeopardy he clearly wants to go and help but he is a slave to his rigid training that demands he watch his only living relative die while he meditate.</p>
<p>Later he becomes a Jedi Knight and is requested by the Chancellor of the whole intergalactic government to serve him on the Jedi council. Instead of granting him the title of &#8220;Jedi Master&#8221;&#8211;even as a formality&#8211;the Council responds like petty children and deny him a momentary bit of happiness after a miserable decade+ of life.</p>
<p>He then comes to find out his wife might die, much like his mother, and much like with his mother, the advice he gets is basically &#8220;clear your mind of attachments.&#8221; So by the time Palpatine offers him a way to save his wife&#8217;s life, why <em>wouldn&#8217;t </em>he be tempted. And when the Jedi try to stop Palpatine, why <em>wouldn&#8217;t </em>he side with the &#8220;bad guy&#8221; and go after the selfish Jedi trying to stop him from saving his wife&#8217;s life.</p>
<p>So yeah: Anakin had plenty of reasons (in his mind) to join the Sith and betray the Jedi. But did the movie actually address any of those reasons? Were any logical connections made to show Anakin&#8217;s thought process? Nope. He just went from &#8220;I pledge myself to your teachings&#8221; to &#8220;time to kill some younglings!&#8221; No rhyme or reason whatsoever. He just switched teams like Kentucky basketball fans who suddenly become Tennessee fans once college football season starts.</p>
<p>Remember this? Remember Nunu?</p>
<p><iframe  id="_ytid_33563" width="750" height="563" src="https://www.youtube.com/embed/ZW8UReCYyRQ?enablejsapi=1&#038;autoplay=0&#038;cc_load_policy=0&#038;iv_load_policy=1&#038;loop=0&#038;modestbranding=0&#038;rel=1&#038;showinfo=1&#038;playsinline=0&#038;autohide=2&#038;theme=dark&#038;color=red&#038;wmode=opaque&#038;vq=&#038;controls=2&#038;" frameborder="0" class="__youtube_prefs__" allowfullscreen data-no-lazy="1"></iframe></p>
<p>This is Anakin in Revenge of the Sith.</p>
<p>And that&#8217;s just Anakin. We can hop over to the other big moment in the movie: Why did Yoda suddenly stop a fight with the Emperor when he was AT LEAST going toe-for-toe with him (and at times clearly had the upper hand)? Why did he suddenly up and just walk away, handing the galaxy over to &#8220;Hitler with a butt-forehead&#8221; and go into exile?</p>
<p>Of course we know the answer: The answer is because Yoda was in exile during the Original Trilogy, so he had to go <strong>into </strong>exile during the prequels. The answer is because George Lucas piddled around for four and a half hours in Episodes I and II and then had to cram the entire Original Trilogy backstory into one half of one movie. Think about it, all the clues we get about the events leading up to Episode IV are answered in the final hour and a half of Revenge of the Sith. There&#8217;s nothing about Trade Federations, Droid Armies, Separatist Movements or Sith uprisings at all in Episodes IV-VI. But those elements comprise three-quarters of the Prequel Trilogy. All the Original Series discussed was Anakin and Obi Wan fighting together in the Clone Wars as Jedi Knights. The way Obi Wan tells it to Luke, the Clone Wars were a kind of Crusade and the good guys were intergalactic Knights of Charlemagne (I&#8217;m aware Charlemagne never led any Crusades; go with it). Vader was a good guy turned bad, who helped the bad guys kill the knights and conquer the galaxy. We then come to find out Luke&#8217;s dad <em>was </em>Vader and was seduced by the promise of easy power through his pent up anger, fear and aggression. Instead of three movies about <em>that</em>, we got a half-movie about it, and two and a half meandering movies about nothing in particular leading up to it.</p>
<p style="text-align: center;">____________________</p>
<p>To be fair to George, it&#8217;s not that I blame him for not having the entire saga mapped out the moment he first started writing &#8220;The Adventures of Luke Starkiller&#8221; (even though he has all but claimed such). I blame him for sitting down in the mid-90&#8217;s to sketch out the Prequels, knowing where the story would end up, and still bungling it. <em>That</em> I blame him for.</p>
<p>And now that they are in Disney&#8217;s litigious hands, the prequels will forever be what they are:</p>
<p>Less than what they could have been.</p>

								</section> <!-- end article section -->

								
								<footer class="article-footer">

                                    <style type="text/css">
                                        .cb-tags a {
                                            background-color:#faa200!important;
                                         }

                                         .entry-content blockquote:before {
                                            color: #faa200;
                                         }

                                        .entry-content h2, .entry-content h3, .entry-content h4 {
                                            color: #faa200;
                                        }

                                         .widget_nav_menu ul li:before, .widget_rss ul li:before, .widget_recent_entries ul li:before, .widget_recent_comments ul li:before, .widget_meta ul li:before, .widget_categories ul li:before, .widget_archive ul li:before, .widget_pages ul li:before, .widget-popular-posts li:before {
                                            color: #faa200 !important;
                                         }

                                         ul.slides {
                                            background-color: #faa200;
                                         }
                                         .entry-content ul li:before {
                                            background-color:#faa200;
                                         }

                                    </style>
									<h3>Tags</h3><p class="cb-tags"> <a href="https://www.cultofwhatever.com/tag/prequel-trilogy/" rel="tag">prequel trilogy</a><a href="https://www.cultofwhatever.com/tag/revenge-of-the-sith/" rel="tag">revenge of the sith</a><a href="https://www.cultofwhatever.com/tag/star-wars/" rel="tag">star wars</a></p>
<div id="disqus_thread">
            <div id="dsq-content">


            <ul id="dsq-comments">
                    <li class="comment even thread-even depth-1" id="dsq-comment-4537">
        <div id="dsq-comment-header-4537" class="dsq-comment-header">
            <cite id="dsq-cite-4537">
                <span id="dsq-author-user-4537">TheRealJMac</span>
            </cite>
        </div>
        <div id="dsq-comment-body-4537" class="dsq-comment-body">
            <div id="dsq-comment-message-4537" class="dsq-comment-message"><p>On TV now (which prompted me to find this article)..&amp; yep, couple good scenes sprinkled over a terrible movie that looks better only when compared to the previous two. So many cringe-worthy moments in the prequels (inc. this) &amp; people will defend them to their death because its called &#8216;Star Wars&#8217;</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-4594">
        <div id="dsq-comment-header-4594" class="dsq-comment-header">
            <cite id="dsq-cite-4594">
                <span id="dsq-author-user-4594">Jacob Stamm</span>
            </cite>
        </div>
        <div id="dsq-comment-body-4594" class="dsq-comment-body">
            <div id="dsq-comment-message-4594" class="dsq-comment-message"><p>Your article makes me sad, but I can&#8217;t deny how on point it is. This may sound melodramatic, but thinking of what &#8220;could have been&#8221; the prequels and then looking at what they actually are gives me an embarrassingly potent pang of depression. It&#8217;s like the character of Revan in the KOTOR timeline. One of the most interesting heroes/villains in the old Star Wars universe, with an INCREDIBLE setup after KOTOR 2, and they completely bastardized it all when SWTOR came out. Thinking of what could have been makes me legitimately disappointed. I&#8217;ll just have to focus on the good. *sigh*</p>
</div>
        </div>

    </li><!-- #comment-## -->
            </ul>


        </div>

    </div>

<script type="text/javascript">
var disqus_url = 'https://www.cultofwhatever.com/2015/05/episode-iii-sucked-too-coming-to-grips-with-the-disappointment-of-the-prequels/';
var disqus_identifier = '25856 https://www.cultofwhatever.com/?p=25856';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'wrestling101';
var disqus_title = "Episode III sucked too: Coming to grips with the disappointment of the Prequels.";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=25856';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>

<div id="cb-related-posts" class="clearfix"><h3 class="cb-block-title" style="border-bottom: 4px solid #faa200;">You might also like</h3><ul>
							<li class="no-1">

								<div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2015/04/machete-the-other-way-to-watch-star-wars/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2015/04/star-wars-anakin-skywalker-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2015/04/machete-the-other-way-to-watch-star-wars/">MACHETE: The &#8220;other&#8221; way to watch Star Wars</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2015-04-19">April 19, 2015</time></div></div>
								</div>

							</li>


							<li class="no-2">

								<div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2015/04/relics-of-the-past-a-closer-look-at-the-second-the-force-awakens-teaser/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/star-wars-episode7-poster-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2015/04/relics-of-the-past-a-closer-look-at-the-second-the-force-awakens-teaser/">Relics of the Past: A closer look at the second The Force Awakens teaser</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2015-04-20">April 20, 2015</time></div></div>
								</div>

							</li>


							<li class="no-3">

								<div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2015/04/are-you-afraid-yet-you-should-bewelcome-to-the-dark-side-of-disney/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2015/04/disney-star-wars-jj-abram-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2015/04/are-you-afraid-yet-you-should-bewelcome-to-the-dark-side-of-disney/">Are you afraid yet? You should be…welcome to the dark side of Disney</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/benjamin-hargreaves/">Ben Hargreaves</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2015-04-16">April 16, 2015</time></div></div>
								</div>

							</li>


							<li class="no-4">

								<div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2015/03/expanding-universe-will-the-force-awakens-feel-like-star-wars-or-a-glorified-fanfic/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/star-wars-falcon-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2015/03/expanding-universe-will-the-force-awakens-feel-like-star-wars-or-a-glorified-fanfic/">EXPANDING UNIVERSE: Will &#8220;The Force Awakens&#8221; feel like Star Wars, or a glorified fanfic?</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2015-03-12">March 12, 2015</time></div></div>
								</div>

							</li>


							<li class="no-5">

								<div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2015/03/disneys-world-how-much-bigger-can-the-house-of-mouse-get/"><img width="200" height="170" src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/disney-logo3-200x170.jpg" class="attachment-cb-200-170 size-cb-200-170 wp-post-image" alt="" /></a></div>

								 <div class="cb-meta">

									 <h4><a href="https://www.cultofwhatever.com/2015/03/disneys-world-how-much-bigger-can-the-house-of-mouse-get/">DISNEY&#8217;S WORLD: How much bigger can the house of mouse get?</a></h4>

									 <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2015-03-25">March 25, 2015</time></div></div>
								</div>

							</li>

</ul></div>
								</footer> <!-- end article footer -->

							</article> <!-- end article -->

						
						
					</div> <!-- end #main -->

										

					<style type="text/css">
        .cb-tags a {
            background-color:#faa200!important;
         }

         .entry-content blockquote:before {
            color: #faa200;
         }

        .entry-content h2, .entry-content h3, .entry-content h4 {
            color: #faa200;
        }

         .widget_nav_menu ul li:before, .widget_rss ul li:before, .widget_recent_entries ul li:before, .widget_recent_comments ul li:before, .widget_meta ul li:before, .widget_categories ul li:before, .widget_archive ul li:before, .widget_pages ul li:before, .widget-popular-posts li:before {
            color: #faa200 !important;
         }

         ul.slides {
            background-color: #faa200;
         }
         .entry-content ul li:before {
            background-color:#faa200;
         }

    </style><aside class="cb-sidebar clearfix" role="complementary">

<div id="adrotate_widgets-18" class="cb-sidebar-widget widget_adrotate_widgets"><div class="g g-4"><div class="g-single a-15"><script type="text/javascript"><!--
google_ad_client = "ca-pub-4708759492629486";
/* W101-Big-Box */
google_ad_slot = "5509493980";
google_ad_width = 336;
google_ad_height = 280;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div></div></div><div id="text-33" class="cb-sidebar-widget widget_text">			<div class="textwidget"></div>
		</div>		<div id="recent-posts-5" class="cb-sidebar-widget widget_recent_entries">		<h3 class="cb-sidebar-widget-title">The Latest</h3>		<ul>
					<li>
				<a href="https://www.cultofwhatever.com/2017/03/legion-s01e05-chapter-five-in-which-evil-wears-a-human-face/">Legion S01E05: Chapter Five &#8211; In which evil wears a human face</a>
						</li>
					<li>
				<a href="https://www.cultofwhatever.com/2017/03/some-game-of-thrones-crazy-fan-theories-to-keep-us-warm-before-the-shows-return/">Some Game of Thrones crazy fan theories to keep us warm before the show’s return</a>
						</li>
					<li>
				<a href="https://www.cultofwhatever.com/2017/03/wwe-wm33-updated-card/">WWE Spoilers: Updated card for WrestleMania 33</a>
						</li>
					<li>
				<a href="https://www.cultofwhatever.com/2017/03/nintendos-switch-launch-lineup-is-deceptively-great/">Nintendo&#8217;s Switch launch lineup is deceptively great</a>
						</li>
					<li>
				<a href="https://www.cultofwhatever.com/2017/03/wwe-smackdown-3-7-17-results/">WWE SmackDown LIVE Results: March 7, 2017</a>
						</li>
					<li>
				<a href="https://www.cultofwhatever.com/2017/03/star-trek-nemesis-ended-the-berman-era-with-a-whimper/">Star Trek Nemesis ended the Berman era with a whimper</a>
						</li>
					<li>
				<a href="https://www.cultofwhatever.com/2017/03/wwe-raw-3-6-17-results/">WWE RAW Results: March 6, 2017</a>
						</li>
					<li>
				<a href="https://www.cultofwhatever.com/2017/03/the-walking-dead-s07e12-say-yes-once-again-the-characters-are-they-key-to-good-story-telling/">The Walking Dead S07E12: Say Yes &#8211; Once again the characters are they key to good story-telling</a>
						</li>
					<li>
				<a href="https://www.cultofwhatever.com/2017/03/wwe-fastlane-2017-results/">WWE Fastlane 2017 Results</a>
						</li>
					<li>
				<a href="https://www.cultofwhatever.com/2017/03/spoiler-review-logan-is-a-masterpiece-of-brutality-and-raw-emotions/">Spoiler Review: LOGAN is a masterpiece of brutality and raw emotions</a>
						</li>
				</ul>
		</div>		<div id="adrotate_widgets-19" class="cb-sidebar-widget widget_adrotate_widgets"><div class="g g-5"><div class="g-single a-16"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- COW-300*600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-4708759492629486"
     data-ad-slot="4657643981"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div><div id="latest-articles-4" class="cb-sidebar-widget widget_latest-articles"><h3 class="cb-sidebar-widget-title">Recommended for you</h3>
		<ul class="cb-light cb-small">
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/03/star-trek-nemesis-ended-the-berman-era-with-a-whimper/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-star-trek-nemesis-ships-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-star-trek-nemesis-ships-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-star-trek-nemesis-ships-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/03/star-trek-nemesis-ended-the-berman-era-with-a-whimper/">Star Trek Nemesis ended the Berman era with a whimper</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-07">March 7, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/03/spoiler-review-logan-is-a-masterpiece-of-brutality-and-raw-emotions/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/logan-wolverine-hugh-jackman-2-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/logan-wolverine-hugh-jackman-2-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/logan-wolverine-hugh-jackman-2-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/03/spoiler-review-logan-is-a-masterpiece-of-brutality-and-raw-emotions/">Spoiler Review: LOGAN is a masterpiece of brutality and raw emotions</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-05">March 5, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#24bc3a;">
                		<a href="https://www.cultofwhatever.com/2017/03/system-review-nintendos-switch-brings-joy-and-cons/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/10/nintendo-switch-2-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/10/nintendo-switch-2-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/10/nintendo-switch-2-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/03/system-review-nintendos-switch-brings-joy-and-cons/">SYSTEM REVIEW: Nintendo&#8217;s Switch brings Joy and Cons&#8230;</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-02">March 2, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/03/star-wars-is-in-good-hands-looking-ahead-through-2017/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/star-wars-logo-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/star-wars-logo-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/star-wars-logo-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/03/star-wars-is-in-good-hands-looking-ahead-through-2017/">Star Wars is in good hands; looking ahead through 2017&#8230;</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-01">March 1, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/02/spoiler-free-review-get-out-is-the-best-thriller-in-years/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/get-out-daniel-kaluuya-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/02/get-out-daniel-kaluuya-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/get-out-daniel-kaluuya-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/02/spoiler-free-review-get-out-is-the-best-thriller-in-years/">Spoiler-Free Review: GET OUT is the best thriller in years</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-27">February 27, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/02/review-a-cure-for-wellness-gets-worse-as-it-goes-on-and-on/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/cure-wellness-dane-dehaan-3-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/02/cure-wellness-dane-dehaan-3-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/cure-wellness-dane-dehaan-3-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/02/review-a-cure-for-wellness-gets-worse-as-it-goes-on-and-on/">Review: A CURE FOR WELLNESS gets worse as it goes on (and on)</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-21">February 21, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/02/tron-is-still-awesome-35-years-later/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/tron-1982-2-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/02/tron-1982-2-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/tron-1982-2-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/02/tron-is-still-awesome-35-years-later/">TRON is still awesome, 35 years later&#8230;</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-16">February 16, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#191919;">
                		<a href="https://www.cultofwhatever.com/2017/02/elvis-40-year-reign-1956-1957/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/bg-elvis3-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/02/bg-elvis3-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/bg-elvis3-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/02/elvis-40-year-reign-1956-1957/">Elvis&#8217; 40 Year Reign (1956-1957)</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-14">February 14, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/02/review-lego-batman-is-the-most-purely-fun-dc-movie-ever-made/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/lego-batman-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/02/lego-batman-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/lego-batman-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/02/review-lego-batman-is-the-most-purely-fun-dc-movie-ever-made/">Review: LEGO Batman is the most purely fun DC movie ever made.</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-13">February 13, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/02/review-the-space-between-us-fails-to-do-its-premise-justice/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/space-between-asa-butterfield-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/02/space-between-asa-butterfield-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/space-between-asa-butterfield-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/02/review-the-space-between-us-fails-to-do-its-premise-justice/">Review: The Space Between Us fails to do its premise justice</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-08">February 8, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/02/2017-marvels-biggest-year-so-far/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2015/05/marvels-phase-four-is-not-just-a-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2015/05/marvels-phase-four-is-not-just-a-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2015/05/marvels-phase-four-is-not-just-a-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/02/2017-marvels-biggest-year-so-far/">2017: Marvel&#8217;s biggest year so far?</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-07">February 7, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/02/review-rings-is-equal-parts-frightless-and-frustrating/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/bg-rings-8-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/02/bg-rings-8-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/bg-rings-8-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/02/review-rings-is-equal-parts-frightless-and-frustrating/">Review: Rings is equal parts frightless and frustrating.</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-05">February 5, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/01/split-review-was-almost-good-before-suddenly-it-was-almost-great/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/12/split-poster-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/12/split-poster-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/12/split-poster-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/01/split-review-was-almost-good-before-suddenly-it-was-almost-great/">SPLIT Review: Was almost good, before suddenly it was almost great</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-01-24">January 24, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/01/star-trek-insurrection-would-have-been-a-fine-tv-episode/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/01/star-trek-insurrection-brent-spiner-data-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/01/star-trek-insurrection-brent-spiner-data-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/01/star-trek-insurrection-brent-spiner-data-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/01/star-trek-insurrection-would-have-been-a-fine-tv-episode/">Star Trek Insurrection would have been a fine TV Episode&#8230;</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-01-25">January 25, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/01/bye-bye-man-review-a-scary-movie-that-forgot-the-scares/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/01/bye-man-poster-2-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/01/bye-man-poster-2-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/01/bye-man-poster-2-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/01/bye-bye-man-review-a-scary-movie-that-forgot-the-scares/">Bye Bye Man Review: A scary movie that forgot the scares</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-01-13">January 13, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/01/review-a-monster-calls-is-a-powerful-movie-about-hard-truths/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2017/01/monster-calls-poster-2-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/01/monster-calls-poster-2-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2017/01/monster-calls-poster-2-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/01/review-a-monster-calls-is-a-powerful-movie-about-hard-truths/">Review: A Monster Calls is a powerful movie about hard truths</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-01-08">January 8, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2017/01/2017s-big-movie-year/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/12/guardians-galaxy-vol2-poster-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/12/guardians-galaxy-vol2-poster-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/12/guardians-galaxy-vol2-poster-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/01/2017s-big-movie-year/">2017&#8217;s Big Movie Year</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-01-06">January 6, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2016/12/the-expanded-universe-strikes-back-10-star-wars-stories-disney-would-rather-you-forgot/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/12/star-wars-n64-shadow-empire-125x125.png" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/12/star-wars-n64-shadow-empire-125x125.png 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/12/star-wars-n64-shadow-empire-144x144.png 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2016/12/the-expanded-universe-strikes-back-10-star-wars-stories-disney-would-rather-you-forgot/">The Expanded Universe Strikes Back! 10 Star Wars Stories Disney would rather you forgot</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/gj-harris/">GJ Harris</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-12-21">December 21, 2016</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2016/12/lets-talk-about-blowing-up-the-death-star/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/12/bg-stwr-ds-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/12/bg-stwr-ds-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/12/bg-stwr-ds-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2016/12/lets-talk-about-blowing-up-the-death-star/">Let&#8217;s talk about blowing up the Death Star&#8230;</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-12-10">December 10, 2016</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2016/09/star-wars-the-non-auteur-franchise/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/09/star-wars-team-kathleen-kennedy-jj-abrams-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/09/star-wars-team-kathleen-kennedy-jj-abrams-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/09/star-wars-team-kathleen-kennedy-jj-abrams-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2016/09/star-wars-the-non-auteur-franchise/">Star Wars: The non-auteur franchise</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-09-26">September 26, 2016</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2016/09/there-are-other-worlds-than-these-an-introduction-to-the-dark-tower/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/09/dark-tower-gunslinger-book-cover-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/09/dark-tower-gunslinger-book-cover-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/09/dark-tower-gunslinger-book-cover-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2016/09/there-are-other-worlds-than-these-an-introduction-to-the-dark-tower/">“There are other worlds than these” an introduction to The Dark Tower</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-09-21">September 21, 2016</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2016/08/have-dc-mishandled-the-joker/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/08/bg-joker-jared-leto-2-125x125.png" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/08/bg-joker-jared-leto-2-125x125.png 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/08/bg-joker-jared-leto-2-144x144.png 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2016/08/have-dc-mishandled-the-joker/">Have DC mishandled The Joker?</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-08-25">August 25, 2016</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2016/08/on-superman-darkseid-and-wild-wild-dceu-speculation/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/07/bg-batman-post-apocalyptic-world-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/07/bg-batman-post-apocalyptic-world-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/07/bg-batman-post-apocalyptic-world-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2016/08/on-superman-darkseid-and-wild-wild-dceu-speculation/">On Superman, Darkseid, and wild wild DCEU speculation</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-08-03">August 3, 2016</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2016/04/the-history-of-the-marvel-cinematic-universe/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2015/05/marvels-phase-four-is-not-just-a-125x125.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2015/05/marvels-phase-four-is-not-just-a-125x125.jpg 125w, https://www.cultofwhatever.com/wp-content/uploads/2015/05/marvels-phase-four-is-not-just-a-144x144.jpg 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2016/04/the-history-of-the-marvel-cinematic-universe/">The history of the Marvel Cinematic Universe</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-04-11">April 11, 2016</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                		<a href="https://www.cultofwhatever.com/2016/03/the-history-of-the-now-established-dccu/">
                	    <img width="100" height="100" src="https://www.cultofwhatever.com/wp-content/uploads/2016/03/batman-superman-wonder-woman-3-125x125.png" class="attachment-100x100 size-100x100 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/03/batman-superman-wonder-woman-3-125x125.png 125w, https://www.cultofwhatever.com/wp-content/uploads/2016/03/batman-superman-wonder-woman-3-144x144.png 144w" sizes="(max-width: 100px) 100vw, 100px" />                         </a>
                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2016/03/the-history-of-the-now-established-dccu/">The history of the (now established) DCCU</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-03-23">March 23, 2016</time></div></div>                                           </div>
                </li>
    		    	</ul>

    		</div><div id="adrotate_widgets-20" class="cb-sidebar-widget widget_adrotate_widgets"><div class="g g-8"><div class="g-single a-25"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- COW-336-Bottom -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-4708759492629486"
     data-ad-slot="7611110385"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div><div id="rss-4" class="cb-sidebar-widget widget_rss"><h3 class="cb-sidebar-widget-title"><a class="rsswidget" href="https://www.talkwhateveronline.com/forums/-/index.rss"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.cultofwhatever.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.talkwhateveronline.com/">Latest Forum Discussions</a></h3><ul><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/champions-league-or-europa-league-16-17.63764/'>Champions League or Europa League 16/17</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/wwe-wrestlemania-33-discussion-thread-april-2-2017-from-orlando-fl.63701/'>WWE WrestleMania 33 Discussion Thread - April 2, 2017 from Orlando, FL</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/wwe-smackdown-live-discussion-thread-march-7-2017-from-indianapolis-in-916.63760/'>WWE SmackDown LIVE Discussion Thread - March 7, 2017 from Indianapolis, IN (#916)</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/round-35.63766/'>Round 35</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/39-fwl-update-week-10.63763/'>[39] FWL Update: Week 10</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/ron-bass-passes-away.63765/'>Ron Bass passes away</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/round-34.63758/'>Round 34</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/more-like-a-re-introduction-to-some.63762/'>More Like a Re-Introduction To Some.....</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/wwe-raw-discussion-thread-march-6-2017-from-chicago-il-1241.63759/'>WWE RAW Discussion Thread - March 6, 2017 from Chicago, IL (#1241)</a></li><li><a class='rsswidget' href='https://www.talkwhateveronline.com/threads/wwe-fastlane-2017-discussion-thread-march-5-2017-from-milwaukee-wi-3.63727/'>WWE Fastlane 2017 Discussion Thread - March 5, 2017 from Milwaukee, WI (#3)</a></li></ul></div><div id="cb-popular-posts-4" class="cb-sidebar-widget widget-popular-posts widget-latest-articles"><h3 class="cb-sidebar-widget-title">Popular Posts</h3>
    		<ul class="cb-light cb-small">
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#20007f;">
                	    <a href="https://www.cultofwhatever.com/2007/09/wwe-title-belts-a-guide-to-the-gold/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2013/05/wwe-title-belt-2013-04-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2007/09/wwe-title-belts-a-guide-to-the-gold/">WWE Title Belts: A Guide to the Gold</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/the-beltster/">The Beltster</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2007-09-19">September 19, 2007</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#20007f;">
                	    <a href="https://www.cultofwhatever.com/2011/01/wwe-raw-1-10-11/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2010/11/355-wwe-raw-2010-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2010/11/355-wwe-raw-2010-80x60.png 80w, https://www.cultofwhatever.com/wp-content/uploads/2010/11/355-wwe-raw-2010-125x95.png 125w" sizes="(max-width: 80px) 100vw, 80px" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2011/01/wwe-raw-1-10-11/">WWE Monday Night RAW January 10, 2011 Detailed Results</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2011-01-11">January 11, 2011</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#20007f;">
                	    <a href="https://www.cultofwhatever.com/2011/01/wwe-superstars-1-13-11/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2010/12/355-wwe-superstars-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2011/01/wwe-superstars-1-13-11/">WWE Superstars January 13, 2011 Detailed Results</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2011-01-13">January 13, 2011</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#20007f;">
                	    <a href="https://www.cultofwhatever.com/2014/01/wwe-smackdown-1-10-14-results/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2010/11/355-wwe-smackdown-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2010/11/355-wwe-smackdown-80x60.png 80w, https://www.cultofwhatever.com/wp-content/uploads/2010/11/355-wwe-smackdown-200x152.png 200w" sizes="(max-width: 80px) 100vw, 80px" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2014/01/wwe-smackdown-1-10-14-results/">WWE SmackDown Results: January 10, 2014</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2014-01-11">January 11, 2014</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#20007f;">
                	    <a href="https://www.cultofwhatever.com/2011/02/wwe-intercontinental-title-belts-a-guide-to-the-gold/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2011/02/wwe-intercontinental-title-banner-2-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2011/02/wwe-intercontinental-title-banner-2-80x60.png 80w, https://www.cultofwhatever.com/wp-content/uploads/2011/02/wwe-intercontinental-title-banner-2-540x400.png 540w" sizes="(max-width: 80px) 100vw, 80px" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2011/02/wwe-intercontinental-title-belts-a-guide-to-the-gold/">WWE Intercontinental Title Belts: A Guide to the Gold</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/the-beltster/">The Beltster</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2011-02-19">February 19, 2011</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#20007f;">
                	    <a href="https://www.cultofwhatever.com/2013/04/thebigboots-top-ten-wrestlemania-opening-matches-of-all-time/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2013/04/cow-wrestlemania-24-jbl-finlay-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2013/04/thebigboots-top-ten-wrestlemania-opening-matches-of-all-time/">TheBigBoot&#8217;s Top Ten WrestleMania Opening Matches Of All Time</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/thebigboot/">TheBigBoot</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2013-04-07">April 7, 2013</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#20007f;">
                	    <a href="https://www.cultofwhatever.com/2015/10/interview-kurt-angle-talks-upcoming-qa-shows-in-the-uk-tna-stars-in-nxt-and-more/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2015/10/kurt-angle-tna-2015-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2015/10/interview-kurt-angle-talks-upcoming-qa-shows-in-the-uk-tna-stars-in-nxt-and-more/">Interview: Kurt Angle talks upcoming Q&#038;A shows in the UK, TNA stars in NXT and more</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/josh-modaberi/">Josh Modaberi</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2015-10-28">October 28, 2015</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#20007f;">
                	    <a href="https://www.cultofwhatever.com/2016/02/wwe-smackdown-2-25-16-results/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2010/11/355-wwe-smackdown-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2010/11/355-wwe-smackdown-80x60.png 80w, https://www.cultofwhatever.com/wp-content/uploads/2010/11/355-wwe-smackdown-200x152.png 200w" sizes="(max-width: 80px) 100vw, 80px" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2016/02/wwe-smackdown-2-25-16-results/">WWE SmackDown Results: February 25, 2016</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-02-26">February 26, 2016</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#faa200;">
                	    <a href="https://www.cultofwhatever.com/2017/01/conan-the-barbarian-is-still-awesome-35-years-later/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2017/01/conan-barbarian-arnold-schwarzenegger-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2017/01/conan-the-barbarian-is-still-awesome-35-years-later/">CONAN THE BARBARIAN is still awesome, 35 years later&#8230;</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-01-09">January 9, 2017</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#20007f;">
                	    <a href="https://www.cultofwhatever.com/2015/03/misfiremania-three-wrestlemania-shows-that-almost-killed-the-company/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2014/02/wwe-23082013-miz-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.cultofwhatever.com/2015/03/misfiremania-three-wrestlemania-shows-that-almost-killed-the-company/">MisfireMania: Three WrestleMania shows that almost killed the company</a></h4>
                        <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2015-03-23">March 23, 2015</time></div></div>                                           </div>
                </li>
    		    		</ul>
    		</div>    <div id="recent-comments-3" class="cb-sidebar-widget widget_recent_comments"><h3 class="cb-sidebar-widget-title">Latest Comments</h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Calixtro xx</span> on <a href="https://www.cultofwhatever.com/2017/03/star-trek-nemesis-ended-the-berman-era-with-a-whimper/#comment-4595">Star Trek Nemesis ended the Berman era with a whimper</a></li><li class="recentcomments"><span class="comment-author-link">Jacob Stamm</span> on <a href="https://www.cultofwhatever.com/2015/05/episode-iii-sucked-too-coming-to-grips-with-the-disappointment-of-the-prequels/#comment-4594">Episode III sucked too: Coming to grips with the disappointment of the Prequels.</a></li><li class="recentcomments"><span class="comment-author-link">Dumbodores Revenge</span> on <a href="https://www.cultofwhatever.com/2017/03/spoiler-review-logan-is-a-masterpiece-of-brutality-and-raw-emotions/#comment-4593">Spoiler Review: LOGAN is a masterpiece of brutality and raw emotions</a></li><li class="recentcomments"><span class="comment-author-link">Awesome Cat</span> on <a href="https://www.cultofwhatever.com/2017/02/learning-from-success-has-never-been-the-nintendo-way/#comment-4592">Learning from success has never been the Nintendo way</a></li><li class="recentcomments"><span class="comment-author-link">Angela Weaver</span> on <a href="https://www.cultofwhatever.com/2017/03/spoiler-review-logan-is-a-masterpiece-of-brutality-and-raw-emotions/#comment-4591">Spoiler Review: LOGAN is a masterpiece of brutality and raw emotions</a></li></ul></div><div id="text-32" class="cb-sidebar-widget widget_text">			<div class="textwidget"><div align="center"><a href="https://www.cultofwhatever.com/bookmark-cult-of-whatever/"><img src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/cow336.jpg" alt="Bookmark Cult of Whatever" width="336" height="280" border="0"></a></div>
</div>
		</div><div id="text-18" class="cb-sidebar-widget widget_text"><h3 class="cb-sidebar-widget-title">Follow us on Google+</h3>			<div class="textwidget">
<!-- Place this tag where you want the widget to render. -->
<div class="g-page" data-width="324" data-href="//plus.google.com/109480483111289240773/about" data-rel="publisher"></div>

<!-- Place this tag after the last widget tag. -->
<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>
</div>
		</div>
</aside>
					<div id="main" class="cb-full-width clearfix" role="main">
						<h3 class="cb-block-title" style="border-bottom: 4px solid #faa200">Latest Articles</h3>
						<div id="cb-latest-posts">
													<div class="cb-line clearfix masonry-container">
						        <article id="post-35521" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2017/03/legion-s01e05-chapter-five-in-which-evil-wears-a-human-face/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s01e5-aubrey-plaza-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s01e5-aubrey-plaza-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s01e5-aubrey-plaza-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s01e5-aubrey-plaza-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s01e5-aubrey-plaza.jpg 700w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/legion-s01e05-chapter-five-in-which-evil-wears-a-human-face/">Legion S01E05: Chapter Five &#8211; In which evil wears a human face</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-09">March 9, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Legion delivers its most exhausting and rewarding episode yet.</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/legion-s01e05-chapter-five-in-which-evil-wears-a-human-face/" class="masonry-link-on-hover">
                  <h2 class="h4">Legion S01E05: Chapter Five &#8211; In which evil wears a human face</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-09">March 9, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Legion delivers its most exhausting and rewarding episode yet.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35491" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2017/03/some-game-of-thrones-crazy-fan-theories-to-keep-us-warm-before-the-shows-return/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2016/06/game-of-thrones-s6-e7-david-rintoul-aerys-targaryen-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/06/game-of-thrones-s6-e7-david-rintoul-aerys-targaryen-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2016/06/game-of-thrones-s6-e7-david-rintoul-aerys-targaryen-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2016/06/game-of-thrones-s6-e7-david-rintoul-aerys-targaryen-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2016/06/game-of-thrones-s6-e7-david-rintoul-aerys-targaryen.jpg 700w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/some-game-of-thrones-crazy-fan-theories-to-keep-us-warm-before-the-shows-return/">Some Game of Thrones crazy fan theories to keep us warm before the show’s return</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-09">March 9, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Here's some Game of Thrones fan theories to make you forget that the show isn't back yet...</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/some-game-of-thrones-crazy-fan-theories-to-keep-us-warm-before-the-shows-return/" class="masonry-link-on-hover">
                  <h2 class="h4">Some Game of Thrones crazy fan theories to keep us warm before the show’s return</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-09">March 9, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Here's some Game of Thrones fan theories to make you forget that the show isn't back yet...</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35518" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#20007f;">
               <a href="https://www.cultofwhatever.com/2017/03/wwe-wm33-updated-card/"><img width="360" height="278" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/wrestlemania-33-sign-logo-360x278.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/02/wrestlemania-33-sign-logo-360x278.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/wrestlemania-33-sign-logo-300x232.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/wrestlemania-33-sign-logo.jpg 700w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/wwe-wm33-updated-card/">WWE Spoilers: Updated card for WrestleMania 33</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-09">March 9, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/wrestling-news/" title="View all posts in Wrestling News">Wrestling News</a></div></div>             <div class="cb-excerpt" style="display: none;">Which new championship matches have been announced for WrestleMania 33? Which WrestleMania tradition will return for the fourth year in a row?</div>

              <div class="blog-hidden-content" style="background: rgba(32,0,127, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/wwe-wm33-updated-card/" class="masonry-link-on-hover">
                  <h2 class="h4">WWE Spoilers: Updated card for WrestleMania 33</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-09">March 9, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/wrestling-news/" title="View all posts in Wrestling News">Wrestling News</a></div></div>                   <div class="cb-excerpt" style="display: none;">Which new championship matches have been announced for WrestleMania 33? Which WrestleMania tradition will return for the fourth year in a row?</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-34244" class="cb-blog-style-c clearfix cb-last masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#24bc3a;">
               <a href="https://www.cultofwhatever.com/2017/03/nintendos-switch-launch-lineup-is-deceptively-great/"><img width="360" height="203" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-nintendo-switch-games-360x203.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-nintendo-switch-games-360x203.png 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-nintendo-switch-games-300x169.png 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-nintendo-switch-games-768x432.png 768w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-nintendo-switch-games-1024x576.png 1024w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-nintendo-switch-games.png 1200w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/nintendos-switch-launch-lineup-is-deceptively-great/">Nintendo&#8217;s Switch launch lineup is deceptively great</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-08">March 8, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/video-games/video-game-blogs/" title="View all posts in Video Game Blogs">Video Game Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Still on the fence about getting a Nintendo Switch? Let's break down all the games in its launch line-up and see if there's something for everyone to enjoy.</div>

              <div class="blog-hidden-content" style="background: rgba(36,188,58, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/nintendos-switch-launch-lineup-is-deceptively-great/" class="masonry-link-on-hover">
                  <h2 class="h4">Nintendo&#8217;s Switch launch lineup is deceptively great</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-08">March 8, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/video-games/video-game-blogs/" title="View all posts in Video Game Blogs">Video Game Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Still on the fence about getting a Nintendo Switch? Let's break down all the games in its launch line-up and see if there's something for everyone to enjoy.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35497" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#20007f;">
               <a href="https://www.cultofwhatever.com/2017/03/wwe-smackdown-3-7-17-results/"><img width="355" height="130" src="https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-smackdown-logo-0716-grey.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-smackdown-logo-0716-grey.jpg 355w, https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-smackdown-logo-0716-grey-300x110.jpg 300w" sizes="(max-width: 355px) 100vw, 355px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/wwe-smackdown-3-7-17-results/">WWE SmackDown LIVE Results: March 7, 2017</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-08">March 8, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/show-reports/wwe-smackdown/" title="View all posts in WWE SmackDown">WWE SmackDown</a></div></div>             <div class="cb-excerpt" style="display: none;">Who earned the undisputed right to challenge Bray Wyatt for the WWE Championship at WrestleMania? How did Baron Corbin try to end the career of Dean Ambrose? How did Alexa Bliss' own words lead to her having the toughest title defense of her career at WrestleMania? What did The Miz have to say about John Cena & Nikki Bella's relationship?</div>

              <div class="blog-hidden-content" style="background: rgba(32,0,127, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/wwe-smackdown-3-7-17-results/" class="masonry-link-on-hover">
                  <h2 class="h4">WWE SmackDown LIVE Results: March 7, 2017</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-08">March 8, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/show-reports/wwe-smackdown/" title="View all posts in WWE SmackDown">WWE SmackDown</a></div></div>                   <div class="cb-excerpt" style="display: none;">Who earned the undisputed right to challenge Bray Wyatt for the WWE Championship at WrestleMania? How did Baron Corbin try to end the career of Dean Ambrose? How did Alexa Bliss' own words lead to her having the toughest title defense of her career at WrestleMania? What did The Miz have to say about John Cena & Nikki Bella's relationship?</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-34228" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#faa200;">
               <a href="https://www.cultofwhatever.com/2017/03/star-trek-nemesis-ended-the-berman-era-with-a-whimper/"><img width="360" height="153" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-star-trek-nemesis-ships-360x153.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-star-trek-nemesis-ships-360x153.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-star-trek-nemesis-ships-300x128.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-star-trek-nemesis-ships-768x326.jpg 768w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-star-trek-nemesis-ships-1024x435.jpg 1024w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/bg-star-trek-nemesis-ships.jpg 1200w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/star-trek-nemesis-ended-the-berman-era-with-a-whimper/">Star Trek Nemesis ended the Berman era with a whimper</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-07">March 7, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-blogs/" title="View all posts in Movie Blogs">Movie Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">After a mildly disappointing ninth movie, Star Trek returned "Nemesis," hoping to send the TNG crew out with a bang. Unfortunately they went out with a whimper.</div>

              <div class="blog-hidden-content" style="background: rgba(250,162,0, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/star-trek-nemesis-ended-the-berman-era-with-a-whimper/" class="masonry-link-on-hover">
                  <h2 class="h4">Star Trek Nemesis ended the Berman era with a whimper</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-07">March 7, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-blogs/" title="View all posts in Movie Blogs">Movie Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">After a mildly disappointing ninth movie, Star Trek returned "Nemesis," hoping to send the TNG crew out with a bang. Unfortunately they went out with a whimper.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35480" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#20007f;">
               <a href="https://www.cultofwhatever.com/2017/03/wwe-raw-3-6-17-results/"><img width="355" height="123" src="https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-raw-logo-0716.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-raw-logo-0716.png 355w, https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-raw-logo-0716-300x104.png 300w" sizes="(max-width: 355px) 100vw, 355px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/wwe-raw-3-6-17-results/">WWE RAW Results: March 6, 2017</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-07">March 7, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/show-reports/wwe-raw/" title="View all posts in WWE Raw">WWE Raw</a></div></div>             <div class="cb-excerpt" style="display: none;">Who made an unexpected appearance on RAW and who confronted him to set up a huge match for WrestleMania? Who made an appearance on RAW to confront Goldberg? What happened when Chris Jericho demanded answers from Kevin Owens? How will Bayley find herself in an unenviable title defense at WrestleMania? How did Austin Aries make a statement at the expense of Neville?</div>

              <div class="blog-hidden-content" style="background: rgba(32,0,127, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/wwe-raw-3-6-17-results/" class="masonry-link-on-hover">
                  <h2 class="h4">WWE RAW Results: March 6, 2017</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-07">March 7, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/show-reports/wwe-raw/" title="View all posts in WWE Raw">WWE Raw</a></div></div>                   <div class="cb-excerpt" style="display: none;">Who made an unexpected appearance on RAW and who confronted him to set up a huge match for WrestleMania? Who made an appearance on RAW to confront Goldberg? What happened when Chris Jericho demanded answers from Kevin Owens? How will Bayley find herself in an unenviable title defense at WrestleMania? How did Austin Aries make a statement at the expense of Neville?</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35463" class="cb-blog-style-c clearfix cb-last masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2017/03/the-walking-dead-s07e12-say-yes-once-again-the-characters-are-they-key-to-good-story-telling/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/walking-dead-s07e12-rick-michonne-andrew-lincoln-danai-gurira-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/walking-dead-s07e12-rick-michonne-andrew-lincoln-danai-gurira-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/walking-dead-s07e12-rick-michonne-andrew-lincoln-danai-gurira-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/walking-dead-s07e12-rick-michonne-andrew-lincoln-danai-gurira-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/walking-dead-s07e12-rick-michonne-andrew-lincoln-danai-gurira.jpg 700w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/the-walking-dead-s07e12-say-yes-once-again-the-characters-are-they-key-to-good-story-telling/">The Walking Dead S07E12: Say Yes &#8211; Once again the characters are they key to good story-telling</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-06">March 6, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">It's another solid episode from The Walking Dead in a season that's slowly improving.</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/the-walking-dead-s07e12-say-yes-once-again-the-characters-are-they-key-to-good-story-telling/" class="masonry-link-on-hover">
                  <h2 class="h4">The Walking Dead S07E12: Say Yes &#8211; Once again the characters are they key to good story-telling</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-06">March 6, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">It's another solid episode from The Walking Dead in a season that's slowly improving.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35451" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#20007f;">
               <a href="https://www.cultofwhatever.com/2017/03/wwe-fastlane-2017-results/"><img width="360" height="524" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/wwe-fastlane-2017-poster-360x524.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/wwe-fastlane-2017-poster-360x524.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/wwe-fastlane-2017-poster-206x300.jpg 206w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/wwe-fastlane-2017-poster.jpg 481w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/wwe-fastlane-2017-results/">WWE Fastlane 2017 Results</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-06">March 6, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/show-reports/wwe-ppvs/" title="View all posts in WWE PPVs">WWE PPVs</a></div></div>             <div class="cb-excerpt" style="display: none;">How did Chris Jericho get the ultimate payback against former best friend Kevin Owens? Was Roman Reigns able to topple "The Monster Among Men" Braun Strowman? Did Bayley end Charlotte Flair's undefeated pay-per-view streak? Was Sami Zayn able to overcome Samoa Joe? How did Rusev and Jinder Mahal try, and fail, to prove themselves at Fastlane? Who emerged from a show-stealing title match as the Cruiserweight Champion?</div>

              <div class="blog-hidden-content" style="background: rgba(32,0,127, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/wwe-fastlane-2017-results/" class="masonry-link-on-hover">
                  <h2 class="h4">WWE Fastlane 2017 Results</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-06">March 6, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/show-reports/wwe-ppvs/" title="View all posts in WWE PPVs">WWE PPVs</a></div></div>                   <div class="cb-excerpt" style="display: none;">How did Chris Jericho get the ultimate payback against former best friend Kevin Owens? Was Roman Reigns able to topple "The Monster Among Men" Braun Strowman? Did Bayley end Charlotte Flair's undefeated pay-per-view streak? Was Sami Zayn able to overcome Samoa Joe? How did Rusev and Jinder Mahal try, and fail, to prove themselves at Fastlane? Who emerged from a show-stealing title match as the Cruiserweight Champion?</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-34234" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#faa200;">
               <a href="https://www.cultofwhatever.com/2017/03/spoiler-review-logan-is-a-masterpiece-of-brutality-and-raw-emotions/"><img width="360" height="225" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/logan-wolverine-hugh-jackman-2-360x225.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/logan-wolverine-hugh-jackman-2-360x225.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/logan-wolverine-hugh-jackman-2-300x187.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/logan-wolverine-hugh-jackman-2-430x270.jpg 430w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/logan-wolverine-hugh-jackman-2-400x250.jpg 400w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/logan-wolverine-hugh-jackman-2.jpg 700w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/spoiler-review-logan-is-a-masterpiece-of-brutality-and-raw-emotions/">Spoiler Review: LOGAN is a masterpiece of brutality and raw emotions</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-05">March 5, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-reviews/" title="View all posts in Movie Reviews">Movie Reviews</a></div></div>             <div class="cb-excerpt" style="display: none;">Logan embraces all the violence and bloodshed its character is famous for better than any X-Men film before it. It also rips your heart out on more than one occasion.</div>

              <div class="blog-hidden-content" style="background: rgba(250,162,0, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/spoiler-review-logan-is-a-masterpiece-of-brutality-and-raw-emotions/" class="masonry-link-on-hover">
                  <h2 class="h4">Spoiler Review: LOGAN is a masterpiece of brutality and raw emotions</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-05">March 5, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-reviews/" title="View all posts in Movie Reviews">Movie Reviews</a></div></div>                   <div class="cb-excerpt" style="display: none;">Logan embraces all the violence and bloodshed its character is famous for better than any X-Men film before it. It also rips your heart out on more than one occasion.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-34233" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#20007f;">
               <a href="https://www.cultofwhatever.com/2017/03/your-so-of-course-preview-of-wwe-fast-lane-2017/"><img width="360" height="203" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/Fastlane2017Poster-360x203.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/02/Fastlane2017Poster-360x203.png 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/Fastlane2017Poster-300x169.png 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/Fastlane2017Poster.png 700w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/your-so-of-course-preview-of-wwe-fast-lane-2017/">Your SO OF COURSE preview of WWE Fast Lane 2017</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-05">March 5, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/blogs/wwe-blogs/" title="View all posts in WWE">WWE</a></div></div>             <div class="cb-excerpt" style="display: none;">You can't just predict a WWE PPV, you have to account for the insane and capricious whims of Vince McMahon. THIS is your SO OF COURSE preview of WWE FASTLANE 2017!</div>

              <div class="blog-hidden-content" style="background: rgba(32,0,127, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/your-so-of-course-preview-of-wwe-fast-lane-2017/" class="masonry-link-on-hover">
                  <h2 class="h4">Your SO OF COURSE preview of WWE Fast Lane 2017</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-05">March 5, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/blogs/wwe-blogs/" title="View all posts in WWE">WWE</a></div></div>                   <div class="cb-excerpt" style="display: none;">You can't just predict a WWE PPV, you have to account for the insane and capricious whims of Vince McMahon. THIS is your SO OF COURSE preview of WWE FASTLANE 2017!</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35415" class="cb-blog-style-c clearfix cb-last masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2017/03/riverdale-s01e06-review-faster-pussycats-kill-kill-this-episode-has-everything-except-cheryl/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/riverdale-s01e06-cole-sprouse-lili-reinhart-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/riverdale-s01e06-cole-sprouse-lili-reinhart-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/riverdale-s01e06-cole-sprouse-lili-reinhart-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/riverdale-s01e06-cole-sprouse-lili-reinhart-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/riverdale-s01e06-cole-sprouse-lili-reinhart.jpg 700w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/riverdale-s01e06-review-faster-pussycats-kill-kill-this-episode-has-everything-except-cheryl/">Riverdale S01E06 Review: Faster, Pussycats! Kill! Kill! &#8211; This episode has everything! (Except Cheryl)</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-05">March 5, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">We finally get to meet Polly Cooper on a plot-packed episode of Riverdale.</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/riverdale-s01e06-review-faster-pussycats-kill-kill-this-episode-has-everything-except-cheryl/" class="masonry-link-on-hover">
                  <h2 class="h4">Riverdale S01E06 Review: Faster, Pussycats! Kill! Kill! &#8211; This episode has everything! (Except Cheryl)</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-05">March 5, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">We finally get to meet Polly Cooper on a plot-packed episode of Riverdale.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35396" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2017/03/legion-s01e04-chapter-four-the-most-perplexingly-entertaining-superhero-show/"><img width="360" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s1e4-dan-stevens-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s1e4-dan-stevens-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s1e4-dan-stevens-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s1e4-dan-stevens-600x400.jpg 600w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/legion-s1e4-dan-stevens.jpg 700w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/legion-s01e04-chapter-four-the-most-perplexingly-entertaining-superhero-show/">Legion S01E04: Chapter Four &#8211; The most perplexingly entertaining superhero show?</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-03">March 3, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Legion continues to be the most perplexingly entertaining superhero show.</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/legion-s01e04-chapter-four-the-most-perplexingly-entertaining-superhero-show/" class="masonry-link-on-hover">
                  <h2 class="h4">Legion S01E04: Chapter Four &#8211; The most perplexingly entertaining superhero show?</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/kevin-boyle/">Kevin Boyle</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-03">March 3, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Legion continues to be the most perplexingly entertaining superhero show.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35412" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#20007f;">
               <a href="https://www.cultofwhatever.com/2017/03/wwe-fastlane-2017-card/"><img width="360" height="203" src="https://www.cultofwhatever.com/wp-content/uploads/2017/02/Fastlane2017Poster-360x203.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/02/Fastlane2017Poster-360x203.png 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/Fastlane2017Poster-300x169.png 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/02/Fastlane2017Poster.png 700w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/wwe-fastlane-2017-card/">WWE Spoilers: Final card for Fastlane 2017</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-03">March 3, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/wrestling-news/" title="View all posts in Wrestling News">Wrestling News</a></div></div>             <div class="cb-excerpt" style="display: none;">On the last pay-per-view before WrestleMania, who will challenge Kevin Owens for the WWE Universal Championship? Which unstoppable Superstar will Roman Reigns collide with at Fastlane? Who will face off in a rematch for the RAW Women's Championship? Who will challenge "The King of the Cruiserweights" for his crown?</div>

              <div class="blog-hidden-content" style="background: rgba(32,0,127, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/wwe-fastlane-2017-card/" class="masonry-link-on-hover">
                  <h2 class="h4">WWE Spoilers: Final card for Fastlane 2017</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-03">March 3, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/wrestling-news/" title="View all posts in Wrestling News">Wrestling News</a></div></div>                   <div class="cb-excerpt" style="display: none;">On the last pay-per-view before WrestleMania, who will challenge Kevin Owens for the WWE Universal Championship? Which unstoppable Superstar will Roman Reigns collide with at Fastlane? Who will face off in a rematch for the RAW Women's Championship? Who will challenge "The King of the Cruiserweights" for his crown?</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-34242" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#24bc3a;">
               <a href="https://www.cultofwhatever.com/2017/03/system-review-nintendos-switch-brings-joy-and-cons/"><img width="360" height="175" src="https://www.cultofwhatever.com/wp-content/uploads/2016/10/nintendo-switch-2-360x175.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/system-review-nintendos-switch-brings-joy-and-cons/">SYSTEM REVIEW: Nintendo&#8217;s Switch brings Joy and Cons&#8230;</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-02">March 2, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/video-games/video-games-reviews/" title="View all posts in Video Game Reviews">Video Game Reviews</a></div></div>             <div class="cb-excerpt" style="display: none;">The Switch is here and we have the full hardware review. Jump inside as we break down the inspiration for the device and whether or not it lives up to the hype.</div>

              <div class="blog-hidden-content" style="background: rgba(36,188,58, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/system-review-nintendos-switch-brings-joy-and-cons/" class="masonry-link-on-hover">
                  <h2 class="h4">SYSTEM REVIEW: Nintendo&#8217;s Switch brings Joy and Cons&#8230;</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-02">March 2, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/video-games/video-games-reviews/" title="View all posts in Video Game Reviews">Video Game Reviews</a></div></div>                   <div class="cb-excerpt" style="display: none;">The Switch is here and we have the full hardware review. Jump inside as we break down the inspiration for the device and whether or not it lives up to the hype.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35288" class="cb-blog-style-c clearfix cb-last masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#1a93db;">
               <a href="https://www.cultofwhatever.com/2017/03/taboo-s01e08-review-taboo-ends-with-an-explosive-finale/"><img width="360" height="238" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/taboo-s1e8-tom-hardy-360x238.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/taboo-s1e8-tom-hardy-360x238.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/taboo-s1e8-tom-hardy-300x198.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/taboo-s1e8-tom-hardy.jpg 700w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/taboo-s01e08-review-taboo-ends-with-an-explosive-finale/">Taboo S01E08 Review: Taboo ends with an explosive finale!</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-02">March 2, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">Taboo's first--and maybe only--season comes to an end in an explosive finale.</div>

              <div class="blog-hidden-content" style="background: rgba(26,147,219, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/taboo-s01e08-review-taboo-ends-with-an-explosive-finale/" class="masonry-link-on-hover">
                  <h2 class="h4">Taboo S01E08 Review: Taboo ends with an explosive finale!</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/salome-g/">Salome G</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-02">March 2, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">Taboo's first--and maybe only--season comes to an end in an explosive finale.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-34231" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#faa200;">
               <a href="https://www.cultofwhatever.com/2017/03/star-wars-is-in-good-hands-looking-ahead-through-2017/"><img width="360" height="218" src="https://www.cultofwhatever.com/wp-content/uploads/2017/03/star-wars-logo-360x218.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/03/star-wars-logo-360x218.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/star-wars-logo-300x181.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/star-wars-logo-768x464.jpg 768w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/star-wars-logo-1024x619.jpg 1024w, https://www.cultofwhatever.com/wp-content/uploads/2017/03/star-wars-logo.jpg 1200w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/star-wars-is-in-good-hands-looking-ahead-through-2017/">Star Wars is in good hands; looking ahead through 2017&#8230;</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-01">March 1, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-blogs/" title="View all posts in Movie Blogs">Movie Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">2017 promises a lot for Star Wars fans. Books, shows and movies will bring surprises, revelations and loads of entertainment. It's a great time to be a fan. Here's why...</div>

              <div class="blog-hidden-content" style="background: rgba(250,162,0, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/star-wars-is-in-good-hands-looking-ahead-through-2017/" class="masonry-link-on-hover">
                  <h2 class="h4">Star Wars is in good hands; looking ahead through 2017&#8230;</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-01">March 1, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/movies/movie-blogs/" title="View all posts in Movie Blogs">Movie Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">2017 promises a lot for Star Wars fans. Books, shows and movies will bring surprises, revelations and loads of entertainment. It's a great time to be a fan. Here's why...</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35352" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#20007f;">
               <a href="https://www.cultofwhatever.com/2017/03/wwe-smackdown-2-28-17-results/"><img width="355" height="130" src="https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-smackdown-logo-0716-grey.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-smackdown-logo-0716-grey.jpg 355w, https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-smackdown-logo-0716-grey-300x110.jpg 300w" sizes="(max-width: 355px) 100vw, 355px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/03/wwe-smackdown-2-28-17-results/">WWE SmackDown LIVE Results: February 28, 2017</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-01">March 1, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/show-reports/wwe-smackdown/" title="View all posts in WWE SmackDown">WWE SmackDown</a></div></div>             <div class="cb-excerpt" style="display: none;">How did Randy Orton leave Bray Wyatt a pained and broken man in a dastardly act of betrayal? Who punched their ticket to WrestleMania to challenge Bray Wyatt for the WWE Title? Was Becky Lynch able to best Mickie James in a 2-out-of-3 Falls Match? What did John Cena and The Miz have to say to each other in a heated exchange on Miz TV? Was Apollo Crews able to get a measure of revenge against Dolph Ziggler in a Chairs Match?</div>

              <div class="blog-hidden-content" style="background: rgba(32,0,127, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/03/wwe-smackdown-2-28-17-results/" class="masonry-link-on-hover">
                  <h2 class="h4">WWE SmackDown LIVE Results: February 28, 2017</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-03-01">March 1, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/show-reports/wwe-smackdown/" title="View all posts in WWE SmackDown">WWE SmackDown</a></div></div>                   <div class="cb-excerpt" style="display: none;">How did Randy Orton leave Bray Wyatt a pained and broken man in a dastardly act of betrayal? Who punched their ticket to WrestleMania to challenge Bray Wyatt for the WWE Title? Was Becky Lynch able to best Mickie James in a 2-out-of-3 Falls Match? What did John Cena and The Miz have to say to each other in a heated exchange on Miz TV? Was Apollo Crews able to get a measure of revenge against Dolph Ziggler in a Chairs Match?</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-34229" class="cb-blog-style-c clearfix masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#24bc3a;">
               <a href="https://www.cultofwhatever.com/2017/02/learning-from-success-has-never-been-the-nintendo-way/"><img width="360" height="233" src="https://www.cultofwhatever.com/wp-content/uploads/2017/01/mario-nintendo-switch-360x233.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2017/01/mario-nintendo-switch-360x233.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2017/01/mario-nintendo-switch-300x194.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2017/01/mario-nintendo-switch.jpg 695w" sizes="(max-width: 360px) 100vw, 360px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/02/learning-from-success-has-never-been-the-nintendo-way/">Learning from success has never been the Nintendo way</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-28">February 28, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/video-games/video-game-blogs/" title="View all posts in Video Game Blogs">Video Game Blogs</a></div></div>             <div class="cb-excerpt" style="display: none;">As we prepare for the arrival of Switch, Nintendo fans hope their beloved company has learned from its past failures AND successes...for a change.</div>

              <div class="blog-hidden-content" style="background: rgba(36,188,58, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/02/learning-from-success-has-never-been-the-nintendo-way/" class="masonry-link-on-hover">
                  <h2 class="h4">Learning from success has never been the Nintendo way</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/matthew-martin/">Matthew Martin</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-28">February 28, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/video-games/video-game-blogs/" title="View all posts in Video Game Blogs">Video Game Blogs</a></div></div>                   <div class="cb-excerpt" style="display: none;">As we prepare for the arrival of Switch, Nintendo fans hope their beloved company has learned from its past failures AND successes...for a change.</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
        <article id="post-35327" class="cb-blog-style-c clearfix cb-last masonry-block" role="article">
            <div class="article-content">
              

           
            
          <div class="cb-mask" style="background-color:#20007f;">
               <a href="https://www.cultofwhatever.com/2017/02/wwe-raw-2-27-17-results/"><img width="355" height="123" src="https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-raw-logo-0716.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-raw-logo-0716.png 355w, https://www.cultofwhatever.com/wp-content/uploads/2016/07/355-raw-logo-0716-300x104.png 300w" sizes="(max-width: 355px) 100vw, 355px" /></a>          </div>


          <div class="cb-meta">
                         <h2 class="h4"><a href="https://www.cultofwhatever.com/2017/02/wwe-raw-2-27-17-results/">WWE RAW Results: February 27, 2017</a></h2>
             <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-28">February 28, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/show-reports/wwe-raw/" title="View all posts in WWE Raw">WWE Raw</a></div></div>             <div class="cb-excerpt" style="display: none;">How did Roman Reigns find himself barely surviving another hellacious encounter with Braun Strowman? What did Goldberg and Kevin Owens have to say to each other before Fastlane? How did Seth Rollins find himself face-to-face with Triple H on RAW? How did Sami Zayn get a measure of revenge against Samoa Joe? Who did Charlotte Flair pick as her partner to face Bayley & Sasha Banks? Who was the latest inductee announced for the 2017 WWE Hall of Fame?</div>

              <div class="blog-hidden-content" style="background: rgba(32,0,127, 0.9);">
                <a href="https://www.cultofwhatever.com/2017/02/wwe-raw-2-27-17-results/" class="masonry-link-on-hover">
                  <h2 class="h4">WWE RAW Results: February 27, 2017</h2>
                   <div class="cb-byline"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://www.cultofwhatever.com/author/cassidy-haslett/">Cassidy</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2017-02-28">February 28, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder"></i>  <a href="https://www.cultofwhatever.com/wrestling/show-reports/wwe-raw/" title="View all posts in WWE Raw">WWE Raw</a></div></div>                   <div class="cb-excerpt" style="display: none;">How did Roman Reigns find himself barely surviving another hellacious encounter with Braun Strowman? What did Goldberg and Kevin Owens have to say to each other before Fastlane? How did Seth Rollins find himself face-to-face with Triple H on RAW? How did Sami Zayn get a measure of revenge against Samoa Joe? Who did Charlotte Flair pick as her partner to face Bayley & Sasha Banks? Who was the latest inductee announced for the 2017 WWE Hall of Fame?</div>

                   
                   <!-- <div class="article-stats">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        <div class="no-facebook cb-byline-element"><span><i class="fa fa-facebook-square"></i></span></div>

                        <div class="no-twitter cb-byline-element"><span><i class="fa fa-twitter-square"></i></span></div>                       
                    </div> -->
                  </a>
              </div>

              <!-- <div class="article-stats visible">
                        <div class="no-likes cb-byline-element"><span><i class="fa fa-heart"></i></span></div>

                        
              </div> -->

          </div>
          </div>

        </article>
</div>							</div>
						</div>
					</div>

			</div> <!-- end #cb-content -->

     			<footer id="cb-footer" class=" wrap" role="contentinfo">

    				<div id="cb-widgets" class="cb-footer-b wrap clearfix">

                                                    <div class="cb-one cb-column clearfix">
                                <div id="nav_menu-3" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>Movies</span></h3><div class="menu-movies-container"><ul id="menu-movies" class="menu"><li id="menu-item-24175" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-24175"><a href="https://www.cultofwhatever.com/movies/">Movies</a></li>
<li id="menu-item-24178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24178"><a href="https://www.cultofwhatever.com/movies/movie-featured/">Movie Feature Articles</a></li>
<li id="menu-item-24177" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24177"><a href="https://www.cultofwhatever.com/movies/movie-blogs/">Movie Blogs</a></li>
<li id="menu-item-24179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24179"><a href="https://www.cultofwhatever.com/movies/movie-reviews/">Movie Reviews</a></li>
<li id="menu-item-24176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24176"><a href="https://www.cultofwhatever.com/movies/movie-dvd-reviews/">DVD Reviews</a></li>
</ul></div></div>                            </div>
                                                                            <div class="cb-two cb-column clearfix">
                                <div id="nav_menu-4" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>TV</span></h3><div class="menu-tv-container"><ul id="menu-tv" class="menu"><li id="menu-item-24180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24180"><a href="https://www.cultofwhatever.com/tv/">TV</a></li>
<li id="menu-item-24182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24182"><a href="https://www.cultofwhatever.com/tv/tv-featured/">TV Featured Articles</a></li>
<li id="menu-item-24181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24181"><a href="https://www.cultofwhatever.com/tv/tv-blogs/">TV Blogs</a></li>
</ul></div></div>                            </div>
                                                                            <div class="cb-three cb-column clearfix">
                                <div id="nav_menu-5" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>Video Games</span></h3><div class="menu-video-games-container"><ul id="menu-video-games" class="menu"><li id="menu-item-24183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24183"><a href="https://www.cultofwhatever.com/video-games/">Video Games</a></li>
<li id="menu-item-24285" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24285"><a href="https://www.cultofwhatever.com/video-games/video-game-featured/">Video Game Feature Articles</a></li>
<li id="menu-item-24184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24184"><a href="https://www.cultofwhatever.com/video-games/video-game-blogs/">Video Game Blogs</a></li>
<li id="menu-item-24185" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24185"><a href="https://www.cultofwhatever.com/video-games/video-game-previews/">Video Game Previews</a></li>
<li id="menu-item-24186" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24186"><a href="https://www.cultofwhatever.com/video-games/video-games-reviews/">Video Game Reviews</a></li>
</ul></div></div>                            </div>
                                                                            <div class="cb-four cb-column clearfix">
                                <div id="nav_menu-6" class="cb-footer-widget widget_nav_menu"><h3 class="cb-footer-widget-title"><span>Wrestling</span></h3><div class="menu-wrestling-container"><ul id="menu-wrestling" class="menu"><li id="menu-item-24187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24187"><a href="https://www.cultofwhatever.com/wrestling/">Wrestling</a></li>
<li id="menu-item-24189" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24189"><a href="https://www.cultofwhatever.com/wrestling/featured/">Wrestling Feature Articles</a></li>
<li id="menu-item-24188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24188"><a href="https://www.cultofwhatever.com/wrestling/blogs/">Wrestling Blogs</a></li>
<li id="menu-item-24191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24191"><a href="https://www.cultofwhatever.com/wrestling/interviews/">Wrestling Interviews</a></li>
<li id="menu-item-24195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24195"><a href="https://www.cultofwhatever.com/wrestling/show-reports/">WWE Show Reports</a></li>
<li id="menu-item-24192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24192"><a href="https://www.cultofwhatever.com/wrestling/wrestling-news/">Wrestling News</a></li>
<li id="menu-item-24193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24193"><a href="https://www.cultofwhatever.com/wrestling/reviews/">Wrestling Reviews</a></li>
<li id="menu-item-24190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24190"><a href="https://www.cultofwhatever.com/wrestling/gallery/">Wrestling Galleries</a></li>
<li id="menu-item-24194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24194"><a href="https://www.cultofwhatever.com/wrestling/video/">Wrestling Videos</a></li>
<li id="menu-item-24286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24286"><a href="http://www.talkwhateveronline.com/home/fantasy-wrestling-league/">WWE Fantasy Wrestling League</a></li>
<li id="menu-item-24196" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24196"><a href="https://www.cultofwhatever.com/wwe-uk-tour/">WWE UK Tour &#8211; April 2016</a></li>
<li id="menu-item-27522" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27522"><a href="https://www.cultofwhatever.com/nxt-uk-tour/">NXT UK Tour: June 2016</a></li>
</ul></div></div>                            </div>
                        
                    </div>

                     <div class="footer-h-menu">
                        <div class="menu-info-links-container"><ul id="menu-info-links" class="menu"><li id="menu-item-24197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24197"><a href="https://www.cultofwhatever.com/about-us/">About Us</a></li>
<li id="menu-item-24198" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24198"><a href="https://www.cultofwhatever.com/advertising/">Advertising</a></li>
<li id="menu-item-24199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24199"><a href="https://www.cultofwhatever.com/commenting-policy/">Commenting Policy</a></li>
<li id="menu-item-24200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24200"><a href="https://www.cultofwhatever.com/contact/">Contact Us</a></li>
<li id="menu-item-24201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24201"><a href="https://www.cultofwhatever.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-24202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24202"><a href="https://www.cultofwhatever.com/photo-credits/">Photo Credits</a></li>
<li id="menu-item-24203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24203"><a href="https://www.cultofwhatever.com/privacy-statement/">Privacy Statement</a></li>
<li id="menu-item-24390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24390"><a href="https://www.cultofwhatever.com/rss-feeds/">RSS</a></li>
<li id="menu-item-24204" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24204"><a href="https://www.cultofwhatever.com/write-for-us/">Write For Us</a></li>
</ul></div>                    </div>

                    
                        <div class="cb-footer-lower clearfix">

                            <div class="wrap clearfix">

                                <div class="cb-copyright">All Cult of Whatever articles, logos, illustrations and graphics are copyright CultOfWhatever.com. All other trademarks, logos and copyrights are the property of their respective owners. © 2017 CultOfWhatever. All Rights Reserved.</div>

        						
                                    <div class="footer-badge">
                                    <a title=""><img src="https://www.cultofwhatever.com/wp-content/themes/valenti/images/footer-badge.jpg"></a>
                                </div>

           					</div>

        				</div>
    				
    			</footer> <!-- end footer -->

    		</div> <!-- end #cb-container -->

		</div> <!-- end #cb-outer-container -->

		        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'wrestling101';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        <!-- Start of StatCounter Code for Default Guide -->
<script type="text/javascript">
var sc_project=10343041; 
var sc_invisible=1; 
var sc_security="d327d034"; 
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" +
scJsHost+
"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="shopify site
analytics" href="http://statcounter.com/shopify/"
target="_blank"><img class="statcounter"
src="http://c.statcounter.com/10343041/0/d327d034/1/"
alt="shopify site analytics"></a></div></noscript>
<!-- End of StatCounter Code for Default Guide --> <script type='text/javascript'>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</script><script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js?ver=0.6'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/comment-reply.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/jquery.flexslider-min.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/cookie.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/selectivizr-min.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/jquery.fs.boxer.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/jquery.ext.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti/library/js/cb-scripts.js?ver=3.2'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-content/themes/valenti-child/js/scripts.js'></script>
<script type='text/javascript' src='https://www.cultofwhatever.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
var tracker_url = 'https://www.cultofwhatever.com/wp-content/plugins/adrotate-pro/library/clicktracker.php';
</script>
<!-- /AdRotate JS -->


       
        



	</body>

</html> <!-- The End. what a ride! -->