<!DOCTYPE html><!--[if lt IE 7]><html  xmlns:og="//ogp.me/ns#" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]--><!--[if (IE 7)&!(IEMobile)]><html  xmlns:og="//ogp.me/ns#" class="no-js lt-ie9 lt-ie8"><![endif]--><!--[if (IE 8)&!(IEMobile)]><html  xmlns:og="//ogp.me/ns#" class="no-js lt-ie9"><![endif]--><!--[if gt IE 8]><!--><html xmlns:og="//ogp.me/ns#" class="no-js"><!--<![endif]--><head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
if(typeof isOrig==='undefined'){isOrig=false;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){if((impId!=="0"||isOrig===true)&&adUnit!==""){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}}
function AddPixelById(impFullId,pixelData,isOrig,revenue){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];var pix={type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig};if(typeof revenue!=='undefined'){pix.revenue=revenue;}
pixels.push(pix);}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}});}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false;}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=6', false, [], true, false, true, false);</script><style>
	
 
#cb-nav-bar.cb-dark-menu.stickybar {
    background: black!important;
}	
	
</style>

<style>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</style>
<meta charset="utf-8" />

<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]-->
<title>Riverdale S06E17 Review: American Psychos – Bored</title>
<link href="https://fonts.googleapis.com/css?family=Knewave" rel="stylesheet" type="text/css" />

<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="shortcut icon" href="" />
<link rel="pingback" href="https://www.cultofwhatever.com/xmlrpc.php" />
<link rel="preload" href="https://www.cultofwhatever.com/wp-content/themes/valenti/library/css/fontawesome/fonts/fontawesome-webfont.woff2?v=4.6.3" as="font" type="font/woff2" crossorigin="" />


<title>Riverdale S06E17 Review: American Psychos – Bored</title>

<meta name="description" content="Riverdale throws a serial killer convention, accompanied by a musical that doesn&#39;t mix as well with the storyline as you might think." />
<meta name="keywords" content="riverdale,season 6,episode review" />
<link rel="canonical" href="https://www.cultofwhatever.com/2022/06/riverdale-s06e17-review-american-psychos/" />
<meta property="og:site_name" content="Cult of Whatever ‣ Devoted to cult entertainment" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Riverdale S06E17 Review: American Psychos – Bored" />
<meta property="og:description" content="Riverdale throws a serial killer convention, accompanied by a musical that doesn&#39;t mix as well with the storyline as you might think." />
<meta property="og:url" content="https://www.cultofwhatever.com/2022/06/riverdale-s06e17-review-american-psychos/" />
<meta property="og:image" content="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty.jpg" />
<meta property="og:image:secure_url" content="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty.jpg" />
<meta property="og:image:width" content="750" />
<meta property="og:image:height" content="500" />
<meta property="article:published_time" content="2022-06-18T23:53:04Z" />
<meta property="article:modified_time" content="2022-06-18T23:53:04Z" />
<meta property="article:publisher" content="https://www.facebook.com/cultofwhatever" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@cultofwhatever" />
<meta name="twitter:domain" content="www.cultofwhatever.com" />
<meta name="twitter:title" content="Riverdale S06E17 Review: American Psychos – Bored" />
<meta name="twitter:description" content="Riverdale throws a serial killer convention, accompanied by a musical that doesn&#39;t mix as well with the storyline as you might think." />
<meta name="twitter:image" content="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty.jpg" />
<meta name="google" content="nositelinkssearchbox" />
<script type="application/ld+json" class="aioseo-schema">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</script>

<link rel="stylesheet" id="login-with-ajax-css" href="//www.cultofwhatever.com/wp-content/themes/valenti/plugins/login-with-ajax/widget.css?ver=3.1.11" type="text/css" media="all" />
<link rel="stylesheet" id="wp-block-library-css" href="//www.cultofwhatever.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.4" type="text/css" media="all" />
<link rel="stylesheet" id="scriptlesssocialsharing-css" href="//www.cultofwhatever.com/wp-content/plugins/scriptless-social-sharing/includes/css/scriptlesssocialsharing-style.css?ver=3.2.1" type="text/css" media="all" />
<style id="scriptlesssocialsharing-inline-css" type="text/css">
.scriptlesssocialsharing__buttons a.button { padding: 12px; flex: 1; }@media only screen and (max-width: 767px) { .scriptlesssocialsharing .sss-name { position: absolute; clip: rect(1px, 1px, 1px, 1px); height: 1px; width: 1px; border: 0; overflow: hidden; } }
</style>
<link rel="stylesheet" id="ppress-frontend-css" href="//www.cultofwhatever.com/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=3.1.17" type="text/css" media="all" />
<link rel="stylesheet" id="ppress-flatpickr-css" href="//www.cultofwhatever.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.1.17" type="text/css" media="all" />
<link rel="stylesheet" id="ppress-select2-css" href="//www.cultofwhatever.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=5.8.4" type="text/css" media="all" />
<link rel="stylesheet" id="__EPYT__style-css" href="//www.cultofwhatever.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=13.4.3" type="text/css" media="all" />
<style id="__EPYT__style-inline-css" type="text/css">

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel="stylesheet" id="wpdiscuz-font-awesome-css" href="//www.cultofwhatever.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/css/fontawesome-all.min.css?ver=7.2.2" type="text/css" media="all" />
<link rel="stylesheet" id="wpdiscuz_widgets_comm_vot_style-css" href="//www.cultofwhatever.com/wp-content/plugins/wpdiscuz-widgets/assets/css/style.min.css?ver=7.0.8" type="text/css" media="all" />
<link rel="stylesheet" id="wpdiscuz_widgets_slick_style-css" href="//www.cultofwhatever.com/wp-content/plugins/wpdiscuz-widgets/assets/third-party/slick/slick.min.css?ver=7.0.8" type="text/css" media="all" />
<link rel="stylesheet" id="cb-main-stylesheet-css" href="//www.cultofwhatever.com/wp-content/themes/valenti/library/css/style.min.css?ver=5.5.4" type="text/css" media="all" />
<link rel="stylesheet" id="cb-font-stylesheet-css" href="//fonts.googleapis.com/css?family=Oswald%3A400%2C700%2C400italic%7COpen+Sans%3A400%2C700%2C400italic&amp;subset=greek%2Cgreek-ext&amp;ver=5.5.4" type="text/css" media="all" />
<!--[if lt IE 9]>
<link rel='stylesheet' id='cb-ie-only-css'  href='//www.cultofwhatever.com/wp-content/themes/valenti/library/css/ie.css?ver=5.5.4' type='text/css' media='all' />
<![endif]-->
<link rel="stylesheet" id="cb-child-stylesheet-css" href="//www.cultofwhatever.com/wp-content/themes/valenti-child/style.css?ver=1.2.3" type="text/css" media="all" />
<script type="text/javascript" src="//code.jquery.com/jquery-1.9.1.min.js?ver=1.9.1" id="jquery-js"></script>
<script type="text/javascript" id="login-with-ajax-js-extra">
/* <![CDATA[ */
var LWA = {"ajaxurl":"https:\/\/www.cultofwhatever.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/themes/valenti/plugins/login-with-ajax/login-with-ajax.js?ver=3.1.11" id="login-with-ajax-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=5.8.4" id="ppress-flatpickr-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=5.8.4" id="ppress-select2-js"></script>
<script type="text/javascript" src="//code.jquery.com/jquery-migrate-1.4.1.min.js?ver=1.4.1" id="jquery-migrate-js"></script>
<script type="text/javascript" id="__ytprefs__-js-extra">
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/www.cultofwhatever.com\/wp-admin\/admin-ajax.php","security":"c219bc7e1b","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/www.cultofwhatever.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/www.cultofwhatever.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs__\",\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"13.4.3","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","pause_others":"","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=13.4.3" id="__ytprefs__-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/plugins/youtube-embed-plus/scripts/jquery.cookie.min.js?ver=13.4.3" id="__jquery_cookie__-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/themes/valenti/library/js/modernizr.custom.min.js?ver=2.6.2" id="cb-modernizr-js"></script>
<link rel="alternate" type="application/json+oembed" href="https://www.cultofwhatever.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cultofwhatever.com%2F2022%2F06%2Friverdale-s06e17-review-american-psychos%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.cultofwhatever.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cultofwhatever.com%2F2022%2F06%2Friverdale-s06e17-review-american-psychos%2F&amp;format=xml" />


<script type="text/javascript">
    window._mNHandle = window._mNHandle || {};
    window._mNHandle.queue = window._mNHandle.queue || [];
    medianet_versionId = "3121199";
</script>
<script src="https://contextual.media.net/dmedianet.js?cid=8CUTIP9M5" async="async"></script>


<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 {  margin: 0 auto; }
	.g-2 {  margin: 0 auto; }
	.g-3 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>


<meta property="og:title" content="Riverdale S06E17 Review: American Psychos – Bored" />
<meta property="og:site_name" content="Cult of Whatever" />
<meta property="og:url" content="https://www.cultofwhatever.com/2022/06/riverdale-s06e17-review-american-psychos/" />
<meta property="og:locale" content="en_us" />
<link rel="image_src" href="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-casey-cott-kevin-keller.jpg" />
<meta property="og:image" content="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-casey-cott-kevin-keller.jpg" />
<meta property="og:image" content="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-erinn-westbrook-kj-apa-vanessa-morgan-tabitha-archie-toni.jpg" />
<meta property="og:image" content="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty.jpg" />

<style type="text/css">.like-count-first.wpdiscuz-widget-comment .wpdiscuz-widget-icon-show-box{background:rgba(32, 37, 43, 0.38);}#widget-comments-container .wpdiscuz-widgets-tab-title-list li .fas{color:rgba(32, 37, 43, 0.63);}div#widget-comments-container.widget-comments-container{max-width:1250px;margin-left:10px;margin-right:10px;}div#widget-comments-container div.wpdiscuz-widgets-content{padding-right:10px;padding-left:10px;}div.widget-comments-container>div,div.widget-comments-container>ul>.tab-title-list-active-item{background-color:rgba(255, 255, 255, 0);}#widget-comments-container ul.wpdiscuz-widgets-tab-title-list li.tab-title-list-active-item{border-top-color:rgba(32, 37, 43, 0.63)}#widget-comments-container .wpd_widgets_items_wrapper .slick-arrow{background:rgba(32, 37, 43, 0.38);} #widget-comments-container{font-size:100%}</style>
<style>.cb-base-color, .cb-overlay-stars .fa-star, #cb-vote .fa-star, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, .bbp-submit-wrapper button:visited, .buddypress .cb-cat-header #cb-cat-title a,  .buddypress .cb-cat-header #cb-cat-title a:visited, .woocommerce .star-rating:before, .woocommerce-page .star-rating:before, .woocommerce .star-rating span, .woocommerce-page .star-rating span, .woocommerce .stars a {
            color:#1a93db;
        }#cb-search-modal .cb-header, .cb-join-modal .cb-header, .lwa .cb-header, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            border-color: #1a93db;
        }.cb-sidebar-widget .cb-sidebar-widget-title, .cb-multi-widget .tabbernav .tabberactive, .cb-author-page .cb-author-details .cb-meta .cb-author-page-contact, .cb-about-page .cb-author-line .cb-author-details .cb-meta .cb-author-page-contact, .cb-page-header, .cb-404-header, .cb-cat-header, #cb-footer #cb-widgets .cb-footer-widget-title span, #wp-calendar caption, .cb-tabs ul .current, .cb-tabs ul .ui-state-active, #bbpress-forums li.bbp-header, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li.selected, #buddypress div.item-list-tabs ul li.current, #buddypress .item-list-tabs ul li:hover, .woocommerce div.product .woocommerce-tabs ul.tabs li.active {
            border-bottom-color: #1a93db ;
        }#cb-main-menu .current-post-ancestor, #cb-main-menu .current-menu-item, #cb-main-menu .current-menu-ancestor, #cb-main-menu .current-post-parent, #cb-main-menu .current-menu-parent, #cb-main-menu .current_page_item, #cb-main-menu .current-page-ancestor, #cb-main-menu .current-category-ancestor, .cb-review-box .cb-bar .cb-overlay span, #cb-accent-color, .cb-highlight, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            background-color: #1a93db;
        }body:not(.cb-fis-tl-overlay).single .cb-title-fi .cb-byline a, body:not(.cb-fis-tl-overlay).single .cb-title-fi .cb-byline time {color: #1a93db;}body:not(.cb-fis-tl-overlay) .cb-byline .cb-category {background-color: #1a93db;}</style><style type="text/css">
                                                 body, #respond { font-family: 'Open Sans', sans-serif; }
                                                 h1, h2, h3, h4, h5, h6, .h1, .h2, .h3, .h4, .h5, .h6, #cb-nav-bar #cb-main-menu ul li > a, .cb-author-posts-count, .cb-author-title, .cb-author-position, .search  .s, .cb-review-box .cb-bar, .cb-review-box .cb-score-box, .cb-review-box .cb-title, #cb-review-title, .cb-title-subtle, #cb-top-menu a, .tabbernav, #cb-next-link a, #cb-previous-link a, .cb-review-ext-box .cb-score, .tipper-positioner, .cb-caption, .cb-button, #wp-calendar caption, .forum-titles, .bbp-submit-wrapper button, #bbpress-forums li.bbp-header, #bbpress-forums fieldset.bbp-form .bbp-the-content-wrapper input, #bbpress-forums .bbp-forum-title, #bbpress-forums .bbp-topic-permalink, .widget_display_stats dl dt, .cb-lwa-profile .cb-block, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li, #buddypress .activity-list li.load-more, #buddypress a.activity-time-since, #buddypress ul#groups-list li div.meta, .widget.buddypress div.item-options, .cb-activity-stream #buddypress .activity-header .time-since, .cb-font-header, .woocommerce table.shop_table th, .woocommerce-page table.shop_table th, .cb-infinite-scroll a, .cb-no-more-posts { font-family:'Oswald', sans-serif; }
                     </style><link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
<link rel="manifest" href="/manifest.json" />
<meta name="msapplication-TileColor" content="#ffffff" />
<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
<meta name="theme-color" content="#ffffff" />

<script async="" src="https://www.googletagmanager.com/gtag/js?id=UA-60765351-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-60765351-1');
</script>
<style type="text/css">.site-content article { -webkit-hyphens: none; -moz-hyphens: none; hyphens: none; }#cb-top-menu .cb-breaking-news ul li a { color:#808080; }#cb-nav-logo { margin-right: 100px!important; }</style><meta property="og:image" content="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty.jpg" /><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><style>#cb-nav-bar #cb-main-menu .main-nav .menu-item-24169:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169 .cb-sub-menu { background:#faa200!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24169 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#faa200!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-41523:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-41523:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-41523 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-41523 .cb-sub-menu { background:#fa0088!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-41523 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#fa0088!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24170:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170 .cb-sub-menu { background:#1a93db!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24170 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#1a93db!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24171:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171 .cb-sub-menu { background:#24bc3a!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24171 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#24bc3a!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24172:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172 .cb-sub-menu { background:#20007f!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24172 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#20007f!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-54333:hover,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-54333:focus,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-54333 .cb-sub-menu li .cb-grandchild-menu,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-54333 .cb-sub-menu { background:#191919!important; }
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-54333 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#191919!important; }</style><link rel="icon" href="https://www.cultofwhatever.com/wp-content/uploads/2018/05/cropped-cult-of-whatever-icon-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.cultofwhatever.com/wp-content/uploads/2018/05/cropped-cult-of-whatever-icon-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.cultofwhatever.com/wp-content/uploads/2018/05/cropped-cult-of-whatever-icon-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.cultofwhatever.com/wp-content/uploads/2018/05/cropped-cult-of-whatever-icon-512-270x270.png" />
<style type="text/css" id="wp-custom-css">
			body, p, h1, h2, h3, h4, h5, h6 {
    -moz-hyphens: none !important;
    -ms-hyphens: none !important;
    -webkit-hyphens: none !important;
    hyphens: none !important;
}		</style>

<script data-ad-client="ca-pub-4708759492629486" async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://www.cultofwhatever.com/2022/06/riverdale-s06e17-review-american-psychos/"><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 261200;
var ezdomain = 'cultofwhatever.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":261200,"engaged_time_visit":0,"ezcache_level":1,"ezcache_skip_code":11,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"702a4c39-e279-4cf2-40bf-a0f681072297","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":135735,"response_time_orig":1176,"serverid":"3.238.122.93:25835","state":"VA","t_epoch":1655651552,"template_id":120,"time_on_site_visit":0,"url":"https://www.cultofwhatever.com/2022/06/riverdale-s06e17-review-american-psychos/","user_id":0,"word_count":2098,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_261200=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["702a4c39-e279-4cf2-40bf-a0f681072297", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body class="post-template-default single single-post postid-70037 single-format-standard  cb-sticky-mm cb-mod-underlines cb-mod-zoom cb-m-sticky cb-sb-nar-embed-fw cb-cat-t-dark cb-mobm-light cb-gs-style-a cb-modal-dark cb-light-blog cb-sidebar-right cb-boxed cb-fis-type-standard cb-fis-tl-default cb-fw-bs">

<div id="fb-root"></div>
<script>
        /*
        (function(d, s, id) {
          var js, fjs = d.getElementsByTagName(s)[0];
          if (d.getElementById(id)) return;
          js = d.createElement(s); js.id = id;
          js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
          fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));
        */
        </script>

<div id="cb-outer-container">

<div id="cb-mob-menu" class="clearfix cb-dark-menu">
<a href="#" id="cb-mob-close" class="cb-link"><i class="fa cb-times"></i></a>
<div class="cb-mob-menu-wrap">
<ul class="cb-small-nav"><li id="menu-item-24205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-24205"><a href="https://www.cultofwhatever.com/">Home</a></li>
<li id="menu-item-24206" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24206"><a href="https://www.cultofwhatever.com/movies/">Movies</a></li>
<li id="menu-item-41524" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41524"><a href="https://www.cultofwhatever.com/music/">Music</a></li>
<li id="menu-item-24207" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-24207"><a href="https://www.cultofwhatever.com/tv/">TV</a></li>
<li id="menu-item-24208" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24208"><a href="https://www.cultofwhatever.com/video-games/">Video Games</a></li>
<li id="menu-item-24209" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24209"><a href="https://www.cultofwhatever.com/wrestling/">Wrestling</a></li>
<li id="menu-item-54334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54334"><a href="https://www.cultofwhatever.com/topics/">Topics</a></li>
<li id="menu-item-61226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61226"><a href="https://www.cultofwhatever.com/latest-comments/">Latest Comments</a></li>
</ul> </div>
</div>

<div id="cb-search-modal" class="cb-s-modal cb-modal cb-dark-menu">
<div class="cb-search-box">
<div class="cb-header">
<div class="cb-title">Search</div>
<div class="cb-close">
<span class="cb-close-modal cb-close-m"><i class="fa fa-times"></i></span>
</div>
</div><form role="search" method="get" class="cb-search" action="https://www.cultofwhatever.com/">
<input type="text" class="cb-search-field" placeholder="" value="" name="s" title="" />
<button class="cb-search-submit" type="submit" value=""><i class="fa fa-search"></i></button>
</form></div></div> <div id="cb_boxed_1" class="cb-boxed wrap clearfix" itemscope="" itemtype="http://schema.org/Article">
<header class="header clearfix wrap">
<div class="wrap clearfix">
<div id="cb-logo-box" class="wrap clearfix">
<div id="logo" class="cb-with-large">
<a href="https://www.cultofwhatever.com">
<img src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo.png" alt="Cult of Whatever logo" />
</a>
</div>
</div>
</div>
<nav id="cb-nav-bar" class="clearfix stickybar cb-dark-menu">
<div id="cb-main-menu" class="cb-nav-bar-wrap clearfix wrap">
<div id="cb-main-menu" class="menu-top-navigation-menu-container"><ul class="nav main-nav clearfix"><li id="menu-item-24169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24169"><a href="https://www.cultofwhatever.com/movies/">Movies</a><div class="cb-big-menu"><div class="cb-articles">
<div class="cb-featured">
<div class="cb-mega-title h2"><span style="border-bottom-color:#faa200;">Featured</span></div>
<ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2022/03/the-living-daylights-is-still-awesome-thirty-five-years-later/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2022/02/the-living-daylights-timothy-dalton-james-bond-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="The Living Daylights: Timothy Dalton as James Bond" /></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="https://www.cultofwhatever.com/2022/03/the-living-daylights-is-still-awesome-thirty-five-years-later/">The Living Daylights is still awesome, thirty-five years later</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-03-28">March 28, 2022</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder-o"></i> <a href="https://www.cultofwhatever.com/movies/movie-blogs/" title="View all posts in Movie Blogs">Movie Blogs</a></div></div></div></li></ul>
</div>
<div class="cb-recent cb-recent-fw">
<div class="cb-mega-title h2"><span style="border-bottom-color:#faa200;">Recent</span></div>
 <ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2022/06/review-jurassic-world-dominion/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/jurassic-world-dominion-logo-80x60.jpeg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Jurassic World Dominion Logo" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/06/review-jurassic-world-dominion/">REVIEW: Jurassic World Dominion – Here we go again…again</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-12">June 12, 2022</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2022/05/three-men-and-a-baby-is-still-awesome-thirty-five-years-later/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/three-men-and-a-baby-tom-selleck-ted-danson-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Three Men and a Baby: Tom Selleck and Ted Danson" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/05/three-men-and-a-baby-is-still-awesome-thirty-five-years-later/">Three Men and a Baby is still awesome thirty five years later</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-31">May 31, 2022</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2022/05/review-bobs-burgers-the-movie/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/bobs-burgers-poster-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="The Bob&#39;s Burgers Movie Poster" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/05/review-bobs-burgers-the-movie/">REVIEW: Bob’s Burgers The Movie is Bob’s Burgers The Show, which means it’s great</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-28">May 28, 2022</time></div></div></div></li> <li class="cb-article-4 clearfix"><div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2022/05/review-top-gun-maverick-is-a-sequel-that-soars/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/top-gun-maverick-tom-cruise-3-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Top Gun Maverick: Tom Cruise" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/05/review-top-gun-maverick-is-a-sequel-that-soars/">REVIEW: Top Gun Maverick is a sequel that soars!</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-27">May 27, 2022</time></div></div></div></li> <li class="cb-article-5 clearfix"><div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2022/05/star-wars-45-years-later-and-the-four-people-who-made-it-happen/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2020/05/star-wars-new-hope-mark-hamill-carrie-fisher-harrison-ford-luke-skywalker-princess-leia-han-solo-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Star Wars New Hope Mark Hamill Carrie Fisher Harrison Ford Luke Skywalker Princess Leia Han Solo" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/05/star-wars-45-years-later-and-the-four-people-who-made-it-happen/">Star Wars: 45 Years Later and the four people who made it happen</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-23">May 23, 2022</time></div></div></div></li> <li class="cb-article-6 clearfix"><div class="cb-mask" style="background-color:#faa200;"><a href="https://www.cultofwhatever.com/2022/05/review-chip-n-dale-rescue-rangers-is-a-fever-dream-of-family-fun/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/04/chip-n-dale-rescue-rangers-poster-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Chip &#39;N Dale Rescue Rangers Poster" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/05/review-chip-n-dale-rescue-rangers-is-a-fever-dream-of-family-fun/">REVIEW: Chip n Dale: Rescue Rangers is a fever dream of family fun</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-22">May 22, 2022</time></div></div></div></li></ul>
</div>
</div></div></li>
<li id="menu-item-41523" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41523"><a href="https://www.cultofwhatever.com/music/">Music</a><div class="cb-big-menu"><div class="cb-articles">
<div class="cb-featured">
<div class="cb-mega-title h2"><span style="border-bottom-color:#fa0088;">Random</span></div>
<ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2016/08/august-29-1966-candlestick-park-50-years-later/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2016/08/beatles-selfie-1966-480x240.png" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="Beatles Selfie 1966" /></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="https://www.cultofwhatever.com/2016/08/august-29-1966-candlestick-park-50-years-later/">August 29, 1966: Candlestick Park, 50 years later...</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2016-08-28">August 28, 2016</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder-o"></i> <a href="https://www.cultofwhatever.com/music/music-blogs/" title="View all posts in Music Blogs">Music Blogs</a></div></div></div></li></ul>
</div>
<div class="cb-recent cb-recent-fw">
<div class="cb-mega-title h2"><span style="border-bottom-color:#fa0088;">Recent</span></div>
<ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2021/12/what-get-back-reveals-about-the-beatles/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2021/11/beatles-get-back-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="The Beatles: Get Back" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2021/12/what-get-back-reveals-about-the-beatles/">What GET BACK reveals about the Beatles</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-12-15">December 15, 2021</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2021/07/the-boxer-is-a-song-about-being-conned/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2021/05/simon-and-garfunkel-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Simon And Garfunkel at Feyenoord Stadium in Rotterdam1982" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2021/07/the-boxer-is-a-song-about-being-conned/">The Boxer is a song about being conned</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-07-04">July 4, 2021</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2021/06/lady-gagas-discography-is-totally-out-of-order/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2021/04/lady-gaga-chromatica-album-cover-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Lady Gaga: Chromatica Album Cover" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2021/06/lady-gagas-discography-is-totally-out-of-order/">Lady Gaga’s discography is totally out of order</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-06-03">June 3, 2021</time></div></div></div></li> <li class="cb-article-4 clearfix"><div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2021/03/30-years-ago-music-fans-said-nevermind-to-michael-jackson/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2021/01/michael-jackson-thriller-album-cover-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Michael Jackson Thriller Album Cover" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2021/03/30-years-ago-music-fans-said-nevermind-to-michael-jackson/">Thirty years ago music fans said “Nevermind” to Michael Jackson</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-03-21">March 21, 2021</time></div></div></div></li> <li class="cb-article-5 clearfix"><div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2021/02/on-queens-the-miracle-and-the-importance-of-track-ordering/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2021/01/queen-ii-album-cover-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Queen II Album Cover" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2021/02/on-queens-the-miracle-and-the-importance-of-track-ordering/">On Queen’s The Miracle, and the importance of track ordering</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-02-16">February 16, 2021</time></div></div></div></li> <li class="cb-article-6 clearfix"><div class="cb-mask" style="background-color:#fa0088;"><a href="https://www.cultofwhatever.com/2020/06/50-years-ago-mccartney-dropped-lennon-and-went-solo/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2020/05/linda-paul-mccartney-1976-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Linda Paul Mccartney 1976" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2020/06/50-years-ago-mccartney-dropped-lennon-and-went-solo/">50 years ago, McCartney dropped “Lennon” and went solo…</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2020-06-05">June 5, 2020</time></div></div></div></li></ul>
</div>
</div></div></li>
<li id="menu-item-24170" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-24170"><a href="https://www.cultofwhatever.com/tv/">TV</a><div class="cb-big-menu"><div class="cb-articles">
<div class="cb-featured">
<div class="cb-mega-title h2"><span style="border-bottom-color:#1a93db;">Featured</span></div>
<ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2021/10/nancy-drew-s03e01-review-the-warning-of-the-frozen-heart-uh-oh/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2021/09/nancy-drew-s03e01-kennedy-mcmann-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="Nancy Drew S03e01: Kennedy McMann as Nancy" /></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="https://www.cultofwhatever.com/2021/10/nancy-drew-s03e01-review-the-warning-of-the-frozen-heart-uh-oh/">Nancy Drew S03E01 Review: The Warning of the Frozen Heart - Uh-oh!</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-10-10">October 10, 2021</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder-o"></i> <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div></div></li></ul>
</div>
<div class="cb-recent cb-recent-fw">
<div class="cb-mega-title h2"><span style="border-bottom-color:#1a93db;">Recent</span></div>
<ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2022/06/riverdale-s06e17-review-american-psychos/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Riverdale S06e17: Madelaine Petsch, Camila Mendes and Lili Reinhart as Cheryl, Veronica and Betty" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/06/riverdale-s06e17-review-american-psychos/">Riverdale S06E17 Review: American Psychos – Bored</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-18">June 18, 2022</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2022/06/star-trek-strange-new-worlds-episodes-6-7-review/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/star-trek-strange-new-worlds-s01e06-ian-ho-husein-madhavji-first-servant-elder-gamal-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Star Trek Strange New Worlds S01e06: Ian Ho and Husein Madhavji as First Servant and Elder Gamal" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/06/star-trek-strange-new-worlds-episodes-6-7-review/">Star Trek: Strange New Worlds – Episodes 6-7 review (the best and the not-so best)</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-18">June 18, 2022</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2022/06/roswell-new-mexico-s04e01-s04e02-review-steal-my-sunshine-fly/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/roswell-new-mexico-s04e01-jeanine-mason-liz-ortecho-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Roswell, New Mexico S04e01: Jeanine Mason as Liz Ortecho" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/06/roswell-new-mexico-s04e01-s04e02-review-steal-my-sunshine-fly/">Roswell, New Mexico S04E01 &amp; S04E02 Review: Steal My Sunshine &amp; Fly</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-17">June 17, 2022</time></div></div></div></li> <li class="cb-article-4 clearfix"><div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2022/06/dark-winds-s01e01-review-monster-slayer/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/dark-winds-s01e01-zahn-mcclarnon-joe-leaphorn-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Dark Winds S01e01: Zahn McClarnon as Joe Leaphorn" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/06/dark-winds-s01e01-review-monster-slayer/">Dark Winds S01E01 Review: Monster Slayer – Great start</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-14">June 14, 2022</time></div></div></div></li> <li class="cb-article-5 clearfix"><div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2022/06/evil-s03e01-review-the-demon-of-death/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/evil-s03e01-team-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Evil S03e01: The team" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/06/evil-s03e01-review-the-demon-of-death/">Evil S03E01 Review: The Demon of Death – Feeling unfulfilled</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-14">June 14, 2022</time></div></div></div></li> <li class="cb-article-6 clearfix"><div class="cb-mask" style="background-color:#1a93db;"><a href="https://www.cultofwhatever.com/2022/06/the-orville-s03e01-s03e02-review/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/the-orville-s03e01-anne-winters-mark-jackson-ensign-charly-burke-isaac-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="The Orville S03e01: Anne Winters and Mark Jackson as Ensign Charly Burke and Isaac" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/06/the-orville-s03e01-s03e02-review/">The Orville season three review part 1 (episodes 1-2 bring ups and downs)</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-12">June 12, 2022</time></div></div></div></li></ul>
</div>
</div></div></li>
<li id="menu-item-24171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24171"><a href="https://www.cultofwhatever.com/video-games/">Video Games</a><div class="cb-big-menu"><div class="cb-articles">
<div class="cb-featured">
<div class="cb-mega-title h2"><span style="border-bottom-color:#24bc3a;">Featured</span></div>
<ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2015/07/batman-arkham-knight-a-fitting-end-to-a-trilogy/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2015/07/arkham-knight-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="Arkham Knight" srcset="https://www.cultofwhatever.com/wp-content/uploads/2015/07/arkham-knight-480x240.jpg 480w, https://www.cultofwhatever.com/wp-content/uploads/2015/07/arkham-knight-1400x700.jpg 1400w" sizes="(max-width: 480px) 100vw, 480px" /></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="https://www.cultofwhatever.com/2015/07/batman-arkham-knight-a-fitting-end-to-a-trilogy/">Batman: Arkham Knight - A fitting end to a trilogy</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/tom-farr/" class="fn">Tom Farr</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2015-07-18">July 18, 2015</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder-o"></i> <a href="https://www.cultofwhatever.com/video-games/video-games-reviews/" title="View all posts in Video Game Reviews">Video Game Reviews</a></div></div></div></li></ul>
</div>
<div class="cb-recent cb-recent-fw">
<div class="cb-mega-title h2"><span style="border-bottom-color:#24bc3a;">Recent</span></div>
<ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2022/04/can-a-legend-of-zelda-movie-work/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2015/06/legend-of-zelda-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Legend Of Zelda" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/04/can-a-legend-of-zelda-movie-work/">Can a Legend of Zelda movie work?</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-04-06">April 6, 2022</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2021/12/which-system-had-the-better-launch-a-battle-of-four-nintendo-consoles/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2021/10/super-mario-64-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Super Mario 64" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2021/12/which-system-had-the-better-launch-a-battle-of-four-nintendo-consoles/">Which system had the better launch: A battle of four Nintendo consoles</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-12-01">December 1, 2021</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2021/11/happy-twentieth-to-nintendos-underrated-gem-the-gamecube/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2021/10/luigis-mansion-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Luigi&#39;s Mansion" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2021/11/happy-twentieth-to-nintendos-underrated-gem-the-gamecube/">Happy twentieth to Nintendo’s underrated gem, the Gamecube</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-11-18">November 18, 2021</time></div></div></div></li> <li class="cb-article-4 clearfix"><div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2021/10/metroid-dread-post-game-analysis-and-sequel-needs/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2021/10/metroid-dread-3-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Metroid Dread" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2021/10/metroid-dread-post-game-analysis-and-sequel-needs/">Metroid Dread – Post Game analysis and sequel needs</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-10-29">October 29, 2021</time></div></div></div></li> <li class="cb-article-5 clearfix"><div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2021/10/the-snes-turns-30-a-look-at-some-of-the-systems-best-soundtracks/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2021/08/mario-headphones-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Mario Headphones" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2021/10/the-snes-turns-30-a-look-at-some-of-the-systems-best-soundtracks/">The SNES Turns 30: A look at some of the system’s best soundtracks</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-10-22">October 22, 2021</time></div></div></div></li> <li class="cb-article-6 clearfix"><div class="cb-mask" style="background-color:#24bc3a;"><a href="https://www.cultofwhatever.com/2021/10/review-metroid-dread-reawakens-the-old-gamer-in-me/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2021/09/metroid-dread-poster-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Metroid Dread Poster" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2021/10/review-metroid-dread-reawakens-the-old-gamer-in-me/">REVIEW: Metroid Dread reawakens the old gamer in me</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-10-11">October 11, 2021</time></div></div></div></li></ul>
</div>
</div></div></li>
<li id="menu-item-24172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24172"><a href="https://www.cultofwhatever.com/wrestling/">Wrestling</a><div class="cb-big-menu"><div class="cb-articles">
<div class="cb-featured">
<div class="cb-mega-title h2"><span style="border-bottom-color:#20007f;">Featured</span></div>
<ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2017/04/your-so-of-course-preview-of-wwe-payback-2017/"><img width="480" height="240" src="https://www.cultofwhatever.com/wp-content/uploads/2017/04/wwe-payback-2017-poster-2-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="Wwe Payback 2017 Poster 2" /></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="https://www.cultofwhatever.com/2017/04/your-so-of-course-preview-of-wwe-payback-2017/">Your SO OF COURSE preview of WWE Payback 2017</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2017-04-30">April 30, 2017</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder-o"></i> <a href="https://www.cultofwhatever.com/wrestling/blogs/wwe-blogs/" title="View all posts in WWE Blogs">WWE Blogs</a></div></div></div></li></ul>
</div>
<div class="cb-recent cb-recent-fw">
<div class="cb-mega-title h2"><span style="border-bottom-color:#20007f;">Recent</span></div>
<ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2022/05/review-aew-double-or-nothing-2022-delivered-an-up-and-down-show/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/aew-double-or-nothing-2022-cm-punk-adam-page-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="AEW Double or Nothing 2022: CM Punk vs Adam Page" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/05/review-aew-double-or-nothing-2022-delivered-an-up-and-down-show/">REVIEW: AEW Double or Nothing 2022 delivered an up-and-down show</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-30">May 30, 2022</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2022/05/getting-aew-to-the-next-level/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2021/11/mjf-171121-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="MJF on AEW Dynamite 17th November 2021" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/05/getting-aew-to-the-next-level/">Getting AEW to the next level…</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-29">May 29, 2022</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2022/05/may-21-2001-a-forgotten-date-that-will-live-in-wwe-infamy/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/02/raw-210501-triple-h-stephanie-mcmahon-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Raw 210501: Triple H and Stephanie McMahon" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/05/may-21-2001-a-forgotten-date-that-will-live-in-wwe-infamy/">May 21, 2001 – A (forgotten) date that will live in WWE infamy</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-20">May 20, 2022</time></div></div></div></li> <li class="cb-article-4 clearfix"><div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2022/04/your-way-too-early-predictions-for-wwe-wrestlemania-39/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/03/wrestlemania-39-logo-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="WWE WrestleMania 39 Logo" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/04/your-way-too-early-predictions-for-wwe-wrestlemania-39/">Your WAY TOO EARLY predictions for WWE WrestleMania 39!</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-04-20">April 20, 2022</time></div></div></div></li> <li class="cb-article-5 clearfix"><div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2022/03/your-so-of-course-preview-of-wwe-wrestlemania-38/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2022/03/wwe-wrestlemania-38-poster-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="WWE WrestleMania 38 Poster" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/03/your-so-of-course-preview-of-wwe-wrestlemania-38/">Your SO OF COURSE preview of WWE WRESTLEMANIA 38!</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-03-30">March 30, 2022</time></div></div></div></li> <li class="cb-article-6 clearfix"><div class="cb-mask" style="background-color:#20007f;"><a href="https://www.cultofwhatever.com/2022/03/book-review-the-women-of-wrestlemania/"><img width="80" height="60" src="https://www.cultofwhatever.com/wp-content/uploads/2015/04/wrestlemania-31-paige-aj-lee-2-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="Wrestlemania 31 Paige Aj Lee 2" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.cultofwhatever.com/2022/03/book-review-the-women-of-wrestlemania/">BOOK REVIEW: The Women of WrestleMania is a balanced take on an under-valued slice of history</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-03-16">March 16, 2022</time></div></div></div></li></ul>
</div>
</div></div></li>
<li id="menu-item-54333" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54333"><a href="https://www.cultofwhatever.com/topics/">Topics</a><div class="cb-big-menu"></div></li>
<li class="cb-icons"><ul></ul></li><li id="cb-nav-logo" class="cb-nav-logo-always"><a href="https://www.cultofwhatever.com"><img src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo.png" alt="site logo" width="" height="" data-retina-src="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo@2x.png" /></a></li></ul></div> </div>
</nav>


<div id="cb-top-menu" class="clearfix cb-dark-menu">
<div class="wrap cb-top-menu-wrap clearfix">
<div class="cb-left-side cb-mob">
<a href="#" id="cb-mob-open"><i class="fa fa-bars"></i></a>
<div class="cb-breaking-news"><span>Latest <i class="fa fa-long-arrow-right"></i></span><ul><li><a href="https://www.cultofwhatever.com/2022/06/riverdale-s06e17-review-american-psychos/" title="Look Riverdale S06E17 Review: American Psychos - Bored">Riverdale S06E17 Review: American Psychos - Bored</a> </li> <li><a href="https://www.cultofwhatever.com/2022/06/star-trek-strange-new-worlds-episodes-6-7-review/" title="Look Star Trek: Strange New Worlds - Episodes 6-7 review (the best and the not-so best)">Star Trek: Strange New Worlds - Episodes 6-7 review (the best and the not-so best)</a> </li> <li><a href="https://www.cultofwhatever.com/2022/06/roswell-new-mexico-s04e01-s04e02-review-steal-my-sunshine-fly/" title="Look Roswell, New Mexico S04E01 &amp; S04E02 Review: Steal My Sunshine &amp; Fly">Roswell, New Mexico S04E01 &amp; S04E02 Review: Steal My Sunshine &amp; Fly</a> </li> <li><a href="https://www.cultofwhatever.com/2022/06/dark-winds-s01e01-review-monster-slayer/" title="Look Dark Winds S01E01 Review: Monster Slayer - Great start">Dark Winds S01E01 Review: Monster Slayer - Great start</a> </li> <li><a href="https://www.cultofwhatever.com/2022/06/evil-s03e01-review-the-demon-of-death/" title="Look Evil S03E01 Review: The Demon of Death - Feeling unfulfilled">Evil S03E01 Review: The Demon of Death - Feeling unfulfilled</a> </li> <li><a href="https://www.cultofwhatever.com/2022/06/review-jurassic-world-dominion/" title="Look REVIEW: Jurassic World Dominion - Here we go again...again">REVIEW: Jurassic World Dominion - Here we go again...again</a> </li> </ul></div></div><div class="cb-mob-right"><a href="#" data-cb-tip="Search" class="cb-tip-bot" class="cb-tip-bot cb-small-menu-icons cb-small-menu-search" id="cb-s-trigger-sm"><i class="fa fa-search"></i></a></div><ul class="cb-top-nav"><li id="menu-item-61212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61212"><a href="https://www.cultofwhatever.com/latest-comments/">Latest Comments</a></li>
</ul>
</div>
</div>

<a href="#" id="cb-to-top" class="cb-base-color"><i class="fa fa-long-arrow-up"></i></a>
</header>  <div id="cb-content" class="wrap clearfix">
<meta itemprop="datePublished" content="2022-06-18T19:53:04-04:00" />
<meta itemprop="dateModified" content="2022-06-18T19:53:04-04:00" />
<meta itemscope="" itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.cultofwhatever.com/2022/06/riverdale-s06e17-review-american-psychos/" />
<span class="cb-hide" itemscope="" itemprop="publisher" itemtype="https://schema.org/Organization">
<meta itemprop="name" content="Cult of Whatever" />
<meta itemprop="url" content="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo.png" />
<span class="cb-hide" itemscope="" itemprop="logo" itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.cultofwhatever.com/wp-content/uploads/2015/03/logo.png" />
</span>
</span>
<span class="cb-hide" itemprop="author" itemscope="" itemtype="https://schema.org/Person"><meta itemprop="name" content="Salome G" /></span>
<meta itemprop="headline" content="Riverdale S06E17 Review: American Psychos – Bored" />
<span class="cb-hide" itemscope="" itemtype="http://schema.org/ImageObject" itemprop="image">
<meta itemprop="url" content="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty.jpg" />
<meta itemprop="width" content="750" />
<meta itemprop="height" content="500" />
</span>
<div id="main" class="cb-main clearfix testttt">
<article id="post-70037" class="clearfix post-70037 post type-post status-publish format-standard has-post-thumbnail category-tv-blogs tag-riverdale">
<div id="cb-fis-wrap" class="cb-entry-header hentry cb-fis cb-style-off"><span class="cb-title-fi"><h1 class="entry-title cb-entry-title cb-single-title" itemprop="headline">Riverdale S06E17 Review: American Psychos – Bored</h1><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element vcard author"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="updated" datetime="2022-06-18">June 18, 2022</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder-o"></i> <a href="https://www.cultofwhatever.com/tv/tv-blogs/" title="View all posts in TV Blogs">TV Blogs</a></div></div></span></div> <div class="adrotate_group_container">
 </div>
<section class="cb-entry-content entry-content clearfix" itemprop="articleBody">
<p>Despite my interest in true crime, I can’t say that I’ve ever wanted to go to a convention for such. I really can’t see myself heading out to something the organizers describe as a “serial killer convention.” However, the phrase “Dr. Curdle, Jr. will be performing a simulated autopsy” might just get me there.</p>
<p><span id="more-70037"></span></p>
<p>Hey, guess what we’re doing this week on <em>Riverdale</em>? Yep, the convention. And it’s been a minute since we last saw the show, so it’ll be exciting for me to remember exactly why we’re doing this. Hang on, it’ll come to me. It’s a…TBK thing? Sure, I think that’s it.</p>
<p><img class="aligncenter size-full wp-image-70053" title="Riverdale S06e17: Casey Cott as Kevin Keller" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-casey-cott-kevin-keller.jpg" alt="Riverdale S06e17: Casey Cott as Kevin Keller" width="750" height="500" srcset="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-casey-cott-kevin-keller.jpg 750w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-casey-cott-kevin-keller-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-casey-cott-kevin-keller-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-casey-cott-kevin-keller-600x400.jpg 600w" sizes="(max-width: 750px) 100vw, 750px" /></p>
<p>Wait, what does that small print say? Annual musical epis–WHAT. I can’t believe this. They take a break and then immediately come out of the gate with a musical episode? Didn’t we just have one of these? Now I gotta do it again? Boy, I tell you what, if I’m going to sit through one of these, then y’all had better–*tranquilizer darts*</p>
<p>Whoa, okay. Slaughtercon. Let’s get it. Before we start, though, I should explain. Not about my neutral to negative feelings about musicals, but about this musical. Yes, there is a musical version of <em>American Psycho</em>. I know this solely from my fandom of Jonathan Bailey, who appeared in the UK musical that I’m pretty sure starred not a single American. (It did have a <a href="https://www.cultofwhatever.com/tag/doctor-who/" target="_blank" rel="noopener"><em>Doctor Who</em></a>, though!)</p>
<p>Beyond that, though, I know nothing about it. So this should be an enlightening experience for us all. I do love that before she names it, Veronica describes it as the “Holy Grail of serial killer musicals,” to which Charles asks, “<em>Sweeney Todd</em>“? I mean, he ain’t wrong. And now I kind of wish they’d do that one. But here we are. At Slaughtercon. [Note: In looking up the London production of the musical, I found out that <em>Riverdale</em> creator Roberto Aguirre-Sacasa wrote the book for it, hence the wild praise.]</p>
<p>Slaughtercon, by the way, will take place at Babylonium. If you think an upscale casino is a strange venue for a convention, especially this one, then you’re not alone. I agree. It’s not the musical part–Broadway performers host <a href="https://www.disappearedpod.com/" target="_blank" rel="noopener">one of my favorite crime-related podcasts</a>, after all. It’s the casino part.</p>
<p>Well, it’s this casino part. Babylonium has never been that highbrow–please see, for instance, its owner taking the stage to perform a cover of “Toxic.” However, it has always had a kind of vintage cool. I’m just saying that the vibe of the place doesn’t seem to fit with the reality of a grubby fan convention.</p>
<p>Hey, am I spending a lot of time not talking about the musical aspects of this musical episode? Yeah, maybe. But as I’ve said before, these aren’t the easiest episodes to discuss. Musical numbers don’t really move the plot forward, particularly if they’re from a completely different show.</p>
<p><img class="aligncenter size-full wp-image-70052" title="Riverdale S06e17: Erinn Westbrook, K.J. Apa and Vanessa Morgan as Tabitha, Archie and Toni" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-erinn-westbrook-kj-apa-vanessa-morgan-tabitha-archie-toni.jpg" alt="Riverdale S06e17: Erinn Westbrook, K.J. Apa and Vanessa Morgan as Tabitha, Archie and Toni" width="750" height="500" srcset="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-erinn-westbrook-kj-apa-vanessa-morgan-tabitha-archie-toni.jpg 750w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-erinn-westbrook-kj-apa-vanessa-morgan-tabitha-archie-toni-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-erinn-westbrook-kj-apa-vanessa-morgan-tabitha-archie-toni-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-erinn-westbrook-kj-apa-vanessa-morgan-tabitha-archie-toni-600x400.jpg 600w" sizes="(max-width: 750px) 100vw, 750px" /></p>
<p>I’ll get to it. I’ll get to it! But before any song even breaks out, we get an update on the other stuff. Jughead is still in the Bunker That Hygiene Forgot. The strike is still on, and Archie informs the strikers that the union will be providing living expenses for them. Until that kicks in, though, Tabitha is offering free meals to the workers and their families. It’s a nice gesture that they immediately undercut with the next scene, which opens with Tabitha throwing back some popcorn, the brand of which is made very visible. (They’re not paying ME, so I’m not mentioning them.)</p>
<p>Also, it doesn’t work. While they’re eating at Pop’s, Percival just swans in and mind-pushes them back to work. Operating on the assumption that Percival can’t maintain mind-control over a crowd, Archie, Tabitha, Toni, and other workers’ families show up at the worksite. They then perform “Bread and Roses,” a song that is actually not from the <em>American Psycho</em> musical. It’s an older tune, a political one, and it’s effective.</p>
<p>Now back to the “80s glamfab” thing they’re doing at the casino. The songs are just whatever. Like, no shade to Duncan Sheik or the songs in general. I’m sure they work great in the actual musical. But I’ve got a problem with them here, which I’ll talk about later. We’re going to a convention.</p>
<p>Uhhhhh, it doesn’t work. I mean, they have a convention, but the whole point is to lure in TBK. He does a phone-in during Betty’s live talk, but that’s as close as they get. And then Betty sings a song. She has to do it, incidentally, because she ruined Kevin’s performance and he’s refusing to take the stage. She ruined it, mind you, because she thought TBK was about to attack Kevin. It was actually an in-costume and in-performance Dr. Curdle, Jr. Why am I not front row for that?</p>
<p><img class="aligncenter size-full wp-image-70051" title="Riverdale S06e17: Madelaine Petsch, Camila Mendes and Lili Reinhart as Cheryl, Veronica and Betty" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty.jpg" alt="Riverdale S06e17: Madelaine Petsch, Camila Mendes and Lili Reinhart as Cheryl, Veronica and Betty" width="750" height="500" srcset="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty.jpg 750w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty-600x400.jpg 600w" sizes="(max-width: 750px) 100vw, 750px" /></p>
<p>Finally, I’ve about had it with the ongoing “Betty’s darkness” thing. Ooh, what will she do next? Well, probably nothing. She’s made it this far without going on a killing spree, after all. Sure, she’s killed people, including TBK in this episode, but not out of a drive to do so. So let’s close the lid on this whole “mystery,” please.</p>
<p><strong>6/10 – What a bore. I don’t know any other way to put it, sorry. You’d think a serial killer convention episode would be kind of fun, but the way everyone is split between storylines puts a stop to that. I did like the brief reference to Rivervale, and I hope we revisit that weirdness. Finally, though, a word about the musical episode. I have only one more of these to live through unless they do multiple ones in the final season. (I would not put it past them.) My aforementioned problem with them is that they use other people’s songs, and other people’s stories, which often don’t completely gel with this show’s storyline. If we’re going to do this musical shi…stuff, then it’d be cool if they’d do original songs. Something like <em>Buffy</em>‘s “<a href="https://www.cultofwhatever.com/2022/05/buffy-the-vampire-slayer-every-episode-ranked-part-5-5/" target="_blank" rel="noopener">Once More with Feeling</a>,” for instance. Just a thought, among many.</strong></p>
<img width="750" height="500" src="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty.jpg" class="scriptless__pinterest-image" alt="Riverdale S06e17: Madelaine Petsch, Camila Mendes and Lili Reinhart as Cheryl, Veronica and Betty" data-pin-media="true" style="display:none;" srcset="https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty.jpg 750w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty-300x200.jpg 300w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty-360x240.jpg 360w, https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty-600x400.jpg 600w" sizes="(max-width: 750px) 100vw, 750px" />
</section> 
<footer class="article-footer">
<div class="scriptlesssocialsharing"><h3 class="scriptlesssocialsharing__heading">Share this article:</h3><div class="scriptlesssocialsharing__buttons"><a class="button facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.cultofwhatever.com%2F2022%2F06%2Friverdale-s06e17-review-american-psychos%2F" rel="noopener noreferrer nofollow"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" class="scriptlesssocialsharing__icon facebook" fill="currentcolor" height="1em" width="1em" aria-hidden="true" focusable="false" role="img"><path d="M504 256C504 119 393 8 256 8S8 119 8 256c0 123.78 90.69 226.38 209.25 245V327.69h-63V256h63v-54.64c0-62.15 37-96.48 93.67-96.48 27.14 0 55.52 4.84 55.52 4.84v61h-31.28c-30.8 0-40.41 19.12-40.41 38.73V256h68.78l-11 71.69h-57.78V501C413.31 482.38 504 379.78 504 256z"></path></svg>
<span class="sss-name"><span class="screen-reader-text">Share on </span>Facebook</span></a><a class="button twitter" target="_blank" href="https://twitter.com/intent/tweet?text=Riverdale%20S06E17%20Review%3A%20American%20Psychos%20%E2%80%93%20Bored&amp;url=https%3A%2F%2Fwww.cultofwhatever.com%2F2022%2F06%2Friverdale-s06e17-review-american-psychos%2F&amp;via=cultofwhatever&amp;related=cultofwhatever" rel="noopener noreferrer nofollow"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" class="scriptlesssocialsharing__icon twitter" fill="currentcolor" height="1em" width="1em" aria-hidden="true" focusable="false" role="img"><path d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg>
<span class="sss-name"><span class="screen-reader-text">Share on </span>Twitter</span></a><a class="button pinterest" target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.cultofwhatever.com%2F2022%2F06%2Friverdale-s06e17-review-american-psychos%2F&amp;media=https%3A%2F%2Fwww.cultofwhatever.com%2Fwp-content%2Fuploads%2F2022%2F05%2Friverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty.jpg&amp;description=Riverdale%20throws%20a%20serial%20killer%20convention%2C%20accompanied%20by%20a%20musical%20that%20doesn%27t%20mix%20as%20well%20with%20the%20storyline%20as%20you%20might%20think." rel="noopener noreferrer nofollow" data-pin-no-hover="true" data-pin-custom="true" data-pin-do="skip" data-pin-description="Riverdale throws a serial killer convention, accompanied by a musical that doesn&#39;t mix as well with the storyline as you might think."><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 496 512" class="scriptlesssocialsharing__icon pinterest" fill="currentcolor" height="1em" width="1em" aria-hidden="true" focusable="false" role="img"><path d="M496 256c0 137-111 248-248 248-25.6 0-50.2-3.9-73.4-11.1 10.1-16.5 25.2-43.5 30.8-65 3-11.6 15.4-59 15.4-59 8.1 15.4 31.7 28.5 56.8 28.5 74.8 0 128.7-68.8 128.7-154.3 0-81.9-66.9-143.2-152.9-143.2-107 0-163.9 71.8-163.9 150.1 0 36.4 19.4 81.7 50.3 96.1 4.7 2.2 7.2 1.2 8.3-3.3.8-3.4 5-20.3 6.9-28.1.6-2.5.3-4.7-1.7-7.1-10.1-12.5-18.3-35.3-18.3-56.6 0-54.7 41.4-107.6 112-107.6 60.9 0 103.6 41.5 103.6 100.9 0 67.1-33.9 113.6-78 113.6-24.3 0-42.6-20.1-36.7-44.8 7-29.5 20.5-61.3 20.5-82.6 0-19-10.2-34.9-31.4-34.9-24.9 0-44.9 25.7-44.9 60.2 0 22 7.4 36.8 7.4 36.8s-24.5 103.8-29 123.2c-5 21.4-3 51.6-.9 71.2C65.4 450.9 0 361.1 0 256 0 119 111 8 248 8s248 111 248 248z"></path></svg>
<span class="sss-name"><span class="screen-reader-text">Share on </span>Pinterest</span></a><a class="button reddit" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.cultofwhatever.com%2F2022%2F06%2Friverdale-s06e17-review-american-psychos%2F" rel="noopener noreferrer nofollow"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" class="scriptlesssocialsharing__icon reddit" fill="currentcolor" height="1em" width="1em" aria-hidden="true" focusable="false" role="img"><path d="M440.3 203.5c-15 0-28.2 6.2-37.9 15.9-35.7-24.7-83.8-40.6-137.1-42.3L293 52.3l88.2 19.8c0 21.6 17.6 39.2 39.2 39.2 22 0 39.7-18.1 39.7-39.7s-17.6-39.7-39.7-39.7c-15.4 0-28.7 9.3-35.3 22l-97.4-21.6c-4.9-1.3-9.7 2.2-11 7.1L246.3 177c-52.9 2.2-100.5 18.1-136.3 42.8-9.7-10.1-23.4-16.3-38.4-16.3-55.6 0-73.8 74.6-22.9 100.1-1.8 7.9-2.6 16.3-2.6 24.7 0 83.8 94.4 151.7 210.3 151.7 116.4 0 210.8-67.9 210.8-151.7 0-8.4-.9-17.2-3.1-25.1 49.9-25.6 31.5-99.7-23.8-99.7zM129.4 308.9c0-22 17.6-39.7 39.7-39.7 21.6 0 39.2 17.6 39.2 39.7 0 21.6-17.6 39.2-39.2 39.2-22 .1-39.7-17.6-39.7-39.2zm214.3 93.5c-36.4 36.4-139.1 36.4-175.5 0-4-3.5-4-9.7 0-13.7 3.5-3.5 9.7-3.5 13.2 0 27.8 28.5 120 29 149 0 3.5-3.5 9.7-3.5 13.2 0 4.1 4 4.1 10.2.1 13.7zm-.8-54.2c-21.6 0-39.2-17.6-39.2-39.2 0-22 17.6-39.7 39.2-39.7 22 0 39.7 17.6 39.7 39.7-.1 21.5-17.7 39.2-39.7 39.2z"></path></svg>
<span class="sss-name"><span class="screen-reader-text">Share on </span>Reddit</span></a></div></div><h3>Tags</h3><p class="cb-tags"> <a href="https://www.cultofwhatever.com/tag/riverdale/" rel="tag">Riverdale</a></p><style type="text/css">
                                            .cb-tags a,.category_coded .cb-category a {
                                                background-color:#1a93db!important;
                                             }

                                             .entry-content blockquote:before {
                                                color: #1a93db;
                                             }

                                            .entry-content h1, .entry-content h2, .entry-content h3, .entry-content h4,
    										.entry-content h5, .entry-content h6 {
                                                color: #1a93db;
                                            }

                                             .widget_nav_menu ul li:before, .widget_rss ul li:before, .widget_recent_entries ul li:before, .widget_recent_comments ul li:before, .widget_meta ul li:before, .widget_categories ul li:before, .widget_archive ul li:before, .widget_pages ul li:before, .widget-popular-posts li:before {
                                                color: #1a93db !important;
                                             }

                                             ul.slides {
                                                background-color: #fff;
                                             }
                                             .entry-content ul li:before {
                                                background-color:#1a93db;
                                             }
    										 .entry-content ol li:before {
                                                color:#1a93db;
                                             }
    										 
    										 .entry-content a {
    										    text-decoration: none;
    											color: #333;
    											box-shadow: inset 0 -2px 0 #1a93db;
    											transition: box-shadow .3s ease-out,background-color .3s ease-out;
    											font-weight: 400;
    										}
    										.entry-content a:hover {
    											background-color: rgb(26,147,219);
    											box-shadow: inset 0 -2px 0 rgba(13,190,152,0);
    											text-decoration: none !Important;
    										}
    										.entry-content .color-section {
    											border-color: rgba(26,147,219,0.7);
    											border-width: 2px;
    											border-style: solid;
    											background-color: #f2f3f7;
    											padding: 15px;
    											margin: 20px auto;
    											color: #333;
    										}
    										.cb-article-widget a {
    											background-color: #1a93db;
    										}
                        #cb-content .category_coded {
                          border-top: 3px #1a93db solid;
                          border-bottom: 3px #1a93db solid;
                        }
                        .affiliate_disclaimer a{
                          background-color: #1a93db;
                        }

                                        </style> <div class="adrotate_group_container">
 </div>
</footer> 
</article> 
<div class="clearfix clearfix_width" role="main"> <div id="cb-related-posts" class="clearfix"><h3 style="border-bottom: 4px solid #1a93db;">You might also like</h3><ul>
<li class="no-1">
<div class="cb-mask" style="background-color:#1a93db;"><div class="cb-related-container-img" style="width:600px; height:400px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e16-kj-apa-archie-andrews-600x400.jpg);"></div></div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/05/riverdale-s06e16-review-blue-collar/">Riverdale S06E16 Review: Blue Collar – A new evil…</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-30">May 30, 2022</time></div></div>
</div>
</li>
<li class="no-2">
<div class="cb-mask" style="background-color:#1a93db;"><div class="cb-related-container-img" style="width:600px; height:400px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/05/Riverdale-6-15-3-600x400.jpg);"></div></div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/05/riverdale-s06e15-review-things-that-go-bump-in-the-night/">Riverdale S06E15 Review: Things That Go Bump in the Night – Unexpected allies</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-23">May 23, 2022</time></div></div>
</div>
</li>
<li class="no-3">
<div class="cb-mask" style="background-color:#1a93db;"><div class="cb-related-container-img" style="width:600px; height:400px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/04/riverdale-s06e14-camila-mendes-veronica-lodge-600x400.jpg);"></div></div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/05/riverdale-s06e14-review-venomous/">Riverdale S06E14 Review: Venomous – Spider-Woman?</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-16">May 16, 2022</time></div></div>
</div>
</li>
</ul></div></div>
</div> 
<div class="category_coded">
<h2>FIND THE TOPICS YOU WANT...</h2>
<div class="cb-category cb-byline-element"> <a href="https://www.cultofwhatever.com/tv-topics/" title="View all posts in TV Topics">TV Topics</a></div> </div>
<div class="horizontal_recommended_for_you">
<h3>Recommended for you</h3>
<ul class="cb-light cb-small">
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2022/06/riverdale-s06e17-review-american-psychos/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/05/riverdale-s06e17-madelaine-petsch-camila-mendes-lili-reinhart-cheryl-veronica-betty-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/06/riverdale-s06e17-review-american-psychos/">Riverdale S06E17 Review: American Psychos – Bored</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-18">June 18, 2022</time></div></div> </div>
</li>
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2022/06/star-trek-strange-new-worlds-episodes-6-7-review/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/05/star-trek-strange-new-worlds-s01e06-ian-ho-husein-madhavji-first-servant-elder-gamal-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/06/star-trek-strange-new-worlds-episodes-6-7-review/">Star Trek: Strange New Worlds – Episodes 6-7 review (the best and the not-so best)</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-18">June 18, 2022</time></div></div> </div>
</li>
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2022/06/roswell-new-mexico-s04e01-s04e02-review-steal-my-sunshine-fly/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/05/roswell-new-mexico-s04e01-jeanine-mason-liz-ortecho-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/06/roswell-new-mexico-s04e01-s04e02-review-steal-my-sunshine-fly/">Roswell, New Mexico S04E01 &amp; S04E02 Review: Steal My Sunshine &amp; Fly</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-17">June 17, 2022</time></div></div> </div>
</li>
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2022/06/dark-winds-s01e01-review-monster-slayer/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/05/dark-winds-s01e01-zahn-mcclarnon-joe-leaphorn-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/06/dark-winds-s01e01-review-monster-slayer/">Dark Winds S01E01 Review: Monster Slayer – Great start</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-14">June 14, 2022</time></div></div> </div>
</li>
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2022/06/evil-s03e01-review-the-demon-of-death/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/05/evil-s03e01-team-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/06/evil-s03e01-review-the-demon-of-death/">Evil S03E01 Review: The Demon of Death – Feeling unfulfilled</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-14">June 14, 2022</time></div></div> </div>
</li>
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2022/06/the-orville-s03e01-s03e02-review/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/05/the-orville-s03e01-anne-winters-mark-jackson-ensign-charly-burke-isaac-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/06/the-orville-s03e01-s03e02-review/">The Orville season three review part 1 (episodes 1-2 bring ups and downs)</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-12">June 12, 2022</time></div></div> </div>
</li>
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2022/06/stranger-things-s04-part-1-review/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/05/stranger-things-s04e02-joe-keery-maya-hawke-sadie-sink-gaten-matarazzo-steve-robin-max-dustin-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/06/stranger-things-s04-part-1-review/">Stranger Things S04 Part 1 Review: Almost perfect!</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-06-05">June 5, 2022</time></div></div> </div>
</li>
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2022/05/buffy-the-vampire-slayer-every-episode-ranked-part-5-5/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/03/buffy-the-vampire-slayer-s06e07-sarah-michelle-gellar-summers-5-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/05/buffy-the-vampire-slayer-every-episode-ranked-part-5-5/">Buffy the Vampire Slayer: Every episode ranked! (Part 5/5)</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-30">May 30, 2022</time></div></div> </div>
</li>
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2022/05/the-flight-attendant-s02e08-review-backwards-and-forwards/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/05/the-flight-attendant-s02e08-kaley-cuoco-cheryl-hines-cassie-bowden-dot-karlson-2-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/05/the-flight-attendant-s02e08-review-backwards-and-forwards/">The Flight Attendant S02E08 Review: Backwards and Forwards – A satisfying conclusion</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/salome-g/" class="fn">Salome G</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-27">May 27, 2022</time></div></div> </div>
</li>
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2022/05/star-trek-picard-season-2-not-a-review-but-a-rant/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2022/02/star-trek-picard-s02e04-patrick-stewart-jean-luc-3-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/05/star-trek-picard-season-2-not-a-review-but-a-rant/">Star Trek Picard Season 2 (not a review but a rant)</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/matthew-martin/" class="fn">Matthew Martin</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-05-10">May 10, 2022</time></div></div> </div>
</li>
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2022/03/on-a-scale-of-1-to-really-messed-up-how-well-does-the-boys-translate-to-the-small-screen/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2021/12/the-boys-s01e03-dominique-mcelligott-antony-starr-queen-maeve-homelander-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2022/03/on-a-scale-of-1-to-really-messed-up-how-well-does-the-boys-translate-to-the-small-screen/">On a scale of 1 to really messed up, how well does The Boys translate to the small screen?</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/jason-collins/" class="fn">Jason Collins</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2022-03-15">March 15, 2022</time></div></div> </div>
</li>
<li class="cb-article clearfix">
<div class="cb-mask" style="background-color:#1a93db;">
<a href="https://www.cultofwhatever.com/2021/09/whos-who-we-have-some-ideas-about-the-new-doctor-who/" class="cb-link">
<div class="cb-recommended-container-img" style="width:400px; height:250px;background-image:url(https://www.cultofwhatever.com/wp-content/uploads/2020/02/doctor-who-s12e07-jodie-whittaker-400x250.jpg);"></div> </a>
</div>
<div class="cb-meta">
<h4><a href="https://www.cultofwhatever.com/2021/09/whos-who-we-have-some-ideas-about-the-new-doctor-who/">Who’s Who? We have some ideas about the new Doctor Who</a></h4>
<div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><span>By</span> <a href="https://www.cultofwhatever.com/author/oliver-johnston/" class="fn">Oliver Johnston</a></div><div class="cb-date cb-byline-element"><span>|</span> <time class="" datetime="2021-09-13">September 13, 2021</time></div></div> </div>
</li>
</ul>
</div>
<div class="adrotate_group_container-footer">
 </div>
</div> 
<footer id="cb-footer" class=" wrap" role="contentinfo">
<div id="cb-widgets" class="cb-footer-b cb-footer-wrap wrap clearfix">

</div>
<div class="footer-h-menu">
<div class="menu-info-links-container"><ul id="menu-info-links" class="menu"><li id="menu-item-24197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24197"><a href="https://www.cultofwhatever.com/about-us/">About Us</a></li>
<li id="menu-item-24200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24200"><a href="https://www.cultofwhatever.com/contact/">Contact Us</a></li>
<li id="menu-item-43244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-43244"><a href="https://www.cultofwhatever.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-59190" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59190"><a href="https://www.cultofwhatever.com/affiliate-disclosure/">Affiliate Disclosure</a></li>
<li id="menu-item-24201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24201"><a href="https://www.cultofwhatever.com/cookie-policy/">Cookie Policy and Settings</a></li>
<li id="menu-item-54394" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54394"><a href="https://www.cultofwhatever.com/terms-of-service/">Terms of Use</a></li>
<li id="menu-item-24202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24202"><a href="https://www.cultofwhatever.com/photo-credits/">Photo Credits</a></li>
<li id="menu-item-24390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24390"><a href="https://www.cultofwhatever.com/rss-feeds/">RSS</a></li>
</ul></div> 
</div>
<div class="cb-footer-lower clearfix">
<div class="wrap clearfix">
<div class="cb-copyright">All Cult of Whatever articles, logos, illustrations and graphics are copyright CultOfWhatever.com. All other trademarks, logos and copyrights are the property of their respective owners. © 2021 CultOfWhatever. All Rights Reserved.</div>

<div class="social_icons">
<ul>
<li>
<a href="https://www.facebook.com/cultofwhatever" target="_blank" title="facebook">
<img src="https://www.cultofwhatever.com/wp-content/themes/valenti-child/images/facebook-40.png" alt="facebook" title="facebook" />
</a>
</li>
<li>
<a href="https://twitter.com/cultofwhatever" target="_blank" title="twitter">
<img src="https://www.cultofwhatever.com/wp-content/themes/valenti-child/images/twitter-40.png" alt="twitter" title="twitter" />
</a>
</li>
</ul>
</div>

</div>
</div>
</footer> 
</div> 
</div> 
<span id="cb-overlay"></span>

<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '{your-app-id}',
      cookie     : true,
      xfbml      : true,
      version    : '{api-version}'
    });
      
    FB.AppEvents.logPageView();   
      
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "https://connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>


<script type="text/javascript">
var sc_project=10343041; 
var sc_invisible=1; 
var sc_security="d327d034"; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js" async=""></script>
<noscript><div class="statcounter"><a title="site stats"
href="https://statcounter.com/" target="_blank"><img
class="statcounter"
src="https://c.statcounter.com/10343041/0/d327d034/1/"
alt="site stats"></a></div></noscript>
<noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async="" data-noptimize="1" src="https://www.cultofwhatever.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js?ao_version=2.9.2"></script><script type="text/javascript" id="adrotate-clicktracker-js-extra">
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.cultofwhatever.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js" id="adrotate-clicktracker-js"></script>
<script type="text/javascript" id="ppress-frontend-script-js-extra">
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/www.cultofwhatever.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"413991f0a9","disable_ajax_form":"false"};
/* ]]> */
</script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.1.17" id="ppress-frontend-script-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=13.4.3" id="__ytprefsfitvids__-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/plugins/wpdiscuz-widgets/assets/js/script.min.js?ver=7.0.8" id="wpdiscuz_widgets_comm_vot_script-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/plugins/wpdiscuz-widgets/assets/third-party/slick/slick.min.js?ver=7.0.8" id="wpdiscuz_widgets_slick_script-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/themes/valenti/library/js/cookie.min.js?ver=5.5.4" id="cb-cookie-js"></script>
<script type="text/javascript" id="cb-js-ext-js-extra">
/* <![CDATA[ */
var cbExt = {"cbSS":"on","cbLb":"on"};
/* ]]> */
</script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/themes/valenti-child/library/js/jquery.ext.js?ver=5.5.4" id="cb-js-ext-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1" id="jquery-ui-core-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.12.1" id="jquery-ui-tabs-js"></script>
<script type="text/javascript" id="cb-js-js-extra">
/* <![CDATA[ */
var cbScripts = {"cbUrl":"https:\/\/www.cultofwhatever.com\/wp-admin\/admin-ajax.php","cbPostID":"70037","cbSlider":["600",true,"7000"]};
/* ]]> */
</script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/themes/valenti/library/js/cb-scripts.min.js?ver=5.5.4" id="cb-js-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4" id="imagesloaded-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-includes/js/masonry.min.js?ver=4.2.2" id="masonry-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-content/themes/valenti-child/js/scripts.js" id="theme-script-js"></script>
<script type="text/javascript" src="//www.cultofwhatever.com/wp-includes/js/wp-embed.min.js?ver=5.8.4" id="wp-embed-js"></script>
<script>

jQuery(document).ready(function($)	{
$(window).scroll(function() {    
    var scroll = $(window).scrollTop();

    if (scroll >= 100) {
        $(".stickybar").addClass("cb-stuck");
    } else if( scroll < 50 ) {
        $(".stickybar").removeClass("cb-stuck");
    }
});
});


</script>
<script>
jQuery(document).on('lazyloaded', function(){ let m_container = jQuery( '.masonry-container' ); if ( m_container.length ){ m_container.masonry(); } });
</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="cultofwhatever_com",_audins_did=261200;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.cultofwhatever_com,DomainId.261200" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=0&cb=4', false, [], true, false, true, false);</script></body></html>